Error loading Google Maps page

Greetings experts. This one has me stumped. I have 4 systems running at home. 3 Laptops and one Desktop.

All are running Xp Pro with SP3. A few days ago, I tried to go to google maps:
http://maps.google.com/maps?hl=en&tab=wl

I receieved an error window stating that the web page was unable to be loaded. (I'll try to post the exact wording later as I am at work.)

This happens on all 4 systems. On two systems, I have alternate browsers and the Map Page works with no problem using either Firefox or Opera. Systems have been scanned using Superantispyware (Scheduled scan runs at 2 a.m. each day on every system. They also have Avast! Antivirus running on each system. Each system has Windows Firewall turned on. Settings show that the site is not being blocked. As a check I also ran MBAM on one system and nothing was found. I checked the Gateway to see if somehow a block had been placed. Nothing. I checked the Hosts file. Nothing

Now here's the kicker. Searching for a solution found me this. If I use the following link, I get the web page no problem:
http://maps.google.com/?ie=UTF8&ll=37.0625,-95.677068&spn=57.161276,135.3515

I have tried removing and then setting the default location. Nothing

I will try disabling Avast! and Superantispyware tonight. Have not done that yet. I will try all suggestions after work. Thanks for the help.

Any ideas?
LVL 30
flubbsterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
Tried another User Profile on one of the machines?
johnb6767Commented:
Also, your first link shows me an HTML Parsing error, however the page still loads....Webpage error detailsUser Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; InfoPath.3; Tablet PC 2.0)Timestamp: Wed, 20 Oct 2010 13:31:57 UTCMessage: HTML Parsing Error: Unable to modify the parent container element before the child element is closed (KB927917)Line: 0Char: 0Code: 0URI: http://maps.google.com/maps?hl=en&tab=wl

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
flubbsterAuthor Commented:
Strange. I get no error here at work and none at home. What is interesting also is that at home I get basically a map of the US and some of Canada with the optional link. It is hte same as I should get with just clicking on the Maps link in Google. Here at work, I get most of the entire world with the alternate link.

As far as profiles, each system boots directly into windows using the admin profile.

If you go to www.google.com and then click on Maps, the first link is the web page that is loaded. Interesting that you are seeing an error. I do not se it here at work. Yet at home, it displays the page for a second then errors out, then when the OK is clicked, it goes to a Page not found page.
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

flubbsterAuthor Commented:
Update:

After some more searching, specifically on the Google Forum, it looks like there are a great many people having the same issue as me. There are also many having the same issue as *john6767*, in that the page loads but an error is thrown out.

The concensus is that Google changed something on the web page, and is supposed to be working to fix it. I found a KB from Microsoft that supposedly takes care of the issue. It is listed as a critical security update. Unfortuneately, I am hesitant to install it because there are reports of users not being able to connect to the internet after installing it.

Anyway.....
johnb6767Commented:
No guts no glory!!!!

Whats the KB on it?
flubbsterAuthor Commented:
lol

yeah... I suppose I should do it on my laptop at home. I mess up the wife's or sons and I'm screwed.

The link for the kb is below:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=fc02fc7e-ee85-4377-b54c-012fa60a8c9c&displaylang=en

and... there is another kb, looks like the same thing, just for SP3... supposedly:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c77ee103-7e97-44b2-bbf3-ee9f0de37fed

I'm on my work laptop right now and google maps loads fine. I looked for the update on my system and I can't find it. It seems like it only affects certain systems... and in certain ways. Some don't work at all and some work with an error.

and here is a link to the google maps forum. There are many entries with people reporting the same issue, all starting in the last week or so:
http://www.google.com/support/forum/p/maps/label?lid=3741639227361dcc&hl=en&sort=date

and so it goes....
johnb6767Commented:
Any reason not bumping up to IE8 yet?
flubbsterAuthor Commented:
Applied the kb and still no go...

may just try ie8
flubbsterAuthor Commented:
John,

I appreciate you trying to help me out on this. I took no action and as I hoped, Google fixed the problem on their end.

Please accept the points with my grattitude
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.