Windows SBS 2008 Service Problems

Ben_Locke
Ben_Locke used Ask the Experts™
on
In the office we have a Windows SBS 2008 server, I was doing a log of what was on all our machines in the office when I noticed that this server was not displaying any info in the basic information screen. After a bit of searching I discovered that nearly all of the services that should be running are not running. They are all set to automatic like they should be, if I try to manually start them they just time out and do not start.

I can not look at the network connectivity settings or anything else about the server because the "Diagnostic Policy Service" is one of the services that is not running.

The server also takes about 20 minutes to shut down, hanging a lot on the closing down of the group policies and services.

I also tried to boot from the disc to try and access the repair console but it will not boot from it, set all the BIOS correctly but it continues to ask for a valid boot media. Don't know if this is a separate issue or somehow related.

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Firmin FrederickSenior IT Consultant

Commented:
Hi there - were there any recent changes to the server and is it too late to rebuild the OS?  I only ask because it may be easier to rebuild rather than faultfind at this stage.

This log you were performing did it require an "agent" to be installed on all PCs & server?

Did you do the original installation?  If it's an OEM server there my be install disks to facilitate OS installation, this may or not be the reason why you're failing to boot from disk at the moment.

With all these services failing, is eventlog also failing to start?  If not can you view the event logs and post those flagged red in system and applications?

Author

Commented:
The log was merely filling in a spreadsheet with OS's on etc, so no change was made to the server.

The eventlog seems to be working, these are the two most common errors

Event7001, Service Control Manager Eventlog Provider
       The network list service service depends on Network Location Awareness Service which failed to start because of the following error: The dependency service of group failed to start.

Event 10005 - DistributedCOM
       DCOM got error "1068" attempting to start the service net profm with arguments""in order to run the
server:
       {A47979D2-C419-11D9-A5B4-001185AD2}

Most of the errors that appear in the event log have the same source which is - Service Control Manager Eventlog Provider
Firmin FrederickSenior IT Consultant

Commented:
ok lemme have a google see if  can find sense of this
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Firmin FrederickSenior IT Consultant

Commented:
the quick google I had doesn't give specific solutions but one web page gave me an idea, firstly can you boot into safe mode properly?

If you can then it's a cascade effect whereby one system with many dependencies is failing thereby preventing the others from starting.  If you can boot into safe mode you can disable boot startup items and services to give the main service a chance to start normally.

Now in my reading, one guy thought it may be malware related, this I cannot say for certain because typical malware does not have atypical behavior and most attack systems and files that an admin can use to combat it not systems that would allow a system to get onto the internet for example.

Anyway, safemode or not, you can try using "msconfig" to disable startup items as i explained before.  Pay close attention to things that don't seem importatnt.  In the meantime, I'm going to look at my server and the dependencies because we need to get the root service running so that the others can load.
Firmin FrederickSenior IT Consultant

Commented:
Ok profm must be a third party app or system as there is no reference to it on the net however, the  Network Location Awareness Service is dependent on TCP/IP which is a good start so try this,
  1. if you have the net on the server or if you can get drivers and copy over to the server then get the latest network card drivers for the server.
  2. uninstall the whole network card from device manager and any drivers reboot and then install using the updated drivers.
  3. if that is not a possible scenario try this first:
  4. disable/untick any protocols that are enabled in the network card details that aren't microsoft or TCP/IP related
  5. in TCP/IP make sure you have a static IP address for any netwrok cards in use or disable any that are not in use
  6. reboot and check your services
whoo lol that's long, right let me know how you get on :)

Author

Commented:
Which of the microsoft items and services should I disable?
Firmin FrederickSenior IT Consultant

Commented:
if you're talking about when using msconfig, then you want to focus on the "startup" tab (no point stopping services as they aren't all working anyway!) - you can technically remove everything because no system critical things rely upon "startup" options as depicted in that tab...with the minor exception of antivirus user interfaces.

If you're talking about the netwrok card then ideally only tcp/ip, file and printer sharing, client for microsoft networks, and link layer topology should be enabled (as far as diagnostics is concerned).

Author

Commented:
I disabled all the start up services, when I rebooted a few more of the services seem to run but still not even to close to running all of the one's required, as for the network card solution, I cannot get into the details about the network connect because when I try to open the network window it just hangs and doesn't show anything, I presume this is something to do with the Diagnostic policy service not running or a similar service that prevents it from showing the network connections.
I have managed to get all of the services running again, by doing this -

Boot in safe mode
Run Regedit

The registry entry will be placed in: HKLM\System\CurrentControlSet\Serivces\HTTP

Create a Multi-String Value (also known as reg_multi_sz ) named DependOnService.

Double-click DependOnService and enter CryptSvc as its value.

This fixed all the services and they are know running.

The reason the network connections screen was hanging was because the drivers for the on-board Ethernet adapter weren't installed, after installing them that is now working fine too.
Firmin FrederickSenior IT Consultant

Commented:
fair enough dude good luck o/

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial