Exchange 2007 OWA issue from Internet

Hello

I've just installed a Exchange server 2007 (with SP3) on a server with Windows Server 2008 .
I now try to make work OWA.
Everything is OK from inside the network when I try the URL : https://server.localdomain.loc/owa

Bu nothing work when I try to access to owa from Internet. The URL I try is https://webmail.internetdomain.com/owa 

I've checked that webmail.internetdomain.com dns name is resolved correcly nd returns the public IP address on witch i've made a redirectional NAT to the Exchange server inside the network.

I've also configured the "External URL" to "https://webmail.internetdomain.com/owa" in the properties of owa in the EMC.

So is there any specific configuration to make owa work from Internet ?

Thank's
Yuan38Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sinister_krisCommented:
Can you access it via IP address?
Did you create a DNS A record to the IP address for the OWA?
Yuan38Author Commented:
No I can't access to owa with https://<public-ip-address>/owa from Internet.
Yes, there is a A DNS record : when I do a "nslookup webmail.internetdomain.com " it gives me my public Ip address. So everything seems OK from the DNS side.

thunderheadCommented:
What error do you get when trying externally?

have you opened https in your firewall? (i.e. natted the external ip port 443 to internal 443?)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

ckbhupenCommented:
Have you checked the "Authentication tab" under EMC-> Server Configuration-> Client Access-> Outlook Web Access

If you are using "Standard Authentication", Make sure " Basic Authentication" is ticked. Otherwise use, Forms-Based Authentication.  
Yuan38Author Commented:
With IE the error is : The page cannot be displayed
Yes, everything is OK from the firewall side.

We have just replaced an old Exchange 2003 server by a new server with Exchange 2007. OWA was working perfectly with Exchange 2003. Now the https port is redirected by the firewall to the new server. But it's not working !!
JuusoConnectaCommented:
If your sitting behind a firewall, the firewall is your "face" against internet. owa.yourdomain.com public ip address should be the firewalls public ip address, then set the rules in your firewall to direct / allow the traffic to go against your owa of exchange 2007.

Your MX records ip address is what ? Firewalls or exchange servers  public ip address ?
Yuan38Author Commented:
The problem has been resolved : the issue was on the Firewall !
Sorry for the inconvenience.
JuusoConnectaCommented:
Comments thunderhead and myself stating that the issue is on the firewall, was correct and therefore points should be assigned to the expert comments and not refunded to the user.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.