OpenOffice docs not printing

blueminnow
blueminnow used Ask the Experts™
on
My documents have ceased printing on my HP photosmart Prem-Wb C309n-s (HP0E450A).  Docs from Quickbooks printed fine this morning.  Spreadsheet from Open Office 3.2 is not spooling.  I troubleshot using MS troubleshooter...which resolved an 'issue'.  Still no go.  Turned printer off and on.  Rebooted program.  Did another troubleshoot (can't remember which one) and got message that file "PkgEEF0.cab" was a problem...advised against opening this file as it could be a virus.  Is this an OpenOffice file?  Apparently OpenOffice is the problem as docs from QuickBooks are printing, but not from OpenOffice,.
Thank you.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
maybe a log shot, try to export it to pdf (from openoffice) and then try to print. Does that work?

Author

Commented:
I'm not in the office today, but will give it a go tomorrow.  Thanks.
Unfortunately this could be caused by a myriad of items.  When that is the case, i always like to start by asking what changed?  Many times new software was installed, a program was updated, etc?  If you have installed new software or updated some software, it may have corrupted the OOo installation.  In that cause I would just try to reinstall OOo.

Before doing that, though, I would check a few other things.
1.  Pause the Printer - [Start Menu >> Printers OR Start Menu >> Control Panel >> Printers.  Then double click on your printer.  In the Printer Menu, choose Pause Printer]  Leave this window open.
2.  Now try and Print from Open Office.
3.  Go back to the printer window from step 1.  Does the OOo document show here?  If so, then the problem is with your printer or printer driver.  Try re-installing the driver.  If nothing shows here, then the problem is most likely in OOo.

Looking at OOo
1.  In Calc view the printer setting.  File >> Printer Settings.  Make sure the correct printer is selected
2.  Go File >> Preview.  Does anything show here?  If not, then you have not selected anything to print.  If something does show, then I would try re-installing OOo
3.  If you have nothing to print go to Format >> Print Ranges and make sure you have something to print

Trying jvuz idea is good also and that will provide some more information as to where the problem may be.  Please try these items and let us know what you find.

-Bear

Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Author

Commented:
Hi Bear,

I just got back into the office after a long delay.  Opened OO and tried printing.  It worked.  However, the spooled document from 9 days ago shows up as "sent to printer" under status, but this does not print.  

What is Calc?  When I do a print preview the doc shows.  But that is today, with no problems encountered yet.

What is jvuz?  Sorry for my ignorance.

I have not opened any other programs yet, but have a sneaking suspicion that QuickBooks may be causing the problem.  Will be opening and working in QB shortly, and will post results.

Thanks again.
QB may be causing your problem then, if the document did print.  In the print queue I would delete that old document.  

Calc is Open Offices' spreadsheet program.  You mentioned you were trying to print a spreadsheet from Open Office so that lead me to believe you were using Calc.  (You should see OpenOffice.org Calc in the top title bar)

jvuz is the user who posted the original suggestion.

Delete that old document in the print queue.  Open QuickBooks and try to print.  If it prints fine Open OOo Calc again and try to print from there.  If it does not printer, see what is in the print queue.  If OOo does not print, then I would like to know which program was installed last QB or OOo.  

Let me know what you come up with.

Author

Commented:
I'm out of the office for the next week or so.  Schedule is erratic because of medical issues.

QB was installed after OOo.

Will delete old spooled docs and try again.  If no problems, then maybe it was a glitch?  "PkgEEF0.cab" is a cabinet file that was cited in the original error message.

Thanks for your patience.
Kathy

Author

Commented:
QB does seem to be causing the problem, but I can't pinpoint why.  The printer itself is a pain in the neck.  Which is surprising as HP has always had good printers up to this point.  I'm going to chalk up the issue to QB and printer idiot-syncracies and just keep OOo and QB open at different times.  Thanks so much for your help!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial