Linking Access to Visual Studio 2008

faunnab
faunnab used Ask the Experts™
on
I am so frustrated with Visual Studio 2008!  There never seems to be a quick and "easy" way to do anything with this program!  

I have been using Access for years and have some pretty complex databases.  But it is now time for me to make them web based.

I would like to link a very very simple access database with Visual Studio 2008.  I keep getting errors!  I cannot create an AccessDataSource

I have read on EE that access needs to be 2003.  So, I resaved the database from 2007 to 2003 (it's a simple database, so no issue on this) . . .This did not solve my problem

Then I read on EE that I need to make sure I have correct security rights ("Everyone" needs full access)  which we do

Then I read on EE that I need to add the path/file name to JetOLEDB: System Database

I also read to install/change the IIS . . but I have no idea what to do.  I have IIS on my web server but I think that's all . . .eek!

I keep getting the same error (actually when I add the path to JetOLEDB, I get different errors

Here is my error . . ."Cannot start your application.  The workgroup information file is missing or opened exclusively by another user"  which it isn't. . .

Please Please Please. . . help me!  I really do not know Visual Studio at all and I am trying to learn it, but I can't even get past the first step!

Here is what I am doing  . .

Tools
Connect to Database
DataSource: MICROSOFT ACCESS DATABASE FILE (OLE DB)
DatabaseFileName: \\fileserver\reports\suppluchain\supplychainmgntweb.mdb
Log on to the database:  I have tried my admin, SA and windows logon and passwords . . .

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
"The Microsoft Jet Database engine cannot open the file '<PathToFile>'. It is already opened exclusively by another user, or you need permissions to view it's data" Error
This error is typically caused when there are not enough file system permissions for either the folder in which the database resides, or for the database file itself. Users accessing your pages must have at least read, write, create, and delete permissions to work with the .ldb file that is created by the Microsoft Jet database engine.

These links will help you solve your problem.
http://support.microsoft.com/kb/300699
http://support.microsoft.com/kb/823913
Top Expert 2010

Commented:
Check here for proper connection string:
http://www.connectionstrings.com/access

Author

Commented:
NormanMaina:  I'm the system administrator.  I did read that on EE, but I have full access (and doublechecked after I searched through EE.)

Zhaolai: I will take a look.
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Author

Commented:
Zhaolai - I'm sorry, I don't know where to put this code in my project.  I assume in the aspx.vb but I'm not sure where.

this is the current error I am getting.  I have the access database in my server explorer now.  

" It is an error to use a section registered as allowdefinition='machinetoapplication' beyond application level . . '

also, when I try to edit the data in the web page program (as a user would) I get a security error as well.  I assume they are related.

thx
Top Expert 2010

Commented:
How do you bind the access db, in design time or in the code?
If in the code, you must have a connection string for the connection object.

Author

Commented:
I added it in design time (I think)  It was not in the code (I don't know how to do that : )

I added it in Server Explorer under connections.  Then I added an accessdatabase connection though the toolbox and then added a datagrid.

I am able to run the program, when I go to edit and update data in my datagrid, I get the attached error.




errormessage.jpg

Author

Commented:
I was able to look at the error further and here is where the error is . . .

            <authentication mode="Windows"/>

Author

Commented:
Norman may be correct too on my issue, but when I read through the website links he gave me, I don't have any idea which issue is mine, and how to change it.  I went through each section and I cannot find the menu picks I need. . .eek!
Ho Faunnab:

This link explains common data access deployment errors - including your error:
http://support.microsoft.com/kb/300699

Your error is "Cannot start your application. The workgroup information file is missing or opened exclusively by another user"

description:
This error message occurs when a data access page cannot find the workgroup information file (.mdw). When you are using two-tier deployment, make sure that you put the workgroup file in a shared folder along with the database. Change the connection on the page to use the UNC path to the workgroup file as follows:

The solution provided is:
   1. Start Microsoft Access, and then open the data access page that you are deploying in Design view.
   2. Right-click the page, and then click Page Properties.
   3. On the Data tab, click the Build (...) button to the right of the ConnectionString property.
   4. On the All tab, change the Jet OLEDB:System database property to the UNC location for the workgroup file.

Also try setting up the DSN by running:
%WINDIR%\System32\odbcad32.exe

How to:
http://hodentekhelp.blogspot.com/2008/09/how-do-you-create-odbc-dsn-for.html

Author

Commented:
thank you!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial