Why my page is prompting for credential?

Hi,

I have a classic ASP site on IIS 6. A SSL certificate is applied to the site but only couple of pages uses the SSL and those pages are now prompting for credentials.

I checked the following:
1. Directory and IUSR has full control
3. In IIS is set to use anonymous access

Any direction is appreciated. Thanks,
hackman122Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

F IgorDeveloperCommented:
Check if the IIS configuration applies to all "applications" listed,
or check if your app is using some different security configuration.

What kind of "credentials" are prompting
(HTTP-Authentication or a certificate request?)

hackman122Author Commented:
Check if the IIS configuration applies to all "applications" listed,

Did you mean application pool? There are two application pool with same setup.

or check if your app is using some different security configuration.

I can get in with my AD account. I saw a different message with safari, it says:
To view this page, you must log in to area "www.mysite.com" on www.mysite.com:443

The site uses "Host header value" of mysite.com and has following setup under site>Properties>Advance (Web site identification):
Multiple identities for this web site
----------------------------------------------
192.168.10.18     80  
Default                80       mysite.com

Multiple SSL identities for this Web site
-----------------------------------------------
Default                          443

I am mentioning this because some one suggested, when it come to 80 server knows what to do and when the request comes to 443, it comes encrypted and now the server does not know what to do.
Is this a correct statement?

Does this clear anything?

Any direction is appreciated.

Thanks,
tanujchandnaCommented:
Hi,

Use the following Header values in IIS

192.168.10.18     80   mysite.com
192.168.10.18     80  www. mysite.com
192.168.10.18     443  

2. Inherit user permission in wwwroot directory.

3. point the following DNS A records for your website

mysite.com A 192.168.10.18
www.mysite.com A 192.168.10.18

It should resolves the issue for you.
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

tanujchandnaCommented:
Hi,

Have you tried my solution, Is it works for you?
FreakyEddieCommented:
Turn off 'use client certificate'

It's probably prompting for a client certificate.
tanujchandnaCommented:
Hi,

Waiting for your update.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hackman122Author Commented:
aaa
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.