Save As Issues in Excel 2003 (only)

kangiser
kangiser used Ask the Experts™
on
Excel 2003 is extremely slow to open the Save As dialog box when saving from a website.

Test Machine:
Clean install Windows XP SP3
No antivirus
No Firewall
Not on Domain
No mapped (network) drives
Internet Explorer 7
Connect to hosted PeopleSoft application over the Internet (HTTPS)

Run PeopleSoft report to Excel format, Open the file in Excel, directly from PeopleSoft and then select Save As to save a copy to your computer (local C: drive):
Excel 2000 – Save As dialog box comes up in under 2 second
Excel 2010 - Save As dialog box comes up in under 2 second
Excel 2003 – Save As dialog box takes about 30 seconds to open

With report still open in Excel, unplug the network connection, go to File -> Save As and Excel 2003 opens the Save As dialog box in about 2 seconds.
It appears Excel 2003 has to check back in with the web server, if available, before it will open the Save As dialog box.

Thoughts?

Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
If I remember correctly, Office 2003 originally was set to save to the same place it originated from. In this case the web server that generated the Excel file. There were updates to it that corrected this and then pointed to the documents on the C drive. of course if I remember corectly. But I think it went something like that.

Author

Commented:
Thanks mdpowell71 for the quick response.

 I did see some posts where there were patches for network drives that were not available and for save as issues with some HP products installed but nothing that matches my particular issue.

It’s probably related to this KB article http://support.microsoft.com/?kbid=838028 but no solutions are mentioned.
Commented:
I figured it out.
I ran RegMon (sysinternals) while doing the save-as and after about 2 seconds I stopped collecting data. I searched the RegMon window for “save” and found a missing value “AlwaysSaveToCurrentPath”

HKCU\Software\Microsoft\Office\11.0\Excel\Options\AlwaysSaveToCurrentPath

I added the DWORD and gave it a value of 0 and that didn’t help. I gave it a value of 1 and the save-as dialog appears instantly.

Author

Commented:
Figured it out myself

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial