Get rid of security warning in IE using https

hubfub
hubfub used Ask the Experts™
on
I have a website that uses https for the shopping cart.

Now SSL has been set up correctly but I get the following message:

This webpage contains content that will not be delivered using a secure HTTPS connection, which could compromise the security of the entire webpage.

How do I get rid of it?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2011
Top Expert 2011

Commented:

Put it in your Trusted Sites, should probably make the error go away....

Author

Commented:
yes, but I want this to apply for everybody.. even people who havnet added the website to their trusted sites.
Most Valuable Expert 2011
Top Expert 2011

Commented:
Ah.....

Come to think of it, thats not the standard warning form IE, regarding secure~~>Insecure directions....

Can you please post a screenshot?
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

Author

Commented:
It comes up in a pop up and says:
Security Warning
Do you want to view only the webpage content that can be delivered securely?
This webpage contains content that will not be delivered using a secure HTTPS connection, which could compromise the security of the entire webpage.
 
Then there is a yes or no button.

Sorry I cant get the message to show up again.

Author

Commented:
I own the website and just need to know what kind of changes I need to make to code or file structure to fix this.
Most Valuable Expert 2011
Top Expert 2011
Commented:
"You receive the warning "You are about to be redirected to a connection that is not secure." in Internet Explorer 6 Service Pack 1"
http://support.microsoft.com/kb/883740

I think the verbage has changed for later versions of IE, just cant picture it. The setting is the same thats referenced though.  You might have checked "Do not ask me again", hence why you cannot make the message appear again. If you can see if it is unchecked?

Author

Commented:
I;ve fixed it myself.. was because some images were still using http:// as opposed to https:

Author

Commented:
partial answer
Most Valuable Expert 2011
Top Expert 2011

Commented:
Glad you fixed it....

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial