Active Directory Domain Services

bmic
bmic used Ask the Experts™
on
I have a 2008 R2 Server running exchange 2010. i have 3 service that will not start and i can't figure out why. the services are Active Directory Domain services, Intersite messaging service, and Kerberos Key Distribution center service. All the depend services are running but these 3 will not start. I think that something in the registry is either missing or corrupt. i need to get these started as soon as possible. Not sure how theses service not running will effect the endusers. email seems to be running but when i get into the console i have limited access so i know that it is effecting the right that the administrator account has.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Adrian CantrillSolutions Architect

Commented:
Can you show us any entries in the event logs from when you try and start the ADDS service ?

Author

Commented:
There is nothing in the event view for the adds services bit there is for the other two
Adrian CantrillSolutions Architect

Commented:
Can you paste ? We need to be able to see the errors when each of the services try and start.
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Below is the two errors i get when i try to start the 3 services. As i said earlier i don't get one for the ADDS service which is weird. i get one for the other two but not ADDS. So in the text file i have the intersite and the kerberos error

Log Name:      System
Source:        Service Control Manager
Date:          10/21/2010 10:07:31 AM
Event ID:      7001
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Exchange2010.bensonsd.local
Description:
The Kerberos Key Distribution Center service depends on the Active Directory Domain Services service which failed to start because of the following error:
The operation completed successfully.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7001</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2010-10-21T17:07:31.267895000Z" />
    <EventRecordID>40637</EventRecordID>
    <Correlation />
    <Execution ProcessID="532" ThreadID="7492" />
    <Channel>System</Channel>
    <Computer>Exchange2010.bensonsd.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Kerberos Key Distribution Center</Data>
    <Data Name="param2">Active Directory Domain Services</Data>
    <Data Name="param3">%%0</Data>
  </EventData>
</Event>





Log Name:      System
Source:        Service Control Manager
Date:          10/21/2010 10:07:23 AM
Event ID:      7001
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Exchange2010.bensonsd.local
Description:
The Intersite Messaging service depends on the Active Directory Domain Services service which failed to start because of the following error:
The operation completed successfully.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7001</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2010-10-21T17:07:23.793895000Z" />
    <EventRecordID>40635</EventRecordID>
    <Correlation />
    <Execution ProcessID="532" ThreadID="7492" />
    <Channel>System</Channel>
    <Computer>Exchange2010.bensonsd.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Intersite Messaging</Data>
    <Data Name="param2">Active Directory Domain Services</Data>
    <Data Name="param3">%%0</Data>
  </EventData>
</Event>








Adrian CantrillSolutions Architect

Commented:
ok so both have AD-DS as dependencies.. thats why they wont start. What happens when you try and start AD-DS ?

Author

Commented:
i was told that those services that i listed are not suppose to run on and exchange 2010 server as per Microsoft.
Adrian CantrillSolutions Architect

Commented:
> i was told that those services that i listed are not suppose to run on and exchange 2010 server as per Microsoft.

now im confused - your original post said that those services weren't running and you wanted them too ? what problems are you actually experiencing on the server?

Author

Commented:
After calling and talking to Microsoft i was told that those services were not suppose to run on the exchange server if it is not a domain controller and it isn't. The problem that i was having was that i could not get to everything that i was suppose to as a administrator in the exchange console. we found out that it was a permission problem. So the issue  has been resolved. Thanks again for your help...

Author

Commented:
After calling and talking to Microsoft i was told that those services were not suppose to run on the exchange server if it is not a domain controller and it isn't. The problem that i was having was that i could not get to everything that i was suppose to as a administrator in the exchange console. we found out that it was a permission problem. So the issue  has been resolved. Thanks again for your help...
Solutions Architect
Commented:
Ahh ok.. sorry i didnt get that bit (exchange console) from your original post..entirely my bad. I was looking into the wrong issues as a result. Glad you got it sorted in the end.

Author

Commented:
Got it resolved from Microsoft, but the input from woolnoir was helpful. Thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial