We help IT Professionals succeed at work.
Get Started

Remote Desktop service just stopped working

3,337 Views
Last Modified: 2013-12-19
I have a Windows 2003 R2 server with SP2 that used to run Remote Desktop just
fine. We rebooted one of them yesterday and after the reboot, Remote Desktop doesn't work anymore.

1. The server does not have any firewalls (windows or third party) running
2. netstat -an, port 3389 doesn't show up.
3. When I check the services, terminal services is running, but cannot be stopped or started (a know, that's impossible)
4. I deleted and tried recreating the rdp connection under "Terminal Services Configuration" but it did not help.
5. I had checked the registry and port 3389 is configured to be listen
6. I am sure Remote Desktop is checked in the Remote property
7. "RDP-Tcp (listener)" does not show up under the "Terminal Services Manager"
8. I have restarted the server many times.
9. Event logs does not shows any errors about the RDP service

Any suggestion?
Comment
Watch Question
This problem has been solved!
Unlock 1 Answer and 16 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE