Suse 11.1 ISPConfig MyDNS service will not start at boot.

I am having a very hard time with this ISP config install.  MyDNS service will not start at boot.  It start fine after that but will not start when the machine boots.  I need to get this working.

Inside of /etc/init.d/rc3.d/  I have tried to reorder the services so MySQL starts first and it still does not.  I can see it starts next to last at the boot screen.  

I have read around and seen that others have had this problem, Its like there is another service assigning priority to the system and it has nothing to do with the init scripts.  

Any ideas will be helpful.

Thanks
larspankyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BlazCommented:
1. How did you reorder the services in /etc/init.d/rc3.d/?
2. Are you using runlevel 3 or are you using level 5?
3. Are the reordering changes seen in the /etc/init.d/rc3.d/ folder after reboot?

The thing is that insserv program reorders all services according to their headers (on which service another service depends).

If I understand you correctly you want to run a specific service (MyDNS) after MySQL is already running. Then you should edit the MyDNS startup script and add dependency:
# Required-Start: $mysql
or just use $ALL

http://yourlinuxguy.com/?p=41
larspankyAuthor Commented:
That had no effect at all.  I think its a suse thing, Ill be using redhat moving forward.  

It appears that SUSE starts services in alpha numeric order no matter what.  

I did get the services to start in the correct order my renaming the link from mydns to zmydns and it looks like its working.  

Is there any rupple effect I should know about doing this, or will this work around work out.  I want to be sure that no other scripts are going to look for the mydns link.

Thanks

larspankyAuthor Commented:
and:
1. How did you reorder the services in /etc/init.d/rc3.d/?
2. Are you using runlevel 3 or are you using level 5?
3. Are the reordering changes seen in the /etc/init.d/rc3.d/ folder after reboot?

1.  Yes that is where I tried to reorder them.  Changing S11mydns to S99mydns.
2.  I changed it in both rc3 and rc5, but I am running in runlevel 3.
3.  Yes the changes are present after reboot.

I looked around it seems that this is a problem for many running SUSE.

Thank You
larspankyAuthor Commented:
It turns out that SUSE starts processes in Alpha Numeric order.  I changed the  mydns link to Zmydns and set it in services.  (chkconfig) That solved the problem.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
larspankyAuthor Commented:
Stumbled across an answer that worked for me.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux OS Dev

From novice to tech pro — start learning today.