?
Solved

ASP.NET 4, Cookies problem

Posted on 2010-11-07
13
Medium Priority
?
368 Views
Last Modified: 2012-05-10
0
Comment
Question by:evo_x
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
13 Comments
 
LVL 25

Expert Comment

by:Rouchie
ID: 34086030
Because when you navigate through your site from http://www.mobivel.com that's what the links on the page are showing as the destination URL's
0
 
LVL 2

Author Comment

by:evo_x
ID: 34086086
but I have set the cookies to files instead of URL from web.config
0
 
LVL 25

Expert Comment

by:Rouchie
ID: 34086206
Have you just uploaded a new version, because after clearing my browser cache and loading up your site again, the links are all working fine for me?

The only other issue (from an SEO perspective) is that your list of car manufacturers using a linkbutton that posts back, so the URL (for Acura) is
   javascript:__doPostBack('ctl00$Main$CategoryBrowser$TopCategoryList$ctl00$NestedSubCategoryRepeater$ctl01$SubCategoryButton','')

when it should really be just:

http://www.mobivel.com/Search.aspx?c=111

which Google will natively follow.  For ASP.NET 4.0, you should be using Routes to create really friendly SEO URLS like this:

http://www.mobivel.com/cars/acura

See here for the tutorial:
http://weblogs.asp.net/scottgu/archive/2009/10/13/url-routing-with-asp-net-4-web-forms-vs-2010-and-net-4-0-series.aspx
0
What is a Denial of Service (DoS)?

A DoS is a malicious attempt to prevent the normal operation of a computer system. You may frequently see the terms 'DDoS' (Distributed Denial of Service) and 'DoS' used interchangeably, but there are some subtle differences.

 
LVL 2

Author Comment

by:evo_x
ID: 34086280
No, I have not uploaded a newer version, it is the same.
I already use routes for Ad pages
Thanks for the tips, I have used that tutorial when I have implemented the routes :)
0
 
LVL 25

Expert Comment

by:Rouchie
ID: 34091001
If the pages are now being referenced correctly in the URL's (which it appears they are), then it will take Google (usually) around a couple of weeks to re-index your site and correct itself.
0
 
LVL 2

Author Comment

by:evo_x
ID: 34091936
I have made this change 2 months ago, and I have added new pages to the website which were still indexed by google with that cookie in the URL :(
0
 
LVL 25

Expert Comment

by:Rouchie
ID: 34091970
In addition to checking your site using its spidering method, it will also check additional links that it has in its database to see whether they're still active.  Because your site still accepts the cookie-style format of URL, then its including them in addition to the other format.
I'm not entirely sure how to stop ASP.NET accepting the previous (cookie) format without seeing your web.config file.
0
 
LVL 2

Author Comment

by:evo_x
ID: 34093117
This is my web.config file
0
 
LVL 2

Author Comment

by:evo_x
ID: 34093128
sorry, I forgot to attach it.
webconfig.zip
0
 
LVL 25

Expert Comment

by:Rouchie
ID: 34093648
cookieless="UseCookies" in the web.config file was what I was hoping to see.  I notice however that your site is still processing the original URL containing the cookie data.  Is it possible for you to restart IIS or the web site?  That would kill the sessions which are being resumed.

Also, try setting regenerateExpiredSessionId="False" in the anonymousIdentification part of web.config.  That should stop the previous URL's working when the sessions have been removed from the server
0
 
LVL 2

Author Comment

by:evo_x
ID: 34093668
this web.config file is 3 months old, and the server was restarted since then, almost every 2-3 days.
0
 
LVL 25

Accepted Solution

by:
Rouchie earned 2000 total points
ID: 34093853
Okay then regenerateExpiredSessionId="False"  is what you'll need.
0
 
LVL 2

Author Comment

by:evo_x
ID: 34095456
ok, thanks ! I hope it will work :)
0

Featured Post

Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question