Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 921
  • Last Modified:

Windows SBS 2008 not updating

Hi,

I am running a SBS 2008 at present.  I cannot run any microsoft updates at all.

When attempting to run windows update or microsoft update I get error 80072EFD.  I looked into this as much as I could and there seemed to be a DCOM error and the resolution was simply to restart, this made no difference.

Cheers
0
Lawrie Gormley
Asked:
Lawrie Gormley
  • 4
  • 2
  • 2
1 Solution
 
hatkindCommented:
It can means that your sbs server can't connect to Microsoft updates site.
Do you use any firewall?
0
 
JBond2010Commented:
It sounds like your Windows Update cache has been corrupted.

See http://support.microsoft.com/kb/971058/en-us for instructions and a Microsoft fix-it widget.
0
 
JBond2010Commented:
Start run oobe
Select Configure Windows Firewall
Choose advanced settings
Choose windows firewall properties
Make sure firewall state is off for domain profile, private and public

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
JBond2010Commented:
Looked at the Windows Update log file, located at C:\Windows\WindowsUpdate.log.
0
 
Lawrie GormleyAuthor Commented:
Hi guys,

The Microsoft Fix-It widget made no difference.  The server is one of three all running with no windows firewall activated and sophos antivirus.  The same configuration is on all 3 servers and the other 2 update with no errors at all.

The Windows update.log is attached.
WindowsUpdate.log
0
 
JBond2010Commented:
I presume your not using WSUS? That was a red flag to me immediately. Edit the default domain policy as follows:

Computer Configuration >> Administrative Templates >> Windows Components >> Windows Updates >> "Specify intranet Microsoft update service location".  It was set to "Not configured".

Set it to disabled, and then reboot your Server.
0
 
hatkindCommented:
If you really not using WSUS try do that suggest JBond2010.

But if you use WSUS try do next:

 - stop Automatic Update and BITS service
 - remove all files and folders in C:\Windows\SoftwareDistribution
 - start Automatic Update and BITS service
 - run wuauclt /resetauthorization /detectnow
0
 
Lawrie GormleyAuthor Commented:
Seems on completing this it allowed me update windows update and then start installing further updates!!  

Cheers :)
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now