• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1142
  • Last Modified:

Remote desktop permissions - Windows 7.

I enabled remote desktop access in my domain using group policies. Desktop computers running windows 7 accept connections only for administrators by default. I manually opened remote desktop settings and added a security group allowed to login. Everything works fine - but when I reboot a desktop computer the allowed users list is empty.

Is there any way to:
a) Add allowed users using GPO?
b) Prevent this settings from being deleted after reboot?
0
psalkiew
Asked:
psalkiew
1 Solution
 
Netman66Commented:
Yes.

For this solution, you want to use Restricted Users.

Group your workstations into an OU (the Computers container is not an OU).
Create and link a new GPO to this OU.
Proceed as follows:

1) Expand Computer Configuration>Windows Settings>Security Settings>Restricted Groups
2) Right click Restricted Groups in the left pane and select Add Group.
3) Browse to your Security group in the domain that you want to add to the Remote Desktop Users group.  Press OK.
4) In the LOWER section of the next applet (This group is a member of), press the Add button.
5) Manually type in the local group name, Remote Desktop Users and press OK.
6) Press Apply then OK (or just OK).
7) Close group policy editor.

Make sure the GPO is linked and it should begin to apply after a reboot or two.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now