Solved

Unable to setup BIS Email

Posted on 2010-11-08
18
1,018 Views
Last Modified: 2012-05-10
Hi all

This one is driving me up the wall!

Scenario:

Company 1
Company 2
Both in the same office, but different subnets so in effect totally seperate.

Both on SBS 2003 Std, with OWA confirmed as working. No SSL is used.

The BB's in question are used for either Company 1 or 2, and are under the same Carrier Contract.

All BB's set up for Company 2 work straight away, it only goes as far as asking for the email and password (I dont need to choose "I will provide extra settings" as  normally do)

Company 1 however - The same error message every time. "Cannot log in. Verify your email address, user name and password. If the error persists, contact company1domain.co.uk"

I have called the carrier who insists there is nothing wrong their end, and I'm entitled to believe them because phones used for Company 2 work.

I have opened IIS and compared settings between the 2 servers and they are identical.

Not a firewall issue - all traffic has been allowed outbound for testing.

OWA works, mailboxe names triple checked.

Also tried changing AD Alias' to match mailbox name (although this wasnt needed on Company 2)

Complete loss as to what to check next. This isnt the first time I have set up BB's for BIS, and I am 100% the details are correct.

Help!
0
Comment
Question by:hongedit
  • 10
  • 8
18 Comments
 
LVL 25

Expert Comment

by:Tony1044
ID: 34083694
What happens if you try and set up on your carrier's BIS website?
Why not consider throwing in BES Express? That way you get two way synch of all the folders for free (just no OTA activation - needs to be wifi in the office or over a web portal by you or the end user).
0
 
LVL 1

Author Comment

by:hongedit
ID: 34083716
I am currently getting one of the users to allow web site login for their BB so I can test.

I would consider BES Express as a last option I guess, but I really want to get BIS working. Also some users are using their own personal blackberries, I dont know if that affects anything.

0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34083738
Re BES Express: It's quite annoying to set up but once it is, it works like a charm.
Re Personal BlackBerries - shouldn't make any difference except something that's just sprung to mind: The users it is failing for don't have a policy applied from the operator that blocks BIS by any chance? Might be worthwhile asking a slightly different question to them along the lines of "Does this account include BIS?" ?
0
 
LVL 1

Author Comment

by:hongedit
ID: 34083802
I have already checked that unfortunately.

In fact, the first time I rang O2, they told me BIS wasnt even activated on the account and that is why it was not working. But now it is, and it still isnt working (for 1 company).

The users with personal BB#s are able to ue them for their own personal accounts (Yahoo or whatever). And they can set up a Company 2 email account fine as well - which leaves just one culprit.

However, I have no idea what to check next.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34084207
The only other thing I can think of is service books - have you tried getting O2 to resend them?
The O2 BIS Portal is below:
https://bis.eu.blackberry.com/html?brand=o2mailuk 
You should be able to send them from there.
0
 
LVL 1

Author Comment

by:hongedit
ID: 34084230
Can service books be resent from the phone?

I am still trying to get one of the users to set up their phone to allow web management, but it seems they have all gone to lunch!
0
 
LVL 1

Author Comment

by:hongedit
ID: 34084241
Would Service Books really be a viable culprit if they can get the BB's working on the other server no probs?

Seems to me like I am missing something on the server itself.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34084272
No it could be the service books - they're required for BIS too.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34084279
If you set up one of the failing handsets from the link above, it should resend the required books too (usually).
Worth a try and see if mails start flowing.
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 1

Author Comment

by:hongedit
ID: 34084452
I will try this, as soon as one of them gets back to me.

But if they can set their phones up for the other SBS Server no probs, then can it still be service books.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34084558
Sorry - I didn't realise that! I thought it was a case of handsets at company 2 not working full stop.
So if I have it right now(?) any handset can connect to company 1's OWA via BIS but company 2 handsets cannot connect to company 2's OWA via BIS?
When you log onto OWA for either company, there's no URL redirection going on is there? They both have the same path?
 
0
 
LVL 1

Author Comment

by:hongedit
ID: 34084632
I think you have it half right!

Company 1 and Company 2 are sister companies. As far as IT goes, they are seperate.

The BB's howeever are ALL registered under Company 1, but some are used (solely) for Company 2. As in, the bills all go to Company 1.

Now, every phone can sync up with OWA on Company 2. However no phones can sync up with Company 1.

There are 2 personal BB's thrown in the mix also, but they are also experiecning the same problem.

Everything leads to the Company 1 server. In terms of config, both servers are practically identical.

There is no redirection going on. Just straight http access, i.e http://mail.company.com/exchange

Still stuck!
0
 
LVL 1

Author Comment

by:hongedit
ID: 34084739
Same error when trying from the O2 web page.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34084741
Hmm how odd.
Would these be of any relevance?
http://www.blackberry.com/btsc/microsites/search.do?cmd=displayKC&docType=kc&externalId=KB02858&sliceId=1&docTypeID=DT_SUPPORTISSUE_1_1&dialogID=203226847&stateId=1 0 203222769#1
Particularly the bit about bad username or password?
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 34084773
Also there are points about requiring WebDAV on Exchange 2003 and not being supported behing ISA server.
0
 
LVL 1

Author Comment

by:hongedit
ID: 34085225
Well here's an update.

Between my last post and popping out for 15 mins, somethng has changed.

When navigating to the OWA address now, my user authentication is not working for some users, but ok for others.

The BIS web page now displays the error of not being able to contact the URL.

Grr.

WOuld resetting my IIS vdirs be an idea?

Something isnt right.

No idea what WebDAV is, and no ISA server.
0
 
LVL 1

Accepted Solution

by:
hongedit earned 0 total points
ID: 34085601
Well, solved apparently.

Again, nothing changed on the server.

I set up a dummy user to test with. Worked 1st go.

Then went back and tried the others, and they started working.

No idea how or why...still blame O2.
0
 
LVL 1

Author Closing Comment

by:hongedit
ID: 34126655
Fingers crossed it stays fixed!
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Find out what Office 365 Transport Rules are, how they work and their limitations managing Office 365 signatures.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now