Solved

Cisco CME 3 connect to external SIP (BroadVoice)

Posted on 2010-11-08
9
1,643 Views
Last Modified: 2012-06-27
Experts,

I've tried a lot of different forums / postings about configuring my CME router (2621xm) to BroadVoice's SIP as an external provider.

I can't get it to work to save my life.

Could somebody help me decifer these logs?  I apologize in advance, as I'm not a voice guy at all.

Debugs listed below:  Which is me trying to call 1-800-call-att as a test.  *I've blanked out my own number for posting here on EE.

The phone spews back (it's a 7960) "unknown number" and I can't make any calls.  Any help you guys can provide would be amazing.

Also, when trying to call from the outside in, BroadVoice is telling me that the number isn't available, which probably means its an authentication issue.  But I honestly have no idea.
Nov  8 13:12:15.830: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:18002255288@sip.broadvoice.com:5060 SIP/2.0
Via: SIP/2.0/UDP  10.0.0.1:5060;branch=z9hG4bK2E7F15B9
From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=6285694-B75
To: <sip:18002255288@sip.broadvoice.com>
Date: Mon, 08 Nov 2010 13:12:15 GMT
Call-ID: A3A78EF4-EA7011DF-842C8459-742B7999@10.0.0.1
Supported: 100rel,timer,replaces
Min-SE:  1800
Cisco-Guid: 2699266280-3933213151-2217313369-1949006233
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1289221935
Contact: <sip:1##########@10.0.0.1:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 294

v=0
o=CiscoSystemsSIP-GW-UserAgent 4922 6209 IN IP4 10.0.0.1
s=SIP Call
c=IN IP4 10.0.0.1
t=0 0
m=audio 17166 RTP/AVP 0 8 18 101
c=IN IP4 10.0.0.1
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16

Nov  8 13:12:16.070: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Call-ID: A3A78EF4-EA7011DF-842C8459-742B7999@10.0.0.1
CSeq: 101 INVITE
From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=6285694-B75
To: <sip:18002255288@sip.broadvoice.com>
Via: SIP/2.0/UDP 10.0.0.1:5060;branch=z9hG4bK2E7F15B9
Content-Length:    0



Nov  8 13:12:16.074: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Call-ID: A3A78EF4-EA7011DF-842C8459-742B7999@10.0.0.1
CSeq: 101 INVITE
From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=6285694-B75
To: <sip:18002255288@sip.broadvoice.com>;tag=vwxy
Via: SIP/2.0/UDP 10.0.0.1:5060;branch=z9hG4bK2E7F15B9
Allow-Events: telephone-event
User-Agent: Cisco-SIPGateway/IOS-12.x
Content-Length:  251
Content-Type: application/sdp

v=0
o=167772161 4922 6209 IN IP4 10.0.0.1
s=-
c=IN IP4 10.0.0.1
t=0 0
m=audio 17166 RTP/AVP 0 8 18 101
c=
USSOK2621A#IN IP4 10.0.0.1
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000

Nov  8 13:12:16.094: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:18002255288@sip.broadvoice.com:5060 SIP/2.0
Via: SIP/2.0/UDP  10.0.0.1:5060;branch=z9hG4bK2E7F15B9
From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=6285694-B75
To: <sip:18002255288@sip.broadvoice.com>;tag=vwxy
Date: Mon, 08 Nov 2010 13:12:15 GMT
Call-ID: A3A78EF4-EA7011DF-842C8459-742B7999@10.0.0.1
Max-Forwards: 70
CSeq: 101 ACK
Content-Length: 0

Open in new window

0
Comment
Question by:usslindstrom
  • 7
  • 2
9 Comments
 
LVL 5

Author Comment

by:usslindstrom
ID: 34083877
As a side note, I'm getting these messages alot too.

It appears it's trying to register all my ephone's I have defined:

Nov  8 13:24:52.438: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 406 Not Acceptable
Call-ID: 59D11EAB-EA5811DF-83688459-742B7999
CSeq: 94 REGISTER
From: "1001" <sip:1001@sip.broadvoice.com>;tag=633E120-1DB
To: "1001" <sip:1001@sip.broadvoice.com>
Via: SIP/2.0/UDP 10.0.0.1:5060;branch=z9hG4bK2ED51564
Contact: <sip:1001@10.0.0.1:5060>
Expires: 3600
User-Agent: Cisco-SIPGateway/IOS-12.x
Content-Length:    0
0
 
LVL 6

Expert Comment

by:mark_06
ID: 34084035
The problem is your getting 403 Forbidden, this is most likely because your not authenticated.

Can you please post your config and I can have a look at the setup of the SIP trunk and auth setup (you can remove passwords etc).

Your getting the second error you posted because CME is trying to register your ephone-dn's with the SIP trunk. You need to add 'no-reg primary' after each number in your ephone-dn config
e.g.
ephone-dn 1
number 1001 no-reg primary

Note do this to all ephone-dn's that aren't supposed to register with the BroadVoice service.
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 34089104
Here is the current *scrubbed* config.

Thanks for helping.

*I just noticed that my translation rules were messed up on my interface...  I'll fix that when I get back at work.


!

! Last configuration change at 22:07:16 JST Mon Nov 8 2010 by *****

! NVRAM config last updated at 22:28:47 JST Mon Nov 8 2010 by *****

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname *****

!

boot-start-marker

boot system flash:c2600-advipservicesk9-mz.124-25b.bin

boot-end-marker

!

enable secret 5 $1$E4ch$.Og1VaWiGak3ucojxiILq0

!

aaa new-model

!

!

aaa group server radius *****

 server 10.0.226.251 auth-port 1645 acct-port 1646

 server 10.0.226.252 auth-port 1645 acct-port 1646

!

aaa group server radius *****

 server 10.0.2.251 auth-port 1645 acct-port 1646

 server 10.0.2.252 auth-port 1645 acct-port 1646

!

aaa group server radius *****

 server 10.0.12.251 auth-port 1645 acct-port 1646

 server 10.0.12.252 auth-port 1645 acct-port 1646

!

aaa authentication login ***** group ***** local

aaa authorization network default if-authenticated 

!

aaa session-id common

clock timezone *****

ip cef

!

!

!

!

ip domain name *****.com

ip host sip.broadvoice.com 147.135.20.221

ip host lax.broadvoice.com 147.135.8.128

ip host dca.broadvoice.com 147.135.0.128

ip host mia.broadvoice.com 147.135.4.128

ip host atl.broadvoice.com 147.135.28.128

ip host chi.broadvoice.com 147.135.12.221

ip host bos.broadvoice.com 147.135.32.221

ip host nyc.broadvoice.com 147.135.20.221

ip name-server *****

ip name-server *****

ip multicast-routing 

ip inspect max-incomplete low 500

ip inspect max-incomplete high 700

ip inspect one-minute low 400

ip inspect one-minute high 400

ip inspect udp idle-time 120

ip inspect dns-timeout 3

ip inspect tcp idle-time 360

ip inspect tcp synwait-time 15

ip inspect name *****_FW tcp

ip inspect name *****_FW udp

ip inspect name *****_FW icmp

ip inspect name *****_FW ftp

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

voice rtp send-recv

!

voice service voip 

 allow-connections h323 to h323

 allow-connections h323 to sip

 allow-connections sip to h323

 allow-connections sip to sip

 redirect ip2ip

 h323

 sip

  bind control source-interface FastEthernet0/0

  bind media source-interface FastEthernet0/0

  registrar server expires max 3600 min 3600

!

!

!

voice class codec 1

 codec preference 1 g711ulaw

 codec preference 2 g711alaw

 codec preference 3 g729r8

!

!

!

!

!

!

!

!

voice source-group *****_InboundSIP

 access-list 1

!

voice translation-rule 1

 rule 1 /.+/ /*****/

!

voice translation-rule 2

 rule 1 /^99\(.*\)/ /\1/

!

!

voice translation-profile BroadVoice

 translate calling 1

 translate called 2

!

!

!

!

!

application

  service CME_AA flash://its-CISCO.2.0.1.0.tcl

  param operator 1999

  paramspace english language en

  paramspace english index 0

  paramspace english location flash://

  paramspace english prefix en

  param aa-pilot 5999

  !

!

username ***** privilege 15 secret *****

username ***** privilege 15 secret *****

archive

 log config

  hidekeys

!

!

!

class-map match-any P2P

 match protocol edonkey

 match protocol gnutella

 match protocol kazaa2

 match protocol winmx

class-map match-all VoiceOverIPSignaling

 match ip dscp af31 

class-map match-all VoiceOverIP

 match ip dscp ef 

 match protocol sip

 match protocol skinny

!

!

policy-map VoiceOverIPPolicy

 class VoiceOverIP

  priority percent 10

 class VoiceOverIPSignaling

  bandwidth percent 2

 class class-default

  fair-queue

policy-map Drop_P2P

 class P2P

   drop

!

! 

!

crypto isakmp policy 1

 encr aes 256

 hash md5

 authentication pre-share

 group 2

crypto isakmp key ***** address *****

crypto isakmp keepalive 10

!

!

crypto ipsec transform-set ESP-AES esp-aes 256 

!

crypto map *****_VPNMap 1 ipsec-isakmp 

 description ***** VPN --> ***** VPN

 set peer *****

 set security-association lifetime seconds 86400

 set transform-set ESP-AES 

 set pfs group2

 match address *****_VPNTraffic

!

!

!

!

interface Loopback1

 ip address 172.16.0.1 255.255.255.255

 ip ospf authentication message-digest

 ip ospf message-digest-key 1 md5 *****

 ip ospf 1 area 0

!

interface Tunnel1

 ip address 172.16.0.209 255.255.255.252

 ip nat inside

 ip virtual-reassembly

 ip ospf authentication message-digest

 ip ospf authentication-key *****

 ip ospf mtu-ignore

 ip ospf 1 area 0

 keepalive 5 3

 tunnel source Dialer1

 tunnel destination *****

 crypto map *****_VPNMap

!

interface FastEthernet0/0

 description ***** Fa0/0 --> ***** Fa0/3 (10.0.0.0/23)

 ip address 10.0.0.1 255.255.254.0

 ip nbar protocol-discovery

 ip nat inside

 ip virtual-reassembly

 ip ospf authentication message-digest

 ip ospf message-digest-key 1 md5 *****

 speed 100

 full-duplex

 service-policy input Drop_P2P

!

interface FastEthernet0/1

 description ***** Fa0/1 --> ***** ISP Equipment

 no ip address

 no ip redirects

 no ip unreachables

 no ip proxy-arp

 ip virtual-reassembly

 no ip mroute-cache

 speed 100

 half-duplex

 pppoe enable group global

 pppoe-client dial-pool-number 1

!

interface Dialer1

 description ***** Dialer1 --> ***** WAN (ISP)

 mtu 1424

 bandwidth 100000

 ip address negotiated

 no ip unreachables

 ip nbar protocol-discovery

 ip nat outside

 ip inspect *****_FW out

 ip virtual-reassembly

 encapsulation ppp

 ip tcp adjust-mss 1396

 no ip mroute-cache

 dialer pool 1

 dialer-group 1

 no cdp enable

 ppp authentication chap pap callin

 ppp chap hostname *****

 ppp chap password *****

 ppp pap sent-username ***** password *****

 ppp ipcp route default

 crypto map *****_VPNMap

 service-policy output VoiceOverIPPolicy

!

router ospf 1

 router-id 10.0.0.1

 log-adjacency-changes

 area 0 authentication message-digest

 summary-address 10.0.0.0 255.255.240.0

 summary-address 10.0.224.0 255.255.240.0

 redistribute static subnets

 passive-interface default

 no passive-interface FastEthernet0/0

 no passive-interface Tunnel1

 network 10.0.0.0 0.0.15.255 area 0

 network 172.16.0.209 0.0.0.0 area 0

 default-information originate

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip dns server

!

ip http server

no ip http secure-server

ip http path flash:

ip nat inside source list *****_NAT interface Dialer1 overload

ip nat inside source static tcp 10.0.2.221 143 interface Dialer1 143

ip nat inside source static tcp 10.0.2.221 110 interface Dialer1 110

ip nat inside source static tcp 10.0.2.221 80 interface Dialer1 80

ip nat inside source static udp 10.0.2.221 20 interface Dialer1 20

ip nat inside source static tcp 10.0.2.221 20 interface Dialer1 20

ip nat inside source static tcp 10.0.2.221 21 interface Dialer1 21

ip nat inside source static udp 10.0.2.221 21 interface Dialer1 21

ip nat inside source static tcp 10.0.2.221 8081 interface Dialer1 8081

ip nat inside source static udp 10.0.2.221 8081 interface Dialer1 8081

ip nat inside source static tcp 10.0.210.221 8443 interface Dialer1 8443

ip nat inside source static tcp 10.0.210.221 8453 interface Dialer1 8453

ip nat inside source static tcp 10.0.210.221 8400 interface Dialer1 8400

ip nat inside source static tcp 10.0.210.221 8401 interface Dialer1 8401

ip nat inside source static tcp 10.0.210.221 8402 interface Dialer1 8402

ip nat inside source static tcp 10.0.210.221 8403 interface Dialer1 8403

ip nat inside source static tcp 10.0.210.221 8404 interface Dialer1 8404

ip nat inside source static tcp 10.0.210.221 8405 interface Dialer1 8405

ip nat inside source static tcp 10.0.210.221 8406 interface Dialer1 8406

ip nat inside source static tcp 10.0.210.221 8407 interface Dialer1 8407

ip nat inside source static tcp 10.0.210.221 8408 interface Dialer1 8408

ip nat inside source static tcp 10.0.210.221 8409 interface Dialer1 8409

ip nat inside source static tcp 10.0.210.221 8410 interface Dialer1 8410

ip nat inside source static tcp 10.0.210.221 5356 interface Dialer1 5356

ip nat inside source static tcp 10.0.2.221 443 interface Dialer1 443

ip nat inside source static tcp 10.0.210.221 8411 interface Dialer1 8411

ip nat inside source static tcp 10.0.210.221 8412 interface Dialer1 8412

ip nat inside source static tcp 10.0.210.221 8413 interface Dialer1 8413

ip nat inside source static tcp 10.0.210.221 8414 interface Dialer1 8414

ip nat inside source static tcp 10.0.210.221 8415 interface Dialer1 8415

ip nat inside source static tcp 10.0.210.221 8416 interface Dialer1 8416

ip nat inside source static tcp 10.0.210.221 8417 interface Dialer1 8417

ip nat inside source static tcp 10.0.210.221 8418 interface Dialer1 8418

ip nat inside source static tcp 10.0.210.221 8419 interface Dialer1 8419

ip nat inside source static tcp 10.0.210.221 8420 interface Dialer1 8420

ip nat inside source static tcp 10.0.0.6 25 interface Dialer1 25

!

ip access-list extended *****_NAT

 deny   ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255

 deny   ip 10.0.0.0 0.0.255.255 172.16.0.0 0.0.255.255

 deny   ip 172.16.0.0 0.0.255.255 10.0.0.0 0.0.255.255

 deny   ip 172.16.0.0 0.0.255.255 172.16.0.0 0.0.255.255

 permit ip 10.0.0.0 0.0.255.255 any

 permit ip 172.16.0.0 0.0.255.255 any

ip access-list extended *****_SplitTunnel

 permit ip 10.0.0.0 0.0.15.255 10.0.12.0 0.0.1.255

 permit ip 10.0.224.0 0.0.15.255 10.0.12.0 0.0.1.255

ip access-list extended *****_VPNTraffic

 permit ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255

 permit icmp 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255

 permit gre host ***** host *****

!

access-list 1 permit 147.135.28.128

access-list 1 permit 147.135.4.128

access-list 1 permit 147.135.0.128

access-list 1 permit 147.135.8.128

access-list 1 permit 147.135.12.221

access-list 1 permit 147.135.20.221

access-list 1 permit 147.135.32.221

access-list 1 permit 10.0.0.0 0.255.255.255

access-list 1 permit 172.16.0.0 0.0.255.255

access-list 1 deny   any log

snmp-server community public RO

!

!

tftp-server flash:P00307020200.bin alias P00307020200.bin

tftp-server flash:P00307020200.loads alias P00307020200.loads

tftp-server flash:P00307020200.sb2 alias P00307020200.sb2

tftp-server flash:P00307020200.sbn alias P00307020200.sbn

tftp-server flash:Analog1.raw alias Analog1.raw

tftp-server flash:Analog2.raw alias Analog2.raw

tftp-server flash:AreYouThere.raw alias AreYouThere.raw

tftp-server flash:AreYouThereF.raw alias AreYouThereF.raw

tftp-server flash:Bass.raw alias Bass.raw

tftp-server flash:CallBack.raw alias CallBack.raw

tftp-server flash:Chime.raw alias Chime.raw

tftp-server flash:Classic1.raw alias Classic1.raw

tftp-server flash:Classic2.raw alias Classic2.raw

tftp-server flash:ClockShop.raw alias ClockShop.raw

tftp-server flash:DistinctiveRingList.xml alias DistinctiveRingList.xml

tftp-server flash:Drums1.raw alias Drums1.raw

tftp-server flash:Drums2.raw alias Drums2.raw

tftp-server flash:FilmScore.raw alias FilmScore.raw

tftp-server flash:HarpSynth.raw alias HarpSynth.raw

tftp-server flash:Jamaica.raw alias Jamaica.raw

tftp-server flash:KotoEffect.raw alias KotoEffect.raw

tftp-server flash:MusicBox.raw alias MusicBox.raw

tftp-server flash:Piano1.raw alias Piano1.raw

tftp-server flash:Piano2.raw alias Piano2.raw

tftp-server flash:Pop.raw alias Pop.raw

tftp-server flash:Pulse1.raw alias Pulse1.raw

tftp-server flash:Ring1.raw alias Ring1.raw

tftp-server flash:Ring2.raw alias Ring2.raw

tftp-server flash:Ring3.raw alias Ring3.raw

tftp-server flash:Ring4.raw alias Ring4.raw

tftp-server flash:Ring5.raw alias Ring5.raw

tftp-server flash:Ring6.raw alias Ring6.raw

tftp-server flash:Ring7.raw alias Ring7.raw

tftp-server flash:RingList.xml alias RingList.xml

tftp-server flash:Sax1.raw alias Sax1.raw

tftp-server flash:Sax2.raw alias Sax2.raw

tftp-server flash:Vibe.raw alias Vibe.raw

tftp-server flash:cmterm_7920.4.0-02-00.bin alias cmterm_7920.4.0-02-00.bin

radius-server host ***** auth-port 1645 acct-port 1646 key *****

radius-server host ***** auth-port 1645 acct-port 1646 key *****

radius-server host ***** auth-port 1645 acct-port 1646 key *****

radius-server host ***** auth-port 1645 acct-port 1646 key *****

radius-server host ***** auth-port 1645 acct-port 1646 key *****

radius-server host ***** auth-port 1645 acct-port 1646 key *****

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

 supervisory disconnect dualtone mid-call

 pre-dial-delay 0

 cptone *****

 timeouts call-disconnect 1

 timeouts ringing 45

 timeouts wait-release 2

 connection plar 5999

!

voice-port 1/1/1

!

ccm-manager music-on-hold

!

mgcp

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

mgcp behavior g729-variants static-pt

!

!

!

dial-peer voice 1 voip

 destination-pattern 1...

 session target ipv4:10.0.0.1

!

dial-peer voice 2 voip

 destination-pattern 2...

 session target ipv4:10.0.208.1

!

dial-peer voice 99 pots

 destination-pattern 0T

 port 1/1/0

 forward-digits all

!

dial-peer voice 5999 voip

 service cme_aa

 destination-pattern 5999

 session target ipv4:172.16.0.1

 incoming called-number 5999

 dtmf-relay h245-alphanumeric

 codec g711ulaw

 no vad

!

dial-peer voice 5000 voip

 description ***** --> ***** UM

 destination-pattern 5000

 session protocol sipv2

 session target ipv4:10.0.2.241

 session transport tcp

 dtmf-relay rtp-nte

 codec g711ulaw

 fax rate disable

 fax protocol pass-through g711ulaw

 no vad

!

dial-peer voice 9999 voip

 description ***** --> ***** UM

 destination-pattern 9999

 session protocol sipv2

 session target ipv4:10.0.2.241

 session transport tcp

 dtmf-relay rtp-nte

 codec g711ulaw

 fax rate disable

 fax protocol pass-through g711ulaw

 no vad

!

dial-peer voice 100 voip

 description ***** --> BroadVoice SIP

 translation-profile outgoing BroadVoice

 destination-pattern 991..........

 voice-class codec 1

 session protocol sipv2

 session target dns:sip.broadvoice.com

 dtmf-relay rtp-nte

 ip qos dscp cs5 media

 ip qos dscp cs4 signaling

 no vad

!

dial-peer voice 8994210 voip

 description BroadVoice SIP --> ***** (Inbound Calls)

 translation-profile incoming BroadVoice-In

 session protocol sipv2

 session target sip-server

 incoming called-number *****

 dtmf-relay rtp-nte

 codec g711ulaw

 fax protocol pass-through g711ulaw

 ip qos dscp cs5 media

 ip qos dscp cs4 signaling

 no vad

!

sip-ua 

 authentication username ***** password *****

 no remote-party-id

 retry invite 4

 retry response 3

 retry bye 2

 retry cancel 2

 retry register 3

 timers register 250

 mwi-server dns:sip.broadvoice.com expires 3600 port 5060 transport udp unsolicited

 registrar dns:sip.broadvoice.com expires 3600

!

!

!

!

telephony-service

 load 7960-7940 P00307020200

 load 7920 cmterm_7920.4.0-02-00

 max-ephones 24

 max-dn 48

 ip source-address 10.0.0.1 port 2000

 service phone displayIdleTimeout 00:30

 service phone displayOnDuration 1:00

 timeouts interdigit 2

 system message *****.com

 url services http://phone-xml.berbee.com/menu.xml

 time-zone 44

 time-format 24

 create cnf-files version-stamp 7960 Sep 24 2010 18:03:15

 voicemail 5000

 max-conferences 4 gain -6

 call-forward pattern ....

 moh music-on-hold.au

 web admin system name admin secret *****

 dn-webedit 

 transfer-system full-consult

 transfer-pattern ....

 secondary-dialtone 99

 after-hours block pattern 1 1900....... 7-24

 after-hours block pattern 2 0990...... 7-24

 directory entry 2 ***** name ***** Cell

 directory entry 1 ***** name ***** Cell

!

!

ephone-template  1

 softkeys idle  Redial Newcall Pickup Cfwdall Dnd

 softkeys seized  Redial Endcall Cfwdall Pickup Gpickup

 softkeys alerting  Endcall Callback

 softkeys connected  Hold Confrn Flash Park Trnsfer

!

!

ephone-dn  1  dual-line

 call-waiting ring

 number 1009

 pickup-group 1

 label *****

 description *****

 name Server Room

 call-forward busy 5000

 call-forward noan 5000 timeout 18

!

!

ephone-dn  2  dual-line

 call-waiting ring

 number 1001

 pickup-group 1

 label *****

 description *****

 name *****

 call-forward busy 5000

 call-forward noan 5000 timeout 18

!

!

ephone-dn  3  dual-line

 call-waiting ring

 number 2001

 pickup-group 2

 label *****

 description *****

 name *****

 call-forward busy 5000

 call-forward noan 5000 timeout 18

!

!

ephone-dn  4  dual-line

 call-waiting ring

 number 1002

 pickup-group 1

 label *****

 description *****

 name *****

 call-forward busy 5000

 call-forward noan 5000 timeout 18

!

!

ephone-dn  5  dual-line

 call-waiting ring

 number 2002

 pickup-group 2

 label *****

 description *****

 name *****

 call-forward busy 5000

 call-forward noan 5000 timeout 18

!

!

ephone-dn  9

 number 9999

 paging ip 239.1.1.100 port 2000

!

!

ephone-dn  10

 number 1999

 call-forward busy 5000

 call-forward noan 5000 timeout 18

!

!

ephone-dn  11

 number 2999

!

!

ephone-dn  40

 number 5001

 park-slot timeout 90 limit 3

!

!

ephone-dn  41

 number 5002

 park-slot timeout 90 limit 3

!

!

ephone-dn  42

 number 5003

 park-slot timeout 90 limit 3

!

!

ephone-dn  47

 number A2

 intercom A1 barge-in no-mute label "*****"

!

!

ephone-dn  48

 number A1

 intercom A2 barge-in no-mute label "*****"

!

!

ephone  1

 description *****

 ephone-template 1

 mac-address *****

 paging-dn 9

 type 7960

 keep-conference

 button  1o1,10 6:47

!

!

!

ephone  2

 description *****

 ephone-template 1

 mac-address *****

 paging-dn 9

 type 7960

 keep-conference

 button  1o2,10

!

!

!

ephone  3

 description *****

 ephone-template 1

 mac-address *****

 paging-dn 9

 type 7960

 keep-conference

 button  1o3,11

!

!

!

ephone  4

 description *****

 ephone-template 1

 mac-address *****

 paging-dn 9

 type 7960

 button  1o4,10 6:48

!

!

!

ephone  5

 description *****

 ephone-template 1

 mac-address *****

 paging-dn 9

 type 7920

 button  1o4,10

!

!

!

ephone  6

 description *****

 ephone-template 1

 mac-address *****

 type 7920

 button  1o5,11

!

!

banner motd 

*************************************************************

************  Unauthorized Access is Prohibited  ************

*************************************************************



  Access to this system is for the use of authorized

  personel only.



  You are hereby advised that all actions performed are

  subject to monitoring and are being recorded.  In the

  event of any possible criminal activity, evidence will

  be turned over to proper Law Enforcement personnel,

  and offenders will be prosecuted!



  You have accessed:  $(hostname).$(domain)



*************************************************************

************  Unauthorized Access is Prohibited  ************

*************************************************************



!

line con 0

 privilege level 15

 logging synchronous

 login authentication *****

line aux 0

 logging synchronous

 login authentication *****

line vty 0 4

 logging synchronous

 login authentication *****

line vty 5 181

 logging synchronous

 login authentication *****

!

ntp clock-period 17180412

ntp master

ntp server *****

!

end

Open in new window

0
 
LVL 5

Author Comment

by:usslindstrom
ID: 34089224
I'll put the no-reg primary under the configuration on each e-phone.

But on that same note:  "Note do this to all ephone-dn's that aren't supposed to register with the BroadVoice service."

What I'd like to do, is not register any of the internal phones, and use the BroadVoice in the same manner as I have the FXO port configured.  Basically, if it's available, any internal caller can press 99 to get the BroadVoice line, etc.  *On the FXO port, I'm just forwarding all digits, that side is in Japan.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 6

Accepted Solution

by:
mark_06 earned 500 total points
ID: 34089343
Unfortunately you have to put the no-reg primary on all of your ephone-dn's then.

Try changing as follows:

dial-peer voice 100 voip
 description ***** --> BroadVoice SIP
 translation-profile outgoing BroadVoice
 destination-pattern 991..........
 voice-class codec 1
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad

sip-ua
 credentials username ********* password ********* realm sip.broadvoice.com
 authentication username ***** password *****
 no remote-party-id
 retry invite 4
 retry response 3
 retry bye 2
 retry cancel 2
 retry register 3
 timers register 250
 mwi-server dns:sip.broadvoice.com expires 3600 port 5060 transport udp unsolicited
 registrar dns:sip.broadvoice.com expires 3600
 sip-server dns:sip.broadvoice.com
 host-register
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 34090256
Thank you for the advice.

I saw the "credentials" command in a previous post on one of the forums, but unfortunately my IOS does not have that command available.

I will look further into this when I get at work.
0
 
LVL 5

Author Comment

by:usslindstrom
ID: 34091139
I've made the appropriate changes that you suggested...

Thank you very much for the help.

But, unfortunately, my IOS (c2600-adventerprisek9-mz.124-18.bin) doesn't have these two commands under the SIP-UA configuaration:

credentials username ********* password ********* realm sip.broadvoice.com
or
host-register




And here's another stack of text for an attempted call to 1-800-call-att

Nov  9 08:49:25.940: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

INVITE sip:18002255288@sip.broadvoice.com:5060 SIP/2.0

Via: SIP/2.0/UDP  10.0.0.1:5060;branch=z9hG4bK441942

From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=14AB10-FE3

To: <sip:18002255288@sip.broadvoice.com>

Date: Tue, 09 Nov 2010 08:49:25 GMT

Call-ID: 16E53F23-EB1511DF-8035E3BF-A6D7C8F5@10.0.0.1

Supported: 100rel,timer,replaces

Min-SE:  1800

Cisco-Guid: 342960915-3944026591-2150818751-2799159541

User-Agent: Cisco-SIPGateway/IOS-12.x

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE NOTIFY, INFO, UPDATE, REGISTER

CSeq: 101 INVITE

Max-Forwards: 70

Timestamp: 1289292565

Contact: <sip:1##########@10.0.0.1:5060>

Expires: 180

Allow-Events: telephone-event

Content-Type: application/sdp

Content-Length: 294



v=0

o=CiscoSystemsSIP-GW-UserAgent 6647 6715 IN IP4 10.0.0.1

s=SIP Call

c=IN IP4 10.0.0.1

t=0 0

m=audio 16744 RTP/AVP 0 8 18 101

c=IN IP4 10.0.0.1

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16



Nov  9 08:49:26.184: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 100 Trying

Call-ID: 16E53F23-EB1511DF-8035E3BF-A6D7C8F5@10.0.0.1

CSeq: 101 INVITE

From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=14AB10-FE3

To: <sip:18002255288@sip.broadvoice.com>

Via: SIP/2.0/UDP 10.0.0.1:5060;branch=z9hG4bK441942

Content-Length:    0







Nov  9 08:49:26.188: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 403 Forbidden

Call-ID: 16E53F23-EB1511DF-8035E3BF-A6D7C8F5@10.0.0.1

CSeq: 101 INVITE

From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=14AB10-FE3

To: <sip:18002255288@sip.broadvoice.com>;tag=npyz

Via: SIP/2.0/UDP 10.0.0.1:5060;branch=z9hG4bK441942

Allow-Events: telephone-event

User-Agent: Cisco-SIPGateway/IOS-12.x

Content-Length:  251

Content-Type: application/sdp



v=0

o=167772161 6647 6715 IN IP4 10.0.0.1

s=-

c=IN IP4 10.0.0.1

t=0 0

m=audio 16744 RTP/AVP 0 8 18 101

c=IN

USSOK2621A#IP4 10.0.0.1

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:101 telephone-event/8000



Nov  9 08:49:26.212: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

ACK sip:18002255288@sip.broadvoice.com:5060 SIP/2.0

Via: SIP/2.0/UDP  10.0.0.1:5060;branch=z9hG4bK441942

From: "Server Room" <sip:1##########@sip.broadvoice.com>;tag=14AB10-FE3

To: <sip:18002255288@sip.broadvoice.com>;tag=npyz

Date: Tue, 09 Nov 2010 08:49:25 GMT

Call-ID: 16E53F23-EB1511DF-8035E3BF-A6D7C8F5@10.0.0.1

Max-Forwards: 70

CSeq: 101 ACK

Content-Length: 0

Open in new window

0
 
LVL 5

Author Comment

by:usslindstrom
ID: 34091184
On a side note,

Here is the configuration given from BroadVoice (scrubbed):

Given that, is the configuration for authentication what could be causing this?
outbound_proxy_server: proxy-nyc.broadvoice.com

proxy_port: 5060

registrar_server: sip.broadvoice.com registrar_port: 5060 phone_number: XXXXXXXXXX

auth_id: XXXXXXXXXX

auth_password: XXXXXXXXXX

ntp_ip: ntp.broadvoice.com

DTMF: rfc2833 if available, fail over to InBand if rfc2833 not supported

Open in new window

0
 
LVL 5

Author Closing Comment

by:usslindstrom
ID: 34101162
Upgrading the IOS to a T release had those commands, and the system successfully registered to BroadVoice once it had the new configuration.

I'm experiencing an new issue however, with absolutley no audio coming through.  But that's a question for another Exp Exch topic.

Thanks for the assistance here.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now