Avatar of j8547
j8547 asked on

Ubuntu 10.10 Server - Network config

I am totally new to linux so picking up everything on the net. I just installed ubuntu server 10.10 (maverick meerkat) on a test server. I am having problems setting the network connections.  I continue to get the error 'unable to resolve host.....'.

Any ideas on what to do or can oyu point me in step by step documentation. Thanks for all the help
Linux NetworkingLinuxLinux Distributions

Avatar of undefined
Last Comment
netcmh

8/22/2022 - Mon
netcmh

If you have a dhcp server:

    sudo vi /etc/network/interfaces

    # The primary network interface - use DHCP to find our address
    auto eth0
    iface eth0 inet dhcp

Otherwise:

    udo vi /etc/network/interfaces

    # The primary network interface

    auto eth0
    iface eth0 inet static
    address 192.168.1.90
    gateway 192.168.1.1
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255

netcmh

of course you have restart networking

sudo /etc/init.d/networking restart
netcmh

Setup DNS

    sudo vi /etc/resolv.conf

and enter the following details

    search test.com
    nameserver 192.168.1.2

or whatever your dns server's IP is
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
netcmh

Or if you wanted gui, then step by steps are here

http://computingtech.blogspot.com/2008/07/how-to-use-ubuntu-linux-network.html
ASKER
j8547


I did have a static ip address but everytime I try and restart I get the error. I changed to dhcp and I still get the error.

Error is

unable to resolve host xxx.xx.xx.x /etc/init.d/hostname restart
/etc.init.d/networking: command not found
ASKER
j8547

Also when i try to restart the hostname I get:
script you are attempting to invoke has been converted to an upstart job.....

????
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
j8547

Also just to add. I can go to network and view all pc's on the domain, so my pc is connected but I can't get on the internet or seem to install software as it cannot connect.

A bit lost as to where I am
balasundaram_s

Please check whether the network card is identified and loaded into the memory 'lspci' command.
ASKER
j8547

yes it looks like it is
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
netcmh

ASKER
j8547

Both sound like my issue as in not resolving hostname. I checked the first link and both my hosts file and hostname file look correct. As for the bug, im not sure. I have done all updates. You said earlier about the gui and I have seen it on the net but I don't have the 'Network' option under System-Administration-Network.....

I have no clue where to go from here. totally lost.

Thanks for all your help so far
ASKER
j8547

Could it be anything on my windows server side that I need to do
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
j8547

Restarting the networking is working since i rebooted. but still don't know where to go. I cannot get onto internet so something still wrong
ASKER
j8547

AHHHH!!!!

I can ping the gateway and another pc on the network from the ubuntu server. Does this not suggust all is working. But I still cannot connet to internet
chatxfalcon

My suggestion:

I assume your static ip address are correct. (like gateway and private ips)

Execute this on command line (console)

sudo vi /etc/resolv.conf
remove anything listed there and add this:

nameserver 4.2.2.1
nameserver 4.2.2.2


to check if its working execute this command:


dig yahoo.com


If it returns info it means it works now.



Hope this helps.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
ASKER CERTIFIED SOLUTION
netcmh

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
j8547

I had started to rebuild the server from scratch with no extra software installed, before i seen your comments!!. As the updates originally worked and then wouldn't. Once it is finished I will try your tests and report back. Thanks
netcmh

Thanks for the grade!