Solved

Ubuntu 10.10 Server - Network config

Posted on 2010-11-08
18
1,106 Views
Last Modified: 2012-05-10
I am totally new to linux so picking up everything on the net. I just installed ubuntu server 10.10 (maverick meerkat) on a test server. I am having problems setting the network connections.  I continue to get the error 'unable to resolve host.....'.

Any ideas on what to do or can oyu point me in step by step documentation. Thanks for all the help
0
Comment
Question by:j8547
18 Comments
 
LVL 20

Expert Comment

by:netcmh
ID: 34086108
If you have a dhcp server:

    sudo vi /etc/network/interfaces

    # The primary network interface - use DHCP to find our address
    auto eth0
    iface eth0 inet dhcp

Otherwise:

    udo vi /etc/network/interfaces

    # The primary network interface

    auto eth0
    iface eth0 inet static
    address 192.168.1.90
    gateway 192.168.1.1
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255

0
 
LVL 20

Expert Comment

by:netcmh
ID: 34086112
of course you have restart networking

sudo /etc/init.d/networking restart
0
 
LVL 20

Expert Comment

by:netcmh
ID: 34086118
Setup DNS

    sudo vi /etc/resolv.conf

and enter the following details

    search test.com
    nameserver 192.168.1.2

or whatever your dns server's IP is
0
 
LVL 20

Expert Comment

by:netcmh
ID: 34086130
Or if you wanted gui, then step by steps are here

http://computingtech.blogspot.com/2008/07/how-to-use-ubuntu-linux-network.html
0
 

Author Comment

by:j8547
ID: 34086295

I did have a static ip address but everytime I try and restart I get the error. I changed to dhcp and I still get the error.

Error is

unable to resolve host xxx.xx.xx.x /etc/init.d/hostname restart
/etc.init.d/networking: command not found
0
 

Author Comment

by:j8547
ID: 34086355
Also when i try to restart the hostname I get:
script you are attempting to invoke has been converted to an upstart job.....

????
0
 

Author Comment

by:j8547
ID: 34086380
Also just to add. I can go to network and view all pc's on the domain, so my pc is connected but I can't get on the internet or seem to install software as it cannot connect.

A bit lost as to where I am
0
 
LVL 5

Expert Comment

by:balasundaram_s
ID: 34086745
Please check whether the network card is identified and loaded into the memory 'lspci' command.
0
 

Author Comment

by:j8547
ID: 34086775
yes it looks like it is
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 20

Expert Comment

by:netcmh
ID: 34086940
0
 

Author Comment

by:j8547
ID: 34087021
Both sound like my issue as in not resolving hostname. I checked the first link and both my hosts file and hostname file look correct. As for the bug, im not sure. I have done all updates. You said earlier about the gui and I have seen it on the net but I don't have the 'Network' option under System-Administration-Network.....

I have no clue where to go from here. totally lost.

Thanks for all your help so far
0
 

Author Comment

by:j8547
ID: 34087039
Could it be anything on my windows server side that I need to do
0
 

Author Comment

by:j8547
ID: 34087059
Restarting the networking is working since i rebooted. but still don't know where to go. I cannot get onto internet so something still wrong
0
 

Author Comment

by:j8547
ID: 34087153
AHHHH!!!!

I can ping the gateway and another pc on the network from the ubuntu server. Does this not suggust all is working. But I still cannot connet to internet
0
 
LVL 4

Expert Comment

by:chatxfalcon
ID: 34089473
My suggestion:

I assume your static ip address are correct. (like gateway and private ips)

Execute this on command line (console)

sudo vi /etc/resolv.conf
remove anything listed there and add this:

nameserver 4.2.2.1
nameserver 4.2.2.2


to check if its working execute this command:


dig yahoo.com


If it returns info it means it works now.



Hope this helps.
0
 
LVL 20

Accepted Solution

by:
netcmh earned 500 total points
ID: 34092637
I agree. You've got it working all the way to the gateway. Now it's name resolution tests as suggested by chatxfalcon
0
 

Author Comment

by:j8547
ID: 34094696
I had started to rebuild the server from scratch with no extra software installed, before i seen your comments!!. As the updates originally worked and then wouldn't. Once it is finished I will try your tests and report back. Thanks
0
 
LVL 20

Expert Comment

by:netcmh
ID: 34157770
Thanks for the grade!
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now