Solved

RDP

Posted on 2010-11-08
17
1,120 Views
Last Modified: 2012-05-10
hi there expert
i have a computer at home with xp pro + a router dlink dsl-2640b and i want to access to my home
pc via remote control from the internet i have open the remote control 3389 via port forwarding  in my router and i have actived the Remote Desktop in xp but when i put the public ip didn't connect did  i miss anything.
thnx for help.
0
Comment
Question by:joensw
  • 7
  • 4
  • 4
  • +1
17 Comments
 
LVL 3

Expert Comment

by:Mestika
Comment Utility
Have you allowed RDP in the Windows Firewall??
0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi
 yes
0
 
LVL 3

Expert Comment

by:Mestika
Comment Utility
Well, it seems like you are doing anything it requires to enable RDP in Windows.
But you can crosscheck with Microsofts own guide on how to enable it to see if you missed something:

https://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx

And here is the Microsoft FAQ on Remote Desktop Connection:
https://www.microsoft.com/windowsxp/using/mobility/rdfaq.mspx
0
 
LVL 3

Expert Comment

by:jloiseau
Comment Utility
The first thing to do is enable Remote Desktop on the machine you want to connect to. Open System Properties either by right clicking the My Computer icon in the Start menu and choosing properties or Windows Key + Pause/Break on your keyboard. Click the Remote tab in System Properties and check the box next to Allow users to connect remotely to this computer.

Then from where ever the PC is connected, on the same LAN, test to see if RDP is working.

If so, proceed to next step: The next step in the procedure is to configure your router to allow inbound connections to Remote Desktop on your local computer. This requires mapping a port on your router to a port on your local computer. The process for forwarding a port varies depending on who made your router, but in general there are a similar series of steps.

Application or Description field: RDC
Port Range Start: 3389
Port Range End: 3389
Protocol Type: Both (or TCP if a both option isn't available)
IP Address of your PC: Type ipconfig at the command line if you don't know this
Enable: check a box to enable the port forward

For added security of your RDC setup, you can change the default port Remote Desktop Connection listens on from the host computer. This prevents detection by anyone doing a routine scan for RDC. This is also convenient if you want to connect to more than one RDC computer remotely. For instance, I have 3 computers that never leave home. By default, RDC watches the same port on all computers, which means I'll either get a conflict of some kind or I won't be able to connect at all. An alternative is to redirect RDC traffic to each computer.

You can read more about the process in Microsoft Knowledge Base article 306759

To change the listening port, you need to modify the Windows Registry. Locate the appropriate Registry key using Regedit.exe:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

From the Edit menu, click Modify and then click Decimal. Choose a new port number. In general, choosing a number between 49152 and 65535 will avoid conflict with any other apps on your system, but you could theoretically use any port on the system. Once you set the port number you also need to configure your router to pass the specified port to your computer.

To access your computer remotely, instead of typing just the IP address, you need to type the IP address followed by the port number like this: 192.168.1.1:50001

Test Your Connection
0
 
LVL 6

Expert Comment

by:siht
Comment Utility
The others have pretty much summed it up but here are some possible reasons you don't have it working yet:

1. Your router requires you to add a firewall rule to match your port forward. The port forward tells the router to pass traffic on port 3389 to your internal IP, the firewall rule (if necessary) tells the router to allow traffic on port 3389. Often this is done by default but some routers (like my Billion 7800N) require it to be done manually.

2. You have a dynamic IP address from your ISP and it has changed, therefore you are using the wrong address. A dynamic IP can change at any time. An excellent workaround for this is to sign up for a free account at www.dyndns.com which you can use to map a hostname to your ever changing IP address. Once you have done this you will need to enable the dynamic DNS service in you router, that way the router will inform your dyndns account when your IP changes and you can use the hostname to connect.

3. Your PC needs to have a static IP address on your internal LAN, if you have it set to DHCP the IP can change within the DHCP range. If this happens then your port forward is no longer valid. Another option is to set a DHCP reservation in your router, if it supports this feature, this maps an internal IP address to the MAC address of your LAN card making the IP effectivley static.

HTH
Simon.
0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi
i have actived the remote controle in windows xp and rule in xp firewall and forwarding the port did i missed something.
 

D-link.JPG
0
 
LVL 3

Expert Comment

by:jloiseau
Comment Utility
From your LAN network, are you able to RDP into the desktop "192.168.1.2"?
0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi
yes i able to rdp my computer from lan.
0
ScreenConnect 6.0 Free Trial

At ScreenConnect, partner feedback doesn't fall on deaf ears. We collected partner suggestions off of their virtual wish list and transformed them into one game-changing release: ScreenConnect 6.0. Explore all of the extras and enhancements for yourself!

 
LVL 6

Expert Comment

by:siht
Comment Utility
If you can RDP to the machine from your LAN then your target machine is set up correctly. The problem is most likely in your router, or your dynamic IP.

You could have a look in the "Inbound Filter" and "Firewall & DMZ" sections to see if there are any rules for port 3389. You may have to configure one as I mentioned.

You could also turn on logging in the firewall and attempt to connect from outside your LAN. Then you could check the firewall logs to see if port 3389 is being blocked.
0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi

did i configure something in inbound filter and firewall dmz

Inbound.JPG
firewall-dmz.JPG
0
 
LVL 3

Expert Comment

by:jloiseau
Comment Utility
The only issue that I can come up is if your do not have a static IP address with your ISP. Most home users get a dynamic IP address that changes every so often. This makes it extremely hard to connect remotely because it will fail once the IP address changes.

Just go to www.whatismyip.com and it will give you your external IP address. Check that IP against what you are using to RDP and see if the IP address you are using to RDP has changed, if so, this is your issue and I'll let you know how to get around it.

Just want to confirm that this is the issue.

0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi
yes i khow i have a account in www.dlinkdns.com
0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi
when i 'm loging in www.dlinkdns.com it shows me my dynamic ip

Sans-titre.JPG
0
 
LVL 3

Expert Comment

by:jloiseau
Comment Utility
Did you see that the IP you are trying to use change? or did it stay the same?
0
 
LVL 6

Accepted Solution

by:
siht earned 500 total points
Comment Utility
As jloiseau and I have said the IP/hostname you use to connect must match your external IP which you can obtain by opening www.whatismyip.com from any computer on your internal network.

The other thing you can try is creating an inbound filter rule as follows:

Name: RDP
Protocol: RDP
Source IP: any
Source Subnet Mask: any
Source Port: 3389
Destination IP: your.pc.ip (192.168.1.2)
Destination Subnet Mask: 255.255.255.0
Destination Port: 3389

0
 
LVL 7

Author Comment

by:joensw
Comment Utility
hi Mr shiht
there is no rdp in the protocol  menu can i put tcp instead of..

Sans-titre.JPG
0
 
LVL 6

Expert Comment

by:siht
Comment Utility
Sorry it should be TCP, that was a typo on my part.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

As an IT person for a call center we are always looking for tools to make our jobs easier. Well I found the ultimate application for the job. SmartCode VNC Manager gets the job done. Its easy to get up and running just run the wizard to pul…
Local Printing Using Remote Desktop Windows 7 sometimes has issues with printing to a local printer using a Remote Desktop Connection (RDC). The 1st step is to verify that printers are checked on the Local Resources tab of the Remote Desktop C…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now