An ActiveX control on this page might be unsafe

Hello,

I am creating an html file through SAS and when trying to open it receive the following popup:
 
"An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction? Y/N"

I am running Internet Explorer version 8.0.  Is it possible to stop this popup from being populated through a registry change?

Thanks,
SASNewbie
SASnewbieAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
johnb6767Connect With a Mentor Commented:
1200

Ok... From what I can tell, if you modify "Run ActiveX controls and Plugins", to "Enable", in the Trusted Zone, it modifies the DWORD Value "1200" to "0x0" in here....

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\2\

Notice the 2? Thats the Trusted Sites zone in IE. Local Computer Zone is "0"....

So from the looks of it, this might be worth testing.... However......

I WOULDNT DO THIS!!!!

MS closed the security on the Local Computer Zone for a reason, so hacking a method to get your scripts to work, defeats the purpose. It all too often looks like they are making things harder on us,. but in reality they are trying to HELP make thier systems more secure......

With that said.....

Start>run>cmd

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0" /v "1200" /t reg_dword /d "0x0" /f

Good luck......



0
 
johnb6767Commented:
What zone is this site in in your browser?

Add it to the Trusted Site, and go to IE Options>Security>Trusted Sites>Custom Level>and toggle the ones underneath the Active X Controls and Plugins, to Enabled.....

Remember you only do this on sites you Trust, hence only modifying in that zone....
0
 
scrathcyboyCommented:
ALL Active-X controls are "unsafe" to some degree or other, since it is MS's way of making the web page interact with their operating system in a way that IS UNSAFE when you consider the sandbox model that a website should NEVER be allowed to touch or affect the user's system -- period -- i.e. no exceptions.

Pages that use Active X don't work on other browsers but IE, so you are ORPHANING your web page by using them at all.
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
SASnewbieAuthor Commented:
I am running a html file locally, it is stored on my desktop.  
When I try to reference the html file located on my desktop it gives me the Internet Explorer ActiveX control warning.  
Do you know of a registry change to disable the ActiveX control popup?  I have tried changing the settings in IE 8 Internet Options with no luck.  
The program that I am using to run this functionality is SAS, if that helps.
0
 
Aloysius LowCommented:
i believe that regardless, as long as you are opening a webpage that resides on your local machine, you'll get that prompt... and that there's no way of disabling it - it's microsoft's way of trying to alert you to potentially harmful content
0
 
johnb6767Commented:
Post a screenshot please.....

Youre dealing with the local machine security zone, which cannot be modified via IE Options, like it was in IE6..... Only other options I can think of is the IE>Tools>Options>Advanced, and all the way in the last section, "Allow Active Content to run in files in My Computer".....
0
 
SASnewbieAuthor Commented:
Hi all,

Attached are screenshots of the pop up messages...

Thanks,
EE-screenshot.docx
0
 
johnb6767Commented:
In the Trust Center in Outlook, you can allow Programmatic Access to Outlook's files....

I dont think that you can modify the zones in the Local Computer Zone....
0
 
SASnewbieAuthor Commented:
What I am looking for is the changes that should be made to the windows registry. I have asked that this question be added to the Windows Operating System Development site.

Thanks,
0
 
johnb6767Commented:
Understand what youre asking for, and I will continue researching... IE8 changed the way the local machine zone is handled, INCLUDING via the registry.....
0
 
SASnewbieAuthor Commented:
Hi johnb6767,

Thank you very much!!!
0
 
johnb6767Connect With a Mentor Commented:
Light reading on similar issues....

IE8 Refuses to run Javascript from Local Hard Drive
http://superuser.com/questions/89392/ie8-refuses-to-run-javascript-from-local-hard-drive

How Secure Is Internet Explorer?
http://pcworld.about.com/od/securit1/How-Secure-Is-Internet-Explore.htm

After IE8 update- Open File Security Warning for all local executa
http://www.eggheadcafe.com/software/aspnet/34230179/after-ie8-update-open-file-security-warning-for-all-local-executa.aspx

Different problems, but all centered around discussions of the Local Machine lockdown in IE8..... Few workarounds...
0
 
SASnewbieAuthor Commented:
Hi johnb6767,

Going to have to try another method.

I am going to close this question and award you points for all your help and the knowledge you have shared.

Thanks,
SASnewbie
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.