• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 450
  • Last Modified:

Router will not connect through cable modem with static ip

I have a linksys etherfast 4 port router, and my isp has set me up with a static ip address. I set the router to static ip and input the ip address, but it will not connect to the internet. Nothing that plugs into the router has internet access.

When I input the same static ip address into the ipv4 of my computer it connects to the internet via the modem just fine. What else do I have to configure on my router/modem so that the router will work?
0
charlesAMAG
Asked:
charlesAMAG
  • 2
  • 2
  • 2
  • +1
1 Solution
 
wilmaflintstoneCommented:
normally, your modem gets that ip number, and your pc gets an ip number from the modem.

Your router does not get an ip address, but is assigned an ip address by you.

So the steps you have to take:
1) plugin your computer (into the modem) and turn it on
2) when everything works, open a cmd (dosbox) and type ipconfig
3) you will see an ip address and a subnet mask
4) if you have an ip address within 192.168.0.0 and 192.168.255.255, than you have an ip adress assigned to you by the modem.
5) make your router something like 192.168.123.2 (if your ip address is 192.168.123.100, if your ip address is 192.168.1.10 choose 192.168.1.2 for your router.)
6) plugin your router into the modem
7) connect your pc to the router
8) finished

(i made the assumption your router is actually a switch. If it actually is a router, let me now why you want to use this)
0
 
getzjdCommented:
Was the linksys router previously in use?  Are there old settings in it?  Have you tried a factory reset?    Is your gateway and subnet correct on the static wan intrerface?   If your computer connects to the internet with the static IP assigned, then assign the same settings to the Linksys and make sure you cycle the power on the internet modem when switching devices.  sometimes ISPs limit 1 mac address which is reset when you reboot the modem.
0
 
charlesAMAGAuthor Commented:
It is actually a router, and when the computer us directly connected to the modem it will not connect to the Internet unless I have given it the static ip, subnet and gateway information from the ISP.

The modem is set to use a static ip because we use rdp to connect to the machines plugged into the router. The subnet information is correct and all the numbers have been verified. I tried connecting via the computer and then switching to the router with the same configuration and cycling the modem but that fails.

There were old settings in the router but I did a factory reset and it is now clear.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
wilmaflintstoneCommented:
If your computer gets the ip address assigned to your connection, than the modem is in bridging mode (or perhaps some other).

This setup is more complex to handle.

What is it you are trying to accomplish?


0
 
dosdet2Commented:
I'd like to verify your setup.  This is what I got from your posts:
IPS -> Modem -> Router -> workstations

When the workstation is plugged into the Modem & configured with the ISP's IP, Mask & DNS - it works.  but when the router is inserted in between.   I assume you have not made IP changes within the modem.
If this is not right, you can ignore the rest of this post.

Make sure you have done a factory reset by holding the reset button for at least 30 seconds,
Within the router web interface:
Put the ISP's static IP information in the WAN settings of the Router.  The correct mask is critical.

Check the Lan Side - these settings should be factory - but just in case...
Set the LAN side to be a DHCP server.  
Assign the LAN interface with an IP something like 192.168.1.1, Mask 255.255.255.0

Reboot the workstation and try the internet.  If is does not work, please run an IPconfig /all from a command prompt and post the results here.
Let us know

You will need to open up some ports for RDP to work, but one step at a time.

0
 
dosdet2Commented:
One more thing, if you can't get to the internet, go to a command prompt and try pinging 205.171.3.65.
This is a dns server for qwest.  Let us know if this is successful .
0
 
charlesAMAGAuthor Commented:
What it actually was was the mac address issue, though I solved it by cloning the mac address on the router.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now