• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 495
  • Last Modified:

How do I maintain headers by page in a Multiple column & Multiple page report?

I am using SSRS designer and created a report which  has no page headers but there are 6 columns which have headers.  When I render the report the first page has the column headers but as I page through the column headers do not exist on the remaining pages.  Also,  if I print them I experience the same thing, column headers are only on the first page.

How can I view or print so that column headers remain in at the top of the columns on every pager?
0
rhservan
Asked:
rhservan
  • 5
  • 2
1 Solution
 
Alfred A.Commented:
Are you using a Tablix control?  If you are, you can try setting the RepeatRowHeaders property to True.
0
 
Alfred A.Commented:
By the way, if the RepeatRowHeaders setting to true won't work, try the following:

1.  Expose the Static groupings in the Row Groups area by setting the Group Area into "Advance Mode".  The setting of it is found on the upper right corner of the Columns Groups (there is a dropdown there and select Advance Mode).

2.  Then, select at least the upper most "Static" line in the Row Groups area.  This "Static" line should be at least one of the column headers in that row.  Selecting the Static line will expose the property "RepeatOnNewPage".  By default this is set to True.

3.  Set "RepeatOnNewPage" property to True.

4.  Test it out.

0
 
Alfred A.Commented:
Oh correction on my previous post on no. 2.  The default setting for "RepeatOnNewPage" is False and Not True.  :-)
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
rhservanAuthor Commented:
Alfred1,

Actually I am working with column headers not the row headers.  Your info has set me into the right direction though.   I set the "fixedcolumnheaders" to True and placed checkmarks in the Repeat column headers on each page in Tablix properties.   That seemed to work.
0
 
Alfred A.Commented:
OK.  If it works, that is good then. :-)

Have you tried viewing it in print mode if it displays with headers in the next pages?  Try to print out a sample as well to be sure.  If everything works then, good on you. :-)
0
 
Alfred A.Commented:
I don't have any problem with what you want to do.  However, reading your comment, there is a way to do multiple solution (i.e. one comment accepted as solution and other comments accepted as assisted).  I can still recall someone did that with one of the questions I tried to answer before.

I haven't really experience awarding points since 1999 so I don't know how to do it.  :-)

We can actually ask a moderator to help us here but anyway I don't mind what you are planning to do and I will not object.  :-)
0
 
rhservanAuthor Commented:
The term in the question - Column Headers was the concern and required additional configuration.  Thanks Alfred 1 for your response.  I tried to make this a multiple solution but it would not let me.  Since it is going into the knowledge I wanted others to see the most correct solution
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now