• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2821
  • Last Modified:

Exchange Public Folders Missing in OWA

We recently began transitioning to 2007 Exchange.  Our current environment contains two Exchange 2003 servers.  One Back-End and one Front-End.  The new 2007 server is fully patched and running SP3.  I have migrated a few mailboxes over as well as the public folders.  The public folders work fine when using Outlook but when using OWA, they don't show up.  There isn't even an icon for public folders from the OWA page.  I have tried multiple browsers and also made sure I was not using OWA light.  I found this post on EE which details the same issue but it doesn't provide a solution other than contacting Microsoft:


Thanks in advance,
3 Solutions
Viral RathodConsultantCommented:
Can you check if Public Folder is "Enabled" in the /owa virtual directory "Segmentation "

To access the segmentation controls, bring up the properties of the /owa virtual directory and click the Segmentation

Here is Guide
Shreedhar EtteCommented:

You need to check the replica settings for the public folder.

Refer this article:

Hope this helps,
Both of you were in the middle of migration. In your place I would try to finish public folder migration completely (also system folders), be sure that the replication finished successfully and only then try again.
RHNOCAuthor Commented:
Viralrathod - I checked that and all of the features are enabled on the Segmentation tab of the OWA properties.

Shreedhar - I ran "Get-Publicfolder \ -Recurse | fl name,replicas" using the EMS and all 6 public folders listed show, "{exch2007\second storage group\public folder database}

Davorin - I used this EMS script to move all the public and system folders to the new server.  "MoveAllReplicas.ps1 –Server exch2003 –NewServer exch2007"

Thanks for all of your assistance so far.  I really appreciate it.
RHNOCAuthor Commented:
I think I've figured it out and feel like a bozo for not realizing it sooner.  I use Chrome and Firefox primarily and that appears to be the problem.  I tried using IE8 and everything looks perfect.  I found this article afterwards:


Thanks for all of you assistance with this.  
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now