• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1865
  • Last Modified:

Exchange Mailbox Limits

Im having a problem Setting the mailbox limits for a database.

I use the folowing script


Get-MailboxDatabase "DATABASE" | Set-MailboxDatabase -ProhibitSendReceiveQuota "unlimited" -ProhibitSendQuota 2048MB -IssueWarningQuota 1843MB

Open in new window



and then run the folowing to get a report

Get-mailboxdatabase -identity "DATABASE" | get-mailbox | foreach {

$MailboxInfo = Get-Mailbox -identity $_.displayName
$MailboxStat = Get-MailboxStatistics -identity $_.displayName

Add-Member -InputObject $_ noteProperty UseDefault $MailboxInfo.UseDatabaseQuotaDefaults
Add-Member -InputObject $_ noteProperty WarningQuota $MailboxInfo.IssueWarningQuota
Add-Member -InputObject $_ noteProperty SendQuota $MailboxInfo.ProhibitSendQuota
Add-Member -InputObject $_ noteProperty SendRecieveQutoa $MailboxInfo.ProhibitSendReceiveQuota

Add-Member -InputObject $_ noteProperty QuotaStatus $MailboxStat.StorageLimitStatus
Add-Member -InputObject $_ noteProperty TotalItems $MailboxStat.ItemCount
Add-Member -InputObject $_ noteProperty TotalSizeMB $MailboxStat.TotalItemSize.Value.ToMB()
Add-Member -InputObject $_ noteProperty DeleteItems $MailboxStat.DeletedItemCount
Add-Member -InputObject $_ noteProperty DeletedSizeMB $MailboxStat.TotalDeletedItemSize.Value.ToMB() -PassThru
Add-Member -InputObject $_ noteProperty MailboxDatabase $MailboxStat.database

} | Export-Csv -Path "D:\DATABASE.csv"

Open in new window


and the results show that the "WarningQuota" "SendQuota" and "SendRecieveQutoa" havent changed, i would expect them all to be set as the first script.

Am i doing something wrong or is it that damn gnome in the server!
0
Wean
Asked:
Wean
1 Solution
 
JBond2010Commented:
Restart the services for Exchange.
0
 
The_KirschiCommented:
Try

"Set-MailboxDatabase "<servername>\DATABASE" -ProhibitSendReceiveQuota "unlimited" -ProhibitSendQuota 2048MB -IssueWarningQuota 1843MB"
0
 
BusbarSolutions ArchitectCommented:
you are setting the levels on the DB not the mailboxes so mailboxes limits will not change and when calculated it will be based on the DB where they are located.
so this is correct
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
WeanAuthor Commented:
Thanks for all your help The_Kirschi and JBond2010 and busbar.

busbar, that sound's like the problem. Im going to give it a go now.
0
 
WeanAuthor Commented:
How do i modify the script below to change the

I tried to combine the two together to update for each mailbox in a database but i think im horrible wrong.

Get-mailboxdatabase -identity "DATABASE" | get-mailbox | foreach { Set-MailboxDatabase -ProhibitSendReceiveQuota "unlimited" -ProhibitSendQuota 2048MB -IssueWarningQuota 1843MB }

Am I on the right path or far off?

0
 
JuusoConnectaCommented:
Get-mailboxdatabase -identity "DATABASE" | set-mailbox | foreach { Set-MailboxDatabase -ProhibitSendReceiveQuota "unlimited" -ProhibitSendQuota 2048MB -IssueWarningQuota 1843MB }

after piping change the "get-mailbox" to "set-mailbox"
0
 
BusbarSolutions ArchitectCommented:
just do
get-mailbox -database "database" |  Set-MailboxDatabase -ProhibitSendReceiveQuota "unlimited" -ProhibitSendQuota 2048MB -IssueWarningQuota 1843MB
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now