Solved

windows 2003 server / exchange routing group failed

Posted on 2010-11-09
17
340 Views
Last Modified: 2012-06-27
we have 2 microsoft windows 2003 servers in 2 different physical locations. One of our servers is responsible for receiving all of the email for our domain, and we have configured a routing group to forward all email for local users of our other server, which is using the same domain name.

This has been working fine for the paste couple of years.

The problem is that email for our second server is not now being recieved at the second server. I can see nothing under the actual Routing Group itself, but we can see dozens of emails stuck in our first servers queue - ie Server Routing Group Queue with unreachable destinations..

All of the queues in our second server are clear.

We have found that when we kill the process "inetinfo" it automatically restarts itself and then when we have refreshed the queues, the mail that was stuck in the unreachable queue is transferred to the correct active queue and messages start being handed off again.

Shortly after the process happens again. ie mail builds up in the unreachable destination queue again, etc.

Can anyone assist in how we go about troubleshooting this problem, as we need to get mail flowing 2 our remote site ASAP.
0
Comment
Question by:nigelbeatson
  • 7
  • 6
  • 2
  • +1
17 Comments
 
LVL 12

Expert Comment

by:RobinHuman
ID: 34091935
What do the event logs say?
When it stalls, is inetinfo using a high ammount of memory or cpu?
Check these, and let us know
0
 
LVL 3

Expert Comment

by:GurdeepJohal
ID: 34091997
Please check if second server is reachable from the first server.
0
 

Author Comment

by:nigelbeatson
ID: 34092064
hello.

I have enclosed a copy of some of the entries in both the application and system logs. They are in the order as they were in the actual logs, ie most recent first. These are replicated many times throught the log.

inetcfg is running at 0% activity according to task manager, however, when we kill it and restrat it, it does show some activity, but not high.

The server generally seems to run slowly almost stopping at times and then frees up again, although I cannot see any particular process that is responsible for this.

I hope the event logs help.
applicationlog.txt
systemlog.txt
0
 
LVL 3

Expert Comment

by:activit
ID: 34092116
Is this server running any new or updated AV software.  Maybe just disable it as a temp step to see if that is an issue.  Also is there a reason for not doing Outlook Anywhere(Http/RPC) rather than this messy exchange config.
0
 
LVL 3

Expert Comment

by:GurdeepJohal
ID: 34092122
0
 

Author Comment

by:nigelbeatson
ID: 34092180
I have run the Exchange BPA tool and one of the errors indicated that we should set the permissions on the Mail Store to Allow inheritable permissions from parent to propagate to this object. This error indicates that this may produce mail flow problems.

However, I have checked this, and it is already set, but the BPA says it is not???

We are running AVG on both servers, but this has been working for some time.

We have 2 physicall sites with a number of users at each, running OWA is not really a viable option for us.

I could remove the anti virus for a time, but I am concerned about leaving the store exposed.
0
 
LVL 3

Expert Comment

by:GurdeepJohal
ID: 34092187
it looks like network or permission level problem. please check if second server is reachable through network for all exchange services.

0
 

Author Comment

by:nigelbeatson
ID: 34092189
I have noticed that our internet service is alos running very slowly.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 3

Accepted Solution

by:
activit earned 167 total points
ID: 34092230
Would suggest if inet slow to  increase timeout on both servers
0
 

Author Comment

by:nigelbeatson
ID: 34092310
how do I check that the second server is reachable through the network for "all exchange services"?

Thanks.
0
 
LVL 12

Assisted Solution

by:RobinHuman
RobinHuman earned 167 total points
ID: 34092313
suggest the following:
1. increase the timeout values for both servers
2. Check the nic speed negotiation is set the same on both servers (this can cause timeout issues)
3. Fully patch both servers with all updates
Hope this helps
0
 
LVL 3

Expert Comment

by:GurdeepJohal
ID: 34092338
through telnet and tracert command you can check the network routes.
0
 
LVL 3

Expert Comment

by:GurdeepJohal
ID: 34092364
please try to check the routes  http://support.microsoft.com/kb/832281
0
 

Author Comment

by:nigelbeatson
ID: 34093455
I have run the winroute utility and it confirms that the routing connector is not connected.

If we reset the inetinfo service, the routing group connector shows the emails in the correct queue. At this time winroute shows that the routing connector is connected.

After leaving for a few mins, the e-mails jump to the unreachable destination queue, and on checking the winroute utility again, it shows that the routing connector is no longer connected with a red cross.

Our internet service is running much slower than usual, and I have requested a test by our service provider. In the meantime to check the theory, can we increase the timeouts on each server?

If so, how do we do this?

please advise.
0
 
LVL 3

Assisted Solution

by:GurdeepJohal
GurdeepJohal earned 166 total points
ID: 34093840
To access these settings in Exchange 2003, open System Manager and navigate to Servers – Your Mail Server’s Name – Protocols – SMTP. Right click on your SMTP Virtual Server – Properties – Delivery tab.
0
 

Author Comment

by:nigelbeatson
ID: 34101302
reset the smtp timeout to 20 mins and it worked all through the night. came in this morning and it was still working.

decided to troubleshoot the under laying speed issue which we found was an external dns issue. replaced the external dns with the google open dns 8.8.8.8 and it worked fine.

however on reconnecting the internet connection to the network, the problem seems to have returned. mail builds up in the routing connector queue and eventually gets passed to the messages with unreachable destination queue.

any other ideas?
0
 

Author Closing Comment

by:nigelbeatson
ID: 34164938
all helped thanks.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now