Link to home
Start Free TrialLog in
Avatar of topuz
topuz

asked on

HP MSL2024 1 LTO-4 Ultr 1760 SAS Library not detected by BackupExec 11d

Hi,
I have HP MSL2024 1 LTO-4 Ultr 1760 SAS Library connected to Wn2003 Enterprice 32bit server via HP P212/ZM Smart Array Controller.
Both LTO-4 tape drive and library are detected by Windows OS with Bus Number 7, Target Id 0, LUN 0  and Bus Number 7, Target Id 0, LUN 1 appropriately.
But Backup Ecec 11d detects LTO-4 device drive as standalone device and does not detects library.
According to BackupExec 11d HCL  all shall works. The BackupExec 11d is updated with latest availbale be7170RHF37_32bit_300325 DDI  and SP5 is installed.
Could you please advsie.
Avatar of Member_2_231077
Member_2_231077

Although the quickspecs used to say it was recommended to use a P212 they've been corrected now and recommend you connect it to HP SC44Ge Host Bus Adapter. It's never good to put a tape device on a RAID controller.

Can you change the library to use a different SCSI ID rather than different LUN? Multi-LUN devices are never easy.
Avatar of topuz

ASKER

Thanks for advise. Change p212 to SC44Ge consider as last option when insured that problem related to P212. But since OS detects both library and tape device I don't think this is the case. On the other hand both library and tape device seems to be detected by BE as well but with error. Here is a part of ADAMM.log

0003:0007:0000:0000  Device Name             "\\.\Tape0"
                     Secondary Name          "\\?\scsi#sequential&ven_hp&prod_ultrium_4-scsi&rev_u52w#5&96d12ba&0&070000#{53f5630b-b6bf-11d0-94f2-00a0c91efb8b}"
                     Primary Inquiry         "HP      Ultrium 4-SCSI  U52W"
                     Serial Number           "HP      Ultrium 4-SCSI  HU1030BFA5"
                     Device Flags            KSCSI, SN(TYPE 1)
                     Device State            3, Online

                     Device IDs              1002, {74C1AD09-B715-4399-B36C-E5B552EE41D2}
                     Device Name             "HP 1"
                     Device Type             134283265, "LTO 64K (64K,10,0,E,HU)"
                     Device Features         0x001BFB7F: PB,SFB,SRB,WFM,SFF,SRM,PEOD,ES,EL,LU,E,SBS,DC,SDC,TA,HU,RR,W
                     Device Element          0, 0

0003:0007:0000:0001  Device Name             ""
                     Secondary Name          "\\.\Changer0"
                     Primary Inquiry         "HP      MSL G3 Series   4.90"
                     Serial Number           ""
                     Device Flags            KSCSI
                     Device State            1, Offline, ERROR = 0x0000007B (ERROR_INVALID_NAME)

How to fix this INVALID_NAME  error?
Long discussion on that error at http://www.symantec.com/connect/forums/hp-storageworks-autoloader-not-detected-backupexec , admittedly a different library but steps should be the same.
Avatar of topuz

ASKER


That is what I am doing right now..

1. Quit Backup Exec
2. Start BEUtility, and connect to the Backup Exec media server
3. Select the option to stop the Backup Exec services
4. Click Start | Run, and type REGEDIT. Click OK.
5. Browse to HKey_Local_Machine | System | CurrentControlSet | Services. Delete the SCSIChanger key.
6. Browse to HKey_Local_Machine | System | CurrentControlSet | Control. Delete the SCSIChanger key.
7. Close REGEDIT
8. Navigate to C:\Program Files\VERITAS\Backup Exec\NT\ and delete the "loader" folder
9. Navigate to C:\Program Files\VERITAS\Backup Exec\NT\ and launch 'tapeinst.exe"
   a. Select "Uninstall and remove all VERITAS device drivers from your system"
   b. Select "Delete entries for tape devices that are not available"
   c. Complete the wizard and reboot the system
10. Click Start | Settings | Control Panel
11. Double-click Add/Remove Programs
12. Select Backup Exec for Windows Servers, and click Change
13. Click Next when the Welcome screen displays. Under Local Selections, select the "Repair Backup Exec" option
14. Once completed, Shut down the Backup Exec media server and the robotic library
15. Start the robotic library, and verify that the device initializes correctly
16. Start the Backup Exec media server. Verify that the robotic library posts correctly on SCSI startup
17. Check Windows Device Manager to insure both the Medium Changer and Tape Drive has been recognized
18. Download the latest drivers from VERITAS Software, and install them (a reboot may be necessary for this).
19. The robotic library should now be displayed correctly in Backup Exec.


Will come back
Avatar of Gerald Connolly
but have you moved the tape off of the RAID controller? because a) as Andy said its not a supported config and b) i assume you have your disks you want to backup on the same RAID array, so when you backup anything reading from the disks will affect writing to the tape and vice versa as the array only has so much bandwidth and you want all of that bandwidth to get data from the disks.
Remember that a LTO-4 tape has a minimum speed it will accept data (approx 30MBytes/sec) before it starts shoe-shining and if you have the disks that are being backed up on the same controller that you also have the tape on then then its ineviatable that you will get degraded tape performance.
Avatar of topuz

ASKER

Hi,

HDD RAIDs are on another controller P410.
Test backup via by Windows Backup is Ok. But now I have disabled windows RSM.
Regarding compatibility of MSL2024 and P212 - according to HP they are compatible. If you have any other ref. please advise.
I think the issue is related to proper driver installation proceduer. I have event in Event viewer:
        ADAMM configuration warning.
        The device driver may not be installed for device :
        Identifier : HP      MSL G3 Series   4.90.
        Type : MediumChangerPeripheral.
 
the h/w connection may be supported by HP, but is it supported by Symantec? ie is the solution supported (preferably by both vendors?)
Avatar of topuz

ASKER

Pasrt fo HCL of BE 11d:

Newly-Supported Devices
The following new devices have been added to this HCL since the last time it was created. The creation date is listed on the first page of this document. See the
device in its respective section, via bookmarks, for more details.
A new Device Driver Installer (DDI), version 20070215 (for 11.0.6235), and version 20080215 (for 11.0.7170) has been published:
<http://entsupport.symantec.com/umi/V-269-10> Your device may require that you download and install this DDI, but it is RECOMMENDED that the latest DDI is
always used. If the new DDI is utilized, it is required that Intelligent Disaster Recovery users regenerate the IDR boot media.
A new build of 11d has been released: 7170. Some devices listed require that this build be installed, and are identified with a footnote. Details for how to
access this build can be seen : <http://support.veritas.com/docs/287939> .
New tape libraries:
1. HP 1/8 G2 Tape Autoloader with HP StorageWorks Ultrium 1760 LTO4 drive
2. HP MSL2024 with HP StorageWorks Ultrium 1760 LTO4 drive - SAS and SCSI
3. HP MSL4048 with HP StorageWorks Ultrium 1760 LTO4 drive - SAS and SCSI
4. HP MSL8096 with HP StorageWorks Ultrium 1760 LTO4 drive - SAS and SCSI
Avatar of topuz

ASKER

Futher from the same documents in the lsit:

Device Inquiry String Library Interface Address Scheme Drive Manufacturer Drive Model Inquiry String Drive Interface Media


MSL2024 [1] HP^^^^^^MSL^G3^Series SAS Multi LUN HP StorageWorks Ultrium1760 LTO4 HP^^^^^^Ultrium^4-SCSI SAS LTO
But where Symantec say SAS they mean non-RAID SAS as per tech article 24414 that I posted earlier.
ASKER CERTIFIED SOLUTION
Avatar of Gerald Connolly
Gerald Connolly
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of topuz

ASKER

It works with HP Data Protector Express and if no sollution for BackupExec 11d I am going to switch to HP Data Protection 6.11 (assuming it will work...)
Avatar of topuz

ASKER

Hi again,

I have installed fix KB943545 for Win2003 and BE 12.5. Both Library and tape drive are detected properly. But now the backup jobs hungs after writing a few Mb data. Any advice?
I'd buy a SC44Ge for £110 and sell the P212 on eBay.
I agree with Andy, its always problematic trying to do something out of the ordinary, or trying to mix and mend. If you want a reliable and trouble-free solution it pays to go down a tried and tested route, especially if you don't have the knowledge and/or experience of building lots of storage solutions - we have been there and made all those mistakes already!
Too many people too many comments to just delete
There doesn't appear to be a solution though?
In ID:34130453 the response is that it is fixed! then another question is asked. so the original was solved! Split the points between Andy and me
Its #3 split equally between these two

http:#a34110529
http:#a34110618