Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Cannot use autodiscover or rpc over http

Avatar of pbrane
pbrane asked on
ExchangeMicrosoft IIS Web ServerWindows Server 2003
4 Comments1 Solution817 ViewsLast Modified:
System specs:

Windows server 2003 sp2
Exchange server 2007 sp1
certificate has all the correct A records autodiscover, mail etc


I have an issue with my exchange server without having made any changes to the server. I cannot setup new outlook accounts in outlook 2007. All the current outlook accounts seem to be working fine though.

www.testexchangeconnectivity.com results are below:

attempting to test potential autodiscover URL https://domain.co.uk/autodiscover/autodiscover.xml

failed

additonal details

hostname doesn't match any name found on the certificate CN=mail.domain.co.uk, O=CO NAME, L=town, S=county, C=GB

Attempting to test potential autodiscover URL https://autodiscover.domain.co.uk/autodiscover/autodiscover.xml failed

A web exception occurred beacause an HTTP 401 - unauthorized response was received from unknown.

I can telnet into the exchaneg server on ports 443, 80, 6001, 6002 and 6004 ok

rpccfg /hd results in the correct ports being shown

When i try:

C:\Documents and Settings\account>rpcping -t ncacn_http -s i3-mx-01 -o RpcPro
xy=mail.domain.co.uk -P "account,domain.local,*" -I "account,domain.local,*" -
H 2 -u 10 -a connect -F 3 -v 3 -E -R none

I get - client is not authorised to ping rpc proxy but when I change the H value to 1 reponse received from server and pinged successfully.

Can anyone point me in the right direction? I feel that I have nearly resolved this issue but am still not there.

Thanks,

Andrew


ASKER CERTIFIED SOLUTION
Avatar of Shack-Daddy
Shack-DaddyFlag of United States of America image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answers