• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 565
  • Last Modified:

Folder Redirection with GPO not working

I am trying to use GPO settings to redirect the My Documents folder.  All of the other settings in the GPO are applying, but the folder redirection is not.  I have made sure the share I am pointing to has creator owner and system rights, still no go.  It is not working for any user I try to log in as.  Any suggestions?
0
lflorence
Asked:
lflorence
  • 5
  • 3
1 Solution
 
rjwesleyCommented:
Did you set the Home Directory/Folder within the user's properties?

run gpupdate /force on both server side and client side.

Rob
0
 
AntyraelICT SpecialistCommented:
You can verify if the policy has applied with the rsop.msc command.
If you then browse to User Configuration -> Windows Settings -> Folder Redirection -> Documents, you should see an entry for the Documents redirection.
If there isn't one right-click on User Configuration, select Properties and check the Error Information tab.
You might also find some information in the Windows Eventlog.
0
 
lflorenceAuthor Commented:
Ran gpupdate several times.

Does the home folder have to be set to go to the same place?  I was under the assumption that I could just redirect the My Documents folder using the settings in GPO.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
rjwesleyCommented:
Required (in 2008 ) Home Folder location \\servername\sharename\username\Documents

Rob
0
 
rjwesleyCommented:
No not the same place for all users.  \\servername\sharename\%username%\Documents - using that will create a username\Documents folder for all users.

Rob
0
 
lflorenceAuthor Commented:
Wouldn't that kinda' defeat the purpose of using GPO to do the folder redirection?  The option to create the folder for the user in the location specified should do all of that for you.
0
 
rjwesleyCommented:
You assign home folders to centralize all users files - for say backup purposes.

You use Folder Redirection to basically manage all user My Documents folders/location for a variety of purposes.

Rob
0
 
lflorenceAuthor Commented:
I don't want all user's files centralized, I only want to redirect the My Documents folder.  Can you point me to where it states that Home Folder redirection is required in Server 2008 for My Documents redirection through GPO?
0
 
rjwesleyCommented:
That's just a common setting I've always used. You can redirect to any location.

In Folder Redirection, right click Documents > under the Target tab, Select Advanced -Specify locations for various user groups, and use this article for further direction - http://technet.microsoft.com/en-us/library/cc771969(WS.10).aspx

Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now