Solved

How do I change the attachment size limit in Microsoft Exchange 2010?

Posted on 2010-11-09
7
11,134 Views
Last Modified: 2012-05-10
I am have a user who wants to attach a file larger than 10MB in Microsoft Exchange 2010. I have changed every size limit except the following...

ExternalDsnMaxMessageAttachSize

InternalDsnMaxMessageAttachSize

I have tried running this cmdlet that someone posted as follows but I get an error:

Set-TransportServer ” SERVERNAME ” -ExternalDsnMaxMessageAttachSize xxMB
Set-TransportServer ” SERVERNAME ” -InternalDsnMaxMessageAttachSize xxMB

The error is as follows:

The position peremeter can not be found that accepts argument "ExternalDsnMaxMessageAttachSize"

I have attached an image of when I run the "get transportconfig" command.


 These are the two values I need to change...
I have read and did all the steps for the other send and recieve parameters from the following site which was recommended on another post. Everything else is setup properly I just cant seem to change the internal and external attachsize limit. IT still shows 10MB. Thank you in advance for any help! =)

Also I have rebooted the server after I changed my other settings as well.
0
Comment
Question by:Jryals8900
  • 4
  • 2
7 Comments
 
LVL 6

Expert Comment

by:Shack-Daddy
Comment Utility
Try this:

Get-transportserver | Set-TransportServer -ExternalDsnMaxMessageAttachSize 40mb -InternalDsnMaxMessageAttachSize 40mb
0
 
LVL 13

Expert Comment

by:dsmile
Comment Utility
0
 

Author Comment

by:Jryals8900
Comment Utility
Unfortunately I got another error. I will attach it so you can see.
exchange2010errorsz2.png
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:Jryals8900
Comment Utility
dsmile I did all the steps in the second link that you posted. The first link is regarding the Outlook 2010 size limit which is not a problem at the moment for me. Currently my 2010 Exchange is listing my maximum internal and external message attach size limit at 10MB. Thanks for the try ;)
0
 
LVL 6

Accepted Solution

by:
Shack-Daddy earned 500 total points
Comment Utility
I think you are on the wrong track, trying to use the wrong parameter. That's why you are getting the errors. Look at this thread for the actual variables you should be changing:

http://www.tek-tips.com/viewthread.cfm?qid=1594519&page=1
0
 

Author Comment

by:Jryals8900
Comment Utility
Shack-Daddy I believe you may be correct...I am testing now and will award you points if all pans out properly.  That internal and external dsnmessageattachsize is confusing as hell...makes me wonder what that even does

stay tuned...
0
 

Author Closing Comment

by:Jryals8900
Comment Utility
Shackdaddy you were correct! I made the required changes but didnt fully test because I saw the two values at 10MB. Even though these values state attachsize they do not matter because it works internally and externally now. Thanks for your help!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now