How to disable test messaging in Exchange 2010

We are rolling out Exchange 2010 in our environment. Upgrading from Exchange 2007. One of the features I am not too happy about is the ability to send instant messages from OWA and Outlook in 2010. I need to disable this feature before I start moving users over to 2010. I cannot have users pulling down text messages from their phones when they connect with ActiveSync. Most users will freak out if this happens and I cannot believe this feature is enabled by default. I am working in a test environment right now and I am trying to figure out a way to disable this feature. Someone said using the Segmentation tab under the OWA virtual server properties would work but it does not. I disabled Test Messaging and Instant Messaging but I was still able to pull down text messages in my Outlook from my mobile device. There has to be a way to disable this feature on the server.
osiexchangeAsked:
Who is Participating?
 
osiexchangeAuthor Commented:
I will be escalating this to Microsoft support.
0
 
SaakarCommented:
To disable Text Messaging you have to run the following command, this will disable it for all users..
Set-owavirtualdirectory -TextMessagingEnabled:$false
Additionally The mobile device has to be a Windows Mobile 6.1 No iPhone, no Blackberries have this functionality.
More information @ the link below
http://technet.microsoft.com/en-us/library/bb123515.aspx 
0
 
osiexchangeAuthor Commented:
I will try this but it probably will not work. This achieves the same result as disabling using the Segmentation tab which did not help.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
osiexchangeAuthor Commented:
This did not work. I disabled both Instant Messaging and Text Messaging at the Organizational level and the Server level and I am still getting Text messages in my Outlook and OWA from my mobile device. Any other ideas? There has to be a way to disable this feature.
0
 
SaakarCommented:
Try creating a new Test policy for EAS using the technet beow and accept it on the device, for this you may have to recreate the Mobile Device profile agai

http://technet.microsoft.com/en-us/library/bb123756(EXCHG.80).aspx

What we are looking for is -AllowTextMessaging $False parameter

Hope this helps!!
0
 
osiexchangeAuthor Commented:
I tried this already. All this does is disable text messaging on the phone. Not something I want to do.
0
 
osiexchangeAuthor Commented:
Had to escalate to Microsoft support
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.