How to show or hide components in Joomla

I've just set up a Joomla site using a template. There are some different areas on the page, like an image slider, login area, news section, etc. ON my home page all of these elements appear, but on article pages only some of them appear.

On this page: http://cmr.osu.edu/joomla/index.php?option=com_content&view=article&id=46:datasets&catid=1:services&Itemid=53

I would like to remove the elements that say "dataset, about, models, learn" but I'm unable to find the settings in Joomla. Does anyone have an idea where these might be?

Thanks
LVL 4
elliottbenzleAsked:
Who is Participating?
 
netcmhConnect With a Mentor Commented:
I think this link has that covered: http://forum.joomla.org/viewtopic.php?p=1212862
0
 
netcmhCommented:
You can do it very carefully by deleting them manually from within the Administration Back-end so all- Articles, Categories, Sections, Menu items - any custom Modules that you don't want, you can delete. Just make sure that you keep the mainmenu and a Front Page Menu Item with some details.

Or you could very carefully edit the MySQL tables via PHP MyAdmin or similar and delete all the records that you do not want
0
 
brb6708Connect With a Mentor Commented:
The example pages set up during joomla installation are for absolute newbies. If you played around with them to understand how joomla works, you should kill the installation and reinstall joomla without example pages seting up your own system.

I even don't use predefined templates anymore because setting up a joomla template from scratch isn't complicated if you are a little bit familiar with CSS and PHP. And then everything works as you want it to work.

There are really good tutorials for setting up joomla templates available (google is youzr friend)
0
 
Amanda WatsonConnect With a Mentor Web DeveloperCommented:
You mentioned
"I would like to remove the elements that say "dataset, about, models, learn"

on the page I am seeing these are actual menu items.  To remove them from the page you are viewing you will need to disable the menu module that shows for that page.

You can do that by going to Module Manager and finding the menu in the list....Then go into it and make the menu show on only the pages you want.

This can be configured on the lefthand side down the bottom of the module settings.
0
 
netcmhCommented:
Thanks for the grade
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.