Crystal Report 11 -- Cross Tab formatting

My cross tab report is chopping off data, both column wise and row wise. I want the entire data to fit in my screen. I am exporting it as a PDF. I tried changing it landscape, reduce the font size etc.. its still clipping some data off. Is there a way to increase the ruler points(or margin, i dont know the name of that, currently i have 9 pts on the top, I have attached a screen shot, to show what I mean)

Who is Participating?
James0628Connect With a Mentor Commented:

 You and mlmcc seem to be talking about 2 different things.

 When you say "My cross tab report is chopping off data", I think you mean that it's running onto multiple pages.  I would not call that "chopping off".  To me, "chopping off" implies that the data is not shown, but, if I'm correct, the data is there.  It's just on other pages.

 mlmcc suggested making the columns wider, so he was apparently thinking that you meant that values in the individual columns were being cut off, because the columns were too narrow.   Of course if the cross-tab is too wide to fit on one page, making the columns wider is only going to make it worse.  You would need to make the columns narrower, and possibly shorter, if the rows are also running onto multiple pages.

 You said that you tried reducing the font size, but that alone has no effect on the size of the cross-tab.  When you change the font size in a cross-tab, CR does not change the size of the field.  You have to do that manually.  So, you'd reduce the font size and make the field narrower, and that would make the cross-tab narrower.

 You can also remove the margins in the cells of the cross-tab to make them smaller.  Right-click on the upper left corner of the cross-tab and select "Cross-tab Expert".  On the "Customize Style" tab, uncheck the "Show Cell  Margins" option in the bottom section.

 FWIW, there were some things that you said that don't seem to make sense.  You said that the ruler showed "9 pts" (that's inches, BTW), but your screenshot of the Page Setup screen showed legal paper in landscape orientation with narrow margins, in which case the ruler (page width) should go up to around 13.5 inches.  Any chance that your ruler really goes up to around 13.5 and you just need to scroll the window to the right?  Or was the report maybe set for letter (instead of legal) when you were seeing that 9?

vetaldjConnect With a Mentor Commented:
You can remove margin over text in fields, this will reduce space needed to show all data.
Also, you can (I think you already did that) reduce width of columns and height of rows.
To make that ruler bigger you need to right click anywhere on the report and select Page Format, then you can change paper size to any one you need. It will make that ruler bigger. Here you can change orientation as well.
Sorry, "Page Setup...", not Page Format as I wrote above...
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

mlmccConnect With a Mentor Commented:
Have you made the columns wider?

What kind of data is being chopped?  Is it numbers or text?

D-pkAuthor Commented:
I can't change the numbers in the page setup box, no matter what I give changes to some number.. i have attached the screen shot.


I did make the columns wider, but when I try to export it to PDF it prints the data in the next page, instead fitting everything in the screen in one page.
The data is all numbers with 2 decimals.

Are you printing to the same printer that the report is built against?

D-pkAuthor Commented:
D-pkAuthor Commented:
I played around with the suggestion you guys gave and got what I wanted.. Thanks a lot everyone..
You're welcome.  Glad I could help.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.