Solved

Exchange server 2003/2007

Posted on 2010-11-09
32
382 Views
Last Modified: 2012-05-10
Hi,

One of my client want to enable auto response in response a mail(like out of office reply) . Is it possible to set up on a distribution group, an auto response??

Please ..

Thanks,
0
Comment
Question by:ProVal
  • 16
  • 14
  • 2
32 Comments
 

Author Comment

by:ProVal
ID: 34094885
I have just known that client is using exchange server 2007..
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34094968
Yes, in Exchange 2007 it's made very easy.

Open up Exchange management console, go to Organisation > Hub transport and click on the 'Transport Rule' tab. In here you can create rules and apply them to the distribution groups. If you'd like an auto-respond then there's an option for "append disclaimer text using font, size..(etc etc)". You should be able to add the auto-respond message and format you'd like there.
0
 
LVL 4

Expert Comment

by:zgiuffria
ID: 34094972
Out of office assistant?  Is it just for out of office?
0
 

Author Comment

by:ProVal
ID: 34095043
Yes but i want to enable this on the Distribution Group instead of user separately ?.
0
 
LVL 4

Expert Comment

by:zgiuffria
ID: 34095057
You may just have to set up a mail rule and see if there is a way to push it out to them.  
0
 

Author Comment

by:ProVal
ID: 34095165
ConanUK:

Could you explain in more detail because their are multiple options are coming as you said....but what options should i select to create the rule ...
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34095283
Ok, below is what I believe you need:

On the first page, give the rule a name and ensure that 'Enable' is ticked, click next.

On the next page, tick the option for "sent to a member of a distribution list". Once you've ticked this, it will appear in the box below. Click on the blue text in that box, then find the distribution group you need and ok. Click next once the distribution group is selected.

On the next page, select the tick box for "append disclaimer using Arial, smallest, Gray, with separator and fallback to wrap if unable to apply". All of the changable options will show as blue text. Click where it says 'disclaimer' and enter the text you want the recipient to receive in the auto-respond. The other bits like Arial, smallest etc etc will change the format/colour/look of the responder, this you will have to change for your own preference.

It should look something like:
Apply rule to messages
sent to a member of %enter your distribution group here% append % enter your Automated response here% using Arial, smallest, Gray, with separator and fallback to wrap if unable to apply.

Hope this helps :)
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34095299
p.s I missed out the page after, these are the 'except if' rules, you should not need these unless you don't want the auto-responder to work with certain people/groups so just click next and then finish.
0
 

Author Comment

by:ProVal
ID: 34100371
ConanUK:

But this is working as i wants,what i want when a sender sending the mail to a distribution group,either user from inside the organization or outside the organization then sender should get a reply back mail for the successful deliver to the Distribution group...
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34100627
Sorry, was a long day and I mis-read.

You can't do this through distribution groups or a transport rule, you have to use Public Folders to do what you are asking, see below:

http://www.amset.info/exchange/groups-autoreply.asp
0
 

Author Comment

by:ProVal
ID: 34100951
ConanUK:

this link is completely as per my expectation but i am getting some confused..on this line

Go back to the Public folder properties (Exchange 2007), click on the tab "Member of" and add the folder to the distribution list.

i am unable to perform this run ....please explained
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34101083
Which part are you having problems with?

In Exchange Management Console, if you go to Tools > Public Folder Management, find the public folder that you have just created and right click > properties. From here you should see the 'Member of' tab - here you need to add folder as described in the article.

Does that answer your question?
0
 

Author Comment

by:ProVal
ID: 34101121
Member of tab is coming but no option to add the folder ?
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34101172
That would suggest that the Public Folder has not been 'mail enabled' as per the article. Can you confirm that the mail enable option completed succesfully by using the command below (change the names for public folder you created).

To confirm that it was mail enabled correctly, run:

get-publicfolder -identity "\test\moderated folder" | fl

 
0
 

Author Comment

by:ProVal
ID: 34101173
according to this article ist it is telling to open the public folder properties and then saying to add this public folder itself under member of tab of this public folder...Is this right ?

Here i attaching the my newly created public folder and its properties TAB

Can you suggest where am i doing a mistake ?
Auto.JPG
0
 

Author Comment

by:ProVal
ID: 34101190
Their is no button like Add .....
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 
LVL 2

Expert Comment

by:ConanUK
ID: 34101225
Try going into AD > Properties of the Distribution group you added, click on the 'Members' tab then find and add the public folder that way.
0
 

Author Comment

by:ProVal
ID: 34101251
No Luck>.......Please this i have to do at any cost please help me..........by an other way
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34101336
You need to be more specific if you want further help 'No luck' doesn't tell me anything I can use to try and help you!

You have still not confirmed the results of the command I asked:

get-publicfolder -identity "\test\moderated folder" | fl

You must ensure that it is mail enabled and then browse for the public folder that you have created and add it to the Members tab of the distribution group. If you are concerned you have done it wrong, then scrap it and start again.
0
 

Author Comment

by:ProVal
ID: 34101561
All 3 tab is coming after enabling the public folder mail-enabled

Exchange General
Email Address
Member Of
Mail Flow Setting..


And you know very that these tabs only appears when an public folder is mail-enable  but here also i giving the cmdlet output of my public folder


[PS] C:\Windows\system32>Get-PublicFolder -Identity "\Provaltech - Internal\Auto Reply" |fl


RunspaceId                     : 839d7041-6355-4f51-b4c7-9c62b7ecbda8
AgeLimit                       :
EntryId                        : 000000001A447390AA6611CD9BC800AA002FC45A0300B1F38C6DE566F94B8D05E299C7AA2528000013A01C
                                 990000
HasSubFolders                  : False
HiddenFromAddressListsEnabled  : False
IssueWarningQuota              : unlimited
LocalReplicaAgeLimit           :
MailEnabled                    : True
MaxItemSize                    :
Name                           : Auto Reply
ParentPath                     : \Provaltech - Internal
PerUserReadStateEnabled        : True
ProhibitPostQuota              :
Replicas                       : {Public Folder Database 1689825814}
ReplicationSchedule            : {}
RetainDeletedItemsFor          :
UseDatabaseAgeDefaults         : True
UseDatabaseQuotaDefaults       : True
UseDatabaseReplicationSchedule : True
UseDatabaseRetentionDefaults   : True
FolderType                     :
HasRules                       : False
HasModerator                   : False
Identity                       : \Provaltech - Internal\Auto Reply
MapiIdentity                   : \Provaltech - Internal\Auto Reply
OriginatingServer              : vexchange.provaltech.in
IsValid                        : True



[PS] C:\Windows\system32>






0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34101921
Ok, and what happens when you try to add the public folder to the distribution group? you said "no luck" before which is extremely vague - Can you not find the object or does it give an error?
0
 

Author Comment

by:ProVal
ID: 34101944
When i am trying to Add from ad then donot found the public folder..
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34102145
Ok, try this:

Go into ADUC, go to view and click 'Advanced Features'. You should now see 'Microsoft Exchange System Object' container. In here you should be able to see your Public folder, right click on this and go to properties, then you should see the Member of tab and be able to add it through there.
0
 

Author Comment

by:ProVal
ID: 34102841
Yes i am able to see but their is Member OF tab coming when i am opening the properties...
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34102919
That's correct... So add the distribution group to 'Member Of', that will do the same thing.
0
 

Author Comment

by:ProVal
ID: 34103030
Sorry i wanted to say that the member of tab is not coming....by mistake i have typed that it is coming..
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34103197
Could you please provide a screenshot showing the ADUC tree and the properties of the Public Folder you have created.
0
 

Accepted Solution

by:
ProVal earned 0 total points
ID: 34103251
Please.
Untitled.jpg
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34104064
I would delete that public folder and start again as it seems something has been missed. I have just re-created this and did not have that problem.

I'm not sure I can be anymore help than that, good luck :)
0
 
LVL 2

Expert Comment

by:ConanUK
ID: 34119588
There are other ways to get to this tab which I have described, it seems the guide/advice was not followed correctly. I replicated this on my test servers and easily managed to add the public folder to the required group.
0
 

Author Comment

by:ProVal
ID: 34119614
Menas overall scenario is that we have to add this public folder under the DL member tab..i think when a mail be sent to DL email id then a copy of that mail is also received by the public folder then those rule will triggered that is created on the Public folder from outlook ........am i right ?


0
 

Author Closing Comment

by:ProVal
ID: 34153242
Actually above article can worked bettor for exchange server 2003 because you can easily find the tab Member of tab on public folder properties ..................but in exchange server 2007 member of tab appears but there is no button appears from where you can add Distribution List but in exchange server 2003 very easily..........
0

Featured Post

Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now