SBS 2008 - No computers Available

Hi,

I've gone through a bunch of websites trying to find an answer to my problem...and although there are a lot of people with the same problem, none of the answers have been able to help me.

Like the title says, users in my SBS 2008 domain get the "No computers are available" on RWW.

Facts:
- All computers were joined to the domain using the Connect wizard
- All users are local admins
- Users appear on their own machine in the Remote Users group
- I have ran the Fix My Network wizard
- I have ran the Change Role wizard
- I have ran SBS BPA

Help? :(
zig0Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Rob WilliamsConnect With a Mentor Commented:
Were the users created in the SBS console, or Active Directory? If the latter go to the SBS console | Users | lower right and select "Change user role for user accounts". Apply to the necessary users (standard user is fine) and see if that resolves. Users need to be created with the wizards. If they were created with the wizard, running the change role wizard again will not hurt unless you have created additional custom roles.
0
 
Rob WilliamsCommented:
If you opens the Windows SBS console and go to Network | computers | properties of one of the computers to which you are trying to connect | user access | highlight a user | does it show below a check mark next to "can log on remotely to this computer"?
0
 
zig0Author Commented:
Yes, it does.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
zig0Author Commented:
The users were all created using the wizard in SBS console and as I stated initially, I have ran the Change Role wizard again (and I have tried again on 1 user before answering this) on multiple users and it had no effect... besides resending the welcome e-mail from SBS.
0
 
Rob WilliamsCommented:
Sorry missed where you already ran the latter wizard.
0
 
Rob WilliamsCommented:
The only other thought I would have is if it is a migration, rather than a clean install, which doesn't sound as if that is the case, a group policy from the previous server could have been inherited. There are 5 locations where this could be, but extremely unlikely on a clean install.
0
 
zig0Author Commented:
The workstations came from the old Windows 2000 domain. The SBS 2008 server is a fresh install...the computers were recently added. There has been some tweaking in the default GPOs...but it was related to password policy and browser customization...so I can't think they are related. I've ran rsop on one of the workstations and I can't seem to find anything wrong.
0
 
zig0Author Commented:
I have just changed a user role to Network Administrator and now the list is populated. There must be something blocking the list being populated for users with the Standard User role.
0
 
Rob WilliamsCommented:
Check again in the console under users and groups | user roles |properties of standard user role | Remote access |  make sure "this user can access RWW" is checked.
0
 
zig0Author Commented:
The standard user role has the "this user can access RWW" option checked.
0
 
Rob WilliamsCommented:
Very odd. I can't think of anything else at this point.
0
 
zig0Author Commented:
Maybe something to do with NPS? Or the way the TS gateway is configured? I'm tottaly lost....everyone else seems to get a solution...but for some reason nothing works on my end. It's a permissions thing surely...since the network admins get the full list but the standard users don't...but where?!
0
 
Rob WilliamsCommented:
That is why I would have thought it was this issue pointed out in my first post.

Unlikely it is NPS as that is more for VPN connections, however you could check the 3 policies in the TS gateway manager under administrative tools | Terminal services. All 3 policies should show the authorized group as "domain users". If that were changed to something like domain admins it would cause problems similar to yours.

Just to confirm membership again, in a different place, check SBS console | users and groups | groups | general | are the users listed?
0
 
zig0Author Commented:
You didn't mention it, but I guess you mean in the "All Users" group..and yes, they are all listed there.
0
 
Rob WilliamsCommented:
"All users group"? Where are you seeing this? In the two TS Gateway manager consoles I looked at it had "domain users", though the other should work, and in the latter, sorry I left out "Windows SBS Remote Web Workplace Users" group:
SBS console | users and groups | groups | Windows SBS Remote Web Workplace Users | general | are the users listed?
                                                                                                        ^
0
 
zig0Author Commented:
I'm sorry I answered without explaining my self.

The "All users" I mentioned is related to what you asked me to check in the SBS console...I thought you wanted me to check that group. In the RWW Users group, all the users are listed aswell.

In the TS Gateway manager, I also have "Domain Users" in the policies.

Back to square one... :(
0
 
Rob WilliamsCommented:
Very odd. I am running out of ideas.
0
 
zig0Author Commented:
I have been trying to investigate this issue by going through similar problems reported by other users around the web...I can't seem to find a solution to this.
0
 
Rob WilliamsCommented:
The following site has a good list of connection and authorization issues, but I think we have covered any that apply to your problem.
http://blogs.technet.com/b/sbs/archive/2009/06/19/common-remote-web-workplace-rww-connect-to-a-computer-issues-in-sbs-2008.aspx
0
 
zig0Author Commented:
I'm going to go through them to see if anything is missing. I'll get back to you on that asap.
0
 
zig0Author Commented:
Well...I'm happy to say that the problem is solved. Although I have no idea what the solution is... the last action I took on this matter was, for the second time, reapplying the user's group membership in the SBS Console. Apparently it started working.

However, the RWW does not work from within the organization. I was testing it right now internally and the users get the "No computers are available" message, but when they connect from outside the organization they can connect directly to the computer that I set them up with. I do not know if this is a normal behaviour for the RWW feature...but it sure as hell made me feel dumb as I have been testing it from the internal network.

Is this normal for RWW? The network admins still get the hole computer list but the users get the "no computers" message.
0
 
Rob WilliamsCommented:
It should work fine from the LAN as well.
0
 
zig0Author Commented:
For now, I don't think that being unable to access RWW from within the LAN is an issue, so I'll close this question for now.
0
 
zig0Author Commented:
For some reason, reapplying an already known solution worked.
0
 
Rob WilliamsCommented:
What was the "already known solution "?
0
 
zig0Author Commented:
What apparently worked for me was running the "Change user role" wizard for the second time.

Thank you for all the help Rob.
0
 
Rob WilliamsCommented:
Good to know zig0 however I suggested that in the beginning  http:#a34095379
Perhaps it didn't work the first time but it was apparently correct and you state that is what solved the problem. I don't think accepting your answer is correct or fair. Even closing the question and refunding points would be more appropriate.
If you agree you can click the "request attention" link in the question area and the moderators can reopen the question for you.
Thanks.
 --Rob
0
 
Rob WilliamsCommented:
Thank you zig0. Very much appreciated.
Cheers!
--Rob
0
 
zig0Author Commented:
You're welcome.

Great service you got here :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.