We help IT Professionals succeed at work.

How do I get server time from my firewall?

Last Modified: 2012-05-10
I support a Windows AD domain: 1- Win 2003 Enterprise srvr, 1- Windows 2003 Std server, 35 workstations xp, vista, win7, one Sonicwall TZ210W firewall

I setup my firewall to get time from internet timeservers. Now how do I set my Windows 2003 Enterprise server (which is the PDC Emulator) to get time from the Sonicwall?

My sonicwall has an IP of
Watch Question


The best way to do it, is to estrictly follow this KB from Microsoft:
Unless they came out with a new OS, a sonicwall tz210 is not a NTP server. You can setup you server to sync outside though.

Follow this link: http://technet.microsoft.com/en-us/library/cc784553(WS.10).aspx
This one is on us!
(Get your first solution completely free - no credit card required)
After all this, dont forget to verify the configurations by using

w32tm /monitor

and to verify the other domain controllers (the PDC FSMO one will be the master) doing:

w32tm /resync /rediscover


Hi thiagotietze:

I tried your solution and started receiving these messages in the system event log:
The time provider NtpClient is configured to acquire time from one or more time sources, however none of the sources are currently accessible.  No attempt to contact a source will be made for 15 minutes. NtpClient has no source of accurate time.


I ran the two commands. Here is the output:
Microsoft Windows [Version 5.2.3790] (C) Copyright 1985-2003 Microsoft Corp.

C:\>w32tm /monitor
hpm1.xxxx.ads []:
    ICMP: 0ms delay.
    NTP: +21.2220951s offset from hpm3.xxxx.ads
        RefID: time.nist.gov []
hpm3.xxxx.ads *** PDC *** []:
    ICMP: 0ms delay.
    NTP: +0.0000000s offset from hpm3.xxx.ads
        RefID: 'LOCL' []

C:\>w32tm /resync /rediscover
Sending resync command to local computer...
The computer did not resync because no time data was available.

The services have been restarted with sucess?
If yes, try to unregister and re-register the service....

net stop w32time

w32tm /unregister
w32tm /register

net start w32time

If not works yet, are you able to restart the server?


I just ran that with no errors, but this came into the system log:

Event Type:      Warning
Event Source:      W32Time
Event Category:      None
Event ID:      12
Date:            11/9/2010
Time:            3:19:16 PM
User:            N/A
Computer:      HPM3
Time Provider NtpClient: This machine is configured to use the domain hierarchy to determine its time source, but it is the PDC emulator for the domain at the root of the forest, so there is no machine above it in the domain hierarchy to use as a time source.  It is recommended that you either configure a reliable time service in the root domain, or manually configure the PDC to synchronize with an external time source.  Otherwise, this machine will  function as the authoritative time source in the domain hierarchy.  If an external  time source is not configured or used for this computer, you may choose to disable  the NtpClient.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
yes, it is just informing that this machine will assume as an authoritative server...

It is working :-)


I'm still getting the same w32 errors as before.


Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.