Word stops listing the most recent files

On a Win7 workstion of a Windows 2003 AD domain with the Word 2007 icon pinned to the taskbar.

This pc has been installed about 4 fourths. up until about a month ago, when you put your cursor over the word icon, it would display the last 15 ot 20 files accessed. Now it only shows two, even after opening and editing additional word files.

The only way we can see a complete list of the most recent files is by opening word and clicking the orange icon next to File.

How do we fix this?
LVL 25
Tony GiangrecoAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
TAMUGConnect With a Mentor Commented:

In Word 2007:

Click on the Office button, then on Word Options, then Advanced
Scroll down to the Display section
Set the value for Show this number of Recent Documents
 
Recent Documents
The option to change the number of recent documents may be unavailable, “grayed out.” In that case, Windows itself is preventing the display of a recent documents list. To
see if recent documents are disabled everywhere:

Click Start, then Run
Enter regedit
Navigate to the following registry entry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Policies\Explorer

In the right-hand pane, see if there is a DWORD named “NoRecentDocsHistory”. If there is, either delete it or set its value to zero. Then close regedit and reboot.
0
 
brd24gorCommented:
Try deleting the files here and see if it starts working again: %AppData%\Microsoft\Windows\Recent\AutomaticDestinations

More than likely there is one or more files corrupted in this director.
0
 
Tony GiangrecoAuthor Commented:
Perfect
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.