?
Solved

Permissions tab missing in Outlook / Exchange 2010 public calendar

Posted on 2010-11-09
12
Medium Priority
?
5,481 Views
Last Modified: 2012-05-10
I am the Sys Admin of my organization and I need to adjust the permissions for a public calendar.  It was my understanding that all public calendars granted Author permission to all but anonymous users, but I have a group of users that can add items, but cannot edit or delete their own items.

I have 4 calendars in a folder called Department Calendars which is inside the Public Folders.  When I right click on 2 of them and go to Properties (in Outlook), I get three tabs: General, Home Page, and Summary.  When I right click on the other two I get General, Home Page, and Permissions.

I need to edit the permissions of them all.  What is the difference between these two sets of calendars?  Why are 2 giving me the Permissions tab and 2 not?  How can I edit the permissions of the 2 that do not give me the Permissions tab?  What do I need to set or edit in Exchange so that I can get that tab?

Thanks,
Jono
0
Comment
Question by:Jono Martin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 4
12 Comments
 
LVL 15

Expert Comment

by:JBond2010
ID: 34096350
Example: Add-PublicFolderClientPermission -User jimmy -Identity \AVH -AccessRights Owner
0
 
LVL 15

Expert Comment

by:JBond2010
ID: 34096357
The easiet way is to log in to Outlook with the account you used to set up the public folder (administrator).  Find the public folder and right click on it and select properties.  You should see a tab that says 'Permissions'.  You can control access to the folder from there.
0
 
LVL 15

Accepted Solution

by:
JBond2010 earned 2000 total points
ID: 34096362
Try the following command  Add-PublicFolderClientPermission -Identity "\public folder name" -AccessRights Owner -User username
substitute "\public folder name" for the one you're trying to give access to and username for the user you're trying to give access, or give the administrator account a mailbox and then go into public folders, right click on the public folder in question and select permissions. Add the user and give them the required permission.(editor)
1
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 15

Expert Comment

by:JBond2010
ID: 34096367
0
 

Author Comment

by:Jono Martin
ID: 34096689
Hi JBond2010.  Thanks for the reply.  I am trying to add my user ID into the powershell cmdlet you gave and I got this error:
"The term 'Add-PublicFolderClientPermission' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again..."

Could there be a syntax error there?  Should I be entering this into another place other than the powershell?

I just upgraded from Exchange 2003 to 2010 and I am not at all familiar with it.  It seems that in 2003, things were pretty intuitive; I'm lost in 2010.

Thanks for your help.
0
 
LVL 15

Expert Comment

by:JBond2010
ID: 34096750
You can do this through the EMC - Exchange Management Console and the Powershell. Make sure you have Service Pack 1 installed for Exchange 2010.
0
 

Author Comment

by:Jono Martin
ID: 34096845
I don't have SP1 installed.

It's amazing to me (and I guess this is my frustration talking) that it's so difficult to set permissions on a folder in Exchange 2010.  With 2003 I could just go to that folder and do it right in Exchange.

There certainly has to be a way to set these permissions in Exchange 2010 without SP1, and a GUI solution would be preferable.  Is that just something that was left out, requiring SP1?
0
 
LVL 15

Assisted Solution

by:JBond2010
JBond2010 earned 2000 total points
ID: 34096920
Be sure to install service pack 1. The commands I provided in my previous comments should work for you.
0
 
LVL 15

Expert Comment

by:JBond2010
ID: 34096942
Did you check this link from Microsoft
http://technet.microsoft.com/en-us/library/aa997986.aspx

0
 

Author Comment

by:Jono Martin
ID: 34096957
I did look at the link, but it applies to SP1.  I guess that command only exists in SP1.

Was there no way to set permissions on a calendar prior to SP1?  This seems to be a very rudimentary task.  Why is it so difficult to do in Exchange 2010?
0
 
LVL 15

Expert Comment

by:JBond2010
ID: 34096978
That's it. So, install service pack 1 and this should hopefully work for you.
0
 

Author Closing Comment

by:Jono Martin
ID: 34145368
I apologize for the delay on this.  I still have a legacy 2003 Exchange server and I was able to just go in there and take care of it.  I'll be installing SP1 this weekend and getting rid of the legacy server.

Anyway, points awarded.

Jono
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses
Course of the Month10 days, 11 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question