Solved

Web Cam

Posted on 2010-11-09
29
1,898 Views
Last Modified: 2012-05-10
How can i watch my ip camara from internet if my  ISP blocking  port 80 in my WAN router ??


LAN router ----> WRT160Nv2
WAN Router --- > ???

IP CAMARA ---> WVC54GC  (i got 3 camaras working)
ip-router.jpg
0
Comment
Question by:felny
  • 12
  • 9
  • 4
  • +1
29 Comments
 
LVL 35

Assisted Solution

by:Ernie Beek
Ernie Beek earned 100 total points
ID: 34096420
What makes you think that your provider is blocking a port?

Looks to me that your trying to log on to your router by the looks of the screendump.
0
 
LVL 2

Author Comment

by:felny
ID: 34096431
What do you want me to show you?
0
 
LVL 2

Assisted Solution

by:SacTechGroup
SacTechGroup earned 100 total points
ID: 34096461
If your ISP is blocking 80, to prevent home users from hosting websites, then you need to change your webcams to ports other than 80.  Most allow this.  Choose a high port number like 8080, 8081 etc for each cam.  then in your web browser go to yourip:8080 or register at dyndns and got to dyndnsname:8080
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34096469
Nothing yet. If I ping camaraip2.zapto.org it resolves to 192.168.1.104.....

That's a private ip address which can't be routed over the internet. So this means that you are not getting to your camera over the internet but to an adsl router on you own network with that address.
0
 
LVL 7

Accepted Solution

by:
compaqus earned 300 total points
ID: 34096494
Erniebeek is right, your router is responding on 80.

You have to tell your router to forward request on 80 to the IP of the camera.

From Applications and Gaming, single port forwarding.
Each camera should be set to broadcast on another port, you can forward to only one camera at once...
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34096509
camaraip2.zapto.org should resolve to your public IP.

Then you tell your router to forward the request to the IP you need.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34096536
@compaqus
I tend to think that there's something wrong with DNS. If felny wants to connect to his camera over the internet he needs a public ip hooked up. I mean, the firewall behind which the camera is, should forward port 80 from it's public ip to the camera and tha DNS name of the camera should resolve to that public ip address.

Am I making sense here (nobody lost in translation yet)?
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34096542
@compaqus

Correct (you type a lot faster :-~
0
 
LVL 2

Expert Comment

by:SacTechGroup
ID: 34096999
All above is pretty much correct.  You have to do 2 things: forward the port you want to use from the outside of the firewall to the inside And then change your dynamic dns registration to point to your public ip.

I don't recommend port 80 as it is the most attacked port.  You will need a port for each camera.  Get your port forwarding set up then test it by going to your wanip:port.

Once you get it working by ip then fix your dns registration
0
 
LVL 2

Author Comment

by:felny
ID: 34097461
it is imposible, is NAT over NAT...   I can't change wan router
0
 
LVL 2

Author Comment

by:felny
ID: 34112977
My public Ip is 190.153.57.XX,  in my dyns account is 190.153.57.XX:1554, even so, the router adsl askme for a user and pw, somebody toldme that trigggers in LAN router can pass trough that wan router, it is posiblle to configure my ipcamera over triggers port?
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34113186
The router asks you for a password because there is no rule on how to forward the port, and it defaults to 80.
You cannot have a DNS entry that includes the port.

Here are the steps:
1. Go to the dynamic DNS service (zapto?) and set your public IP  (190.153.57.XX ) to resolve to the name you have chosen (camaraip2.zapto.org) - right now it resolves to 208.51.78.252
2. Login to your router and forward the ports to the local IP's.
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34113228
       2.1.    cam1 - 192.168.2.22 - port 8081
        2.2     cam2 - 192.168.2.23 - port 8082
3. Setup the cameras to broadcast on their assigned ports.
4. access the camera by pointing the browser to
http://camaraip2.zapto.org:8081 (for cam1... etc)
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34113268
You can leave the DNS part and use the public IP to test until it works.
http://190.153.57.XX:8081  ;8082  and so on
0
Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

 
LVL 2

Author Comment

by:felny
ID: 34113871
Hi Compaqus, i aprecciate your help..    I did everystep that you told me, but when i write

http://edwjel.gotdns.org  ----> It askme for user & Password

http://edwjel.gotdns.org:8081/ This direction doesn't exist..

Please, cheek the image belong to  devices
No-ip.jpg
2.jpg
3.jpg
4.jpg
0
 
LVL 2

Expert Comment

by:SacTechGroup
ID: 34114367
forget the DNS (for now), one step at a time

Get it working by IP address first!! Then add the DNS layer after its working by IP.

I would say no to the Port Trigger idea.  Port triggers are typically for applications that are inside your firewall, that when active, trigger the firewall to allow them out and return traffic back.  What you are doing needs to be a static config.

you need to port forward your chosen ports to your internal IP's
you said..
"2.1.    cam1 - 192.168.2.22 - port 8081
 2.2     cam2 - 192.168.2.23 - port 8082"

so on your firewall forward 8081 from the WAN to 192.168.2.22 (.22 should be statically assigned or DHCP reserved, it cant change or your setup will break)

to test your port forward go to http://190.153.57.XX:8081.  If it doesnt work your forwarding is not correct, If it does then go back to setting up DyNS

you said...
"My public Ip is 190.153.57.XX,  in my dyns account is 190.153.57.XX:1554, even so, the router adsl askme for a user and pw, somebody toldme that trigggers in LAN router can pass trough that wan router, it is posiblle to configure my ipcamera over triggers port?"
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114379
I see your router and your IP cameras are on a different subnet.
the router  is 10.10.5.1 and the cameras 192.168.x.x
Change the IP of the cameras to a free one from the 10.0.5.x range
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114429
Do you have anything else there except the router? An adsl modem perhaps? That one has to forward too.
0
 
LVL 2

Author Comment

by:felny
ID: 34114440
Compaqus, please read well my last post....    My internal LAN is 192.168.1.x.  my cameras are working fine...
    i can't see the cameras from my house or another location out of my officce..  
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114477
Why am I seeing 10.10.5.2 as your internet connection? I suspect you have another adsl modem there.

To see the cameras from the internal network use http://192.168.1.104:8081
do you see it like this?
0
 
LVL 2

Author Comment

by:felny
ID: 34114536
of course, i've aready  told you i have a adsl router, i mean the isp wan router...     i don't have user $ pw to modificate it...   Is there any other way to do that?
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114556
Ok.
Let's start over.

Is this layout correct?

IPcamera-------<------wireless router------<-----adsl modem---<---internet

You say your cameras are working but you cannot see them from your house. Is your house on the same lan as the cameras? From outside it;s impossible to see them if you have another ADSL modem until you tell it to forward too.

From the inside, when you use the domain name, and not the IP(192.168.1.x) it will go via internet, not directly to the camera as it will go out, ask the dns and try to connect to your public IP. That is your ADSL modem or router, not the camera.
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114599
My mistake, I understood that the ADSL router is the wireless router itself, not that there are 2 separate things...

You could reset the adsl modem if you have the username and password so you'll be able to set it up again.

Unless  that one forwards too, everything is stuck there.
0
 
LVL 2

Author Comment

by:felny
ID: 34114606
Exactly....

IpCamera --->Lan Router -----> ADSL Modem ------> Internet

I can see my camera inside of my office, but not from my house...  My house is another network with another ISP.    in fact, i wooud like to watch my cameras from any city where i am..

my public IP is ---->  190.153.57.10
my lan ip is ------->    192.168.1.xxx



0
 
LVL 2

Author Comment

by:felny
ID: 34114624
jejeje, i JUST can't do that.. i don't know the DNS, THE SUBNET, the internal configuration of my ISP...
0
 
LVL 2

Author Closing Comment

by:felny
ID: 34114665
Thank all you peopple fro helpme, if you have the solution of this problem, please, let me know to open a good accurate question...
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114705
You can reset the modem, that will let you choose another password for it.

You just need from your provider the username and password for your ADSL account.
All(almost) ADSL modems have a reset button that will get it back to the factory settings. It's a few minutes job to set it up again.
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34114824
", i JUST can't do that.. i don't know the DNS, THE SUBNET, the internal configuration of my ISP..."

Usually (pppoe) you only need this:
DSL user name
DSL password
Encapsulation
VPI:
VCI:
The ip, dns, gw, are received via DHCP. And even  if you have ip static, it's not that complicated. But you do have to call the provider to ask that info. And they have to give it to you.

Sorry we couldn't help you more now...
0
 
LVL 2

Expert Comment

by:SacTechGroup
ID: 34115267
If the ADSL WAN router from your ISP has a firewall (which it likely does) then you must have the user/pass to login and modify it to forward the desired ports to the camera.

The only work around (i can think of) is to use a computer that is allways on, inside your office, as a remote access system.   You could use logmein or go to my pc etc as thes work over the internet without modifying ports on the firewall.  Install the software on your desired computer and create the account on the providers website (logmein/gotomypc).  Now you can go home or anywhere and access that PC in your office and use that PC in your office to look at your cameras.  The refresh rate wont be that great on the live feed but it will work.  A lot of these cameras also support email.  You could create a new gmail account for example and have them email a motion activated picture every 10 seconds or something and then just check that email account to see if there has been any activity in the office.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now