install ruby gem behind ISA

I am trying to install ruby gem behind ISA but I keep getting the following:

Error: Http://gems.rubyforge.org/ does not appear to be a repository
Error: could not find gem rails locally or in a repository


anybody knows how to fix this?

thanks
winperezAsked:
Who is Participating?
 
JESiiConnect With a Mentor Commented:
OK; let us know how that goes...
0
 
JESiiCommented:
I think now it's http://rubygems.org
0
 
JESiiCommented:
Also, on the Mac, you can just go to Terminal and try some of the commands ther:
Sorry; I don't know anything about MS Forefront; it might also be a configuration setting there.

  gem list     <== this lists the local gems
  gem list -r  <== this lists (a lot of) remote gems
  gem install <gem-name>
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
winperezAuthor Commented:
I can connect to ruby gems if I try from a computer not behind the firewall with the command below
Sudo gem install rais

But I can't connect when I try from a Mac behind the firewall
0
 
JESiiCommented:
This link:
  http://stackoverflow.com/questions/4418/how-do-i-update-ruby-gems-from-behind-a-proxy-isa-ntlm
has a couple of answers about setting up a proxy to get through the firewall.
0
 
winperezAuthor Commented:
we have two ISAs  2000 and 2006.  the updates can be installed from ISA 2000, but not from 2006. where is the setting in ISA2006 that need to change.
0
 
JESiiCommented:
What system are you running?  If you're on Linux or Mac, you would update your .bashrc file (that's the file that is run as part of your startup in Linux or when you start Terminal in Mac. This previous question and the answer might help you out in this case: http://www.experts-exchange.com/Programming/Languages/Scripting/Ruby/Q_26578638.html?sfQueryTermInfo=1+10+30+bashrc+jesii

If you're on a Windows machine, you'd need to set your environment variables (Right-click on Computer, select Properties and there will be a button for "Environment Variables" where you can set the value as described in the previous link describing the proxy settings.

I've not done this myself so I can't guarantee this will work, but it seems to me to be a reasonable approach.  Hope this helps.
0
 
winperezAuthor Commented:
I am using Mac. installed socks 5 and that doesn't work either
0
 
JESiiCommented:
Firewalls are crazy/complex beasties, as I'm sure you know. If you don't have a security administrator to help you that's tough. Are you the one trying to configure the firewall?

In any event, it looks like you might have to set firewall policy rules... possibly in the "Non-web server protocol publishing rule" (see image - just above the selected item). ISA firewall policy rule configuration or possibly with the generic "Access Rule" wizard.  See http://www.linglom.com/2008/01/07/getting-started-with-microsoft-isa-server-2006-part-iii-create-firewall-policy-rule/ for a little more about that.

If that doesn't help, I'm tapped out... sorry.
0
 
winperezAuthor Commented:
I am getting the following on the ISA 2006

first line
destination: xx.xx.xx.xx
destination port:80
protocol: HTTP
Action: Initiated Connection
Rule: My Rule
Client IP: my IP
Client Username: blank

second Liine:
destination: xx.xx.xx.xx
destination port:80
protocol:blank
Action: Closed Connection
Rule: My Rule
Client IP: my IP
Client Username: Anonymous


third line
destination: xx.xx.xx.xx
destination port:80
protocol: HTTP
Action: Closed Connection
Rule: My Rule
Client IP: my IP
Client Username: blank




0
 
JESiiCommented:
OK... have you checked out what the "My Rule" rule says? Here's a description of the "Rule" field, found at http://technet.microsoft.com/en-us/library/bb838824.aspx#WebProxyFilterLogFields.  "Rule" field description
0
 
winperezAuthor Commented:
My ISA firewall may have configuration problem. I need to reconfigure this
0
 
winperezAuthor Commented:
I did everything you told me to do, but still couldn't get rubygem to install behind the ISA. my only solution was to add another soniwall firewall and skip the proxy.

thanks for trying to help out
0
 
JESiiCommented:
I'm really sorry that didn't work out, but glad that the at least were able to do what you wanted to do. Thank you for the opints.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.