VMWare Player slow shutdown in Windows 7 Enterprise

Hello.

I am running Windows 7 Enterprise 64-bit and VMware Player version 3.1.2.

The virtual PC works fine up to the point where I shut down. After the virtual PC is shut down, the host is unusable for the next 5 minutes. Everything slows down almost to a halt.

I'm using a fairly big image(23GB). I always put the PC to sleep by closing the vmware player, I never use the shutdown-button in the guest-OS.

Are there any compatibility issues with vmware player and windows 7 64-bit? Are there any options that I could set to make the shutdown speedier that don't affect the performance?
LVL 1
nebb-tgrAsked:
Who is Participating?
 
justadadConnect With a Mentor Commented:
I assume that the guest is not really shutting down but paused so that when you start VM the next time you start where you left off. If that is the case, when you close VMPlayer it needs to write the memory of the guest to the HDD so that it is there when you start it up again.  The size of the guest virtual HDD is not as much a factor as the guest memory in this case. If it is taking a long time to shutdown I would suspect 2 things.
1. Your configured memory for the guest is large. You could decrease it making it just large enough for all of your programs installed it the guest to work well. I would try 1GB or less to see if that makes a difference.
2. Your HDD is very slow or very fragmented. As it needs to write a copy of the memory to the disk, if the disk is fairly fragmented and there is not a contiguous space for the memory file then the write can take much longer. I would suggest shutting the guest down using the shutdown in the guest 1 time and then running a defrag on your main HDD. Then starting up your guest and try closing VMPlayer to see if it closes much faster.
0
 
tausifsfaridCommented:
Hi,

You can try this new release: http://www.filehippo.com/download_vmware_player/ 

It works well, by the way how much RAM did u have?
0
 
nebb-tgrAuthor Commented:
That sounds very reasonably justadad. The guest OS uses a lot of RAM, and there is a SQL server running on it that consumes most of that. Since I can't allow myself to allocate less RAM to the guest OS, I will give defragmenting a go. I also disabled anti-virus scanning for the directory that contains the image.

I run defragmentaion once a week, but the guest OS is usually just "put to sleep", this could possibly contribute to the issue.
0
 
justadadCommented:
I forgot to mention disabling anti-virus for the directory. Glad you caught it for future readers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.