Solved

username/password not working for my FTP server setup on iis7, windows 2008

Posted on 2010-11-10
25
7,148 Views
Last Modified: 2013-12-09
Hi,

I have setup an IIS FTP on windows server 2008 using link http://www.trainsignaltraining.com/windows-server-2008-ftp-iis7/2008-04-25/.

Only change done is i have selected basic authentication and specified the user test1. I have created a local user called test1.

When i access this site from outside this server pop up comes asking username/pwd. when i enter test1/welcome nothing happens. pop comes back again.

can someone tell whats the wrong step ?
0
Comment
Question by:anuboggaram
  • 12
  • 7
  • 2
  • +1
25 Comments
 

Expert Comment

by:MagicalTrevor
ID: 34100092
try domainname/username and see report back what happens.
Are you at LAN with the server?
0
 

Author Comment

by:anuboggaram
ID: 34100105
Server is on cloud and no domain is setup. its an independent server.
0
 

Expert Comment

by:MagicalTrevor
ID: 34100119
I would recommend removing the FTP site you created, and use the following guide:
http://learn.iis.net/page.aspx/303/adding-ftp-to-a-web-site/
Just ignore the part after "Adding FTP Publishing by Editing the IIS 7.0 Configuration Files" unless thats something you want.

This is the guide i used when setting it up the first time.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:anuboggaram
ID: 34100513
Did it but same problem is persisting in this method also.
0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 34195561
hi anu,

have you tried logging in locally as suggested in the last article posted by magicaltrevor and can you confirm if you are able to logon to the ftp site locally. If that is working and the issue is only with logging to FTP site externally...

Ensure that Firewall is totally turned off for public/private/domain profiles initially.

from the remote machine open command prompt and try telnet to ftp port to verify if there are any firewalls still in between..


telnet machinename:21 if you see a blank window after that then there are no firewalls.

now within the browser IE 7/8 ensure that "enable FTP folder view) under tools>>options>>advanced is checked.

If you are using Vista/Windows7/Win2008 R2 then ensure that LMcompatibility level is set to 2/3

http://support.microsoft.com/kb/820281

regards
Bhanu
0
 

Author Comment

by:anuboggaram
ID: 34196137
Hi I am able to connect to FTP locallly. Please find below results.

C:\>ftp localhost
Connected to websrv-1010.
220 Microsoft FTP Service
User (websrv-1010:(none)): administrator
331 Password required for administrator.
Password:
230-User logged in.
 Win32 error:   The operation completed successfully.
 Error details: File system returned an error.


When i access the site from outside or externally username\password windows comes up. After entering the same administrator and password it does nothing. it asks for username password again and again.

Since the server is an instance on cloud i have added the port numbers on security group
tcp          20        20      0.0.0.0/0
tcp          21        21       0.0.0.0/0

What might be the problem?
0
 
LVL 23

Accepted Solution

by:
bhanukir7 earned 250 total points
ID: 34197266
did you try telenet test....

if the password is continuously popping up that is a LMcompatibility issue. please follow the MS KB and change the registry value on your machine...i think it might be a vista/windows 7 box.

regards
bhanu
0
 

Author Comment

by:anuboggaram
ID: 34203368
Bhanu,

Did changes as per MS KB to 2. No idea why but ftp is not working internally today. It gives error as:

C:\Users\Administrator>ftp localhost
Connected to websrv-1010.
220 Microsoft FTP Service
User (websrv-1010:(none)): ftptest
530-Valid hostname is expected.
 Win32 error:   No such host is known.
 Error details: Hostname didn't match any configured ftp site.
530 End
Login failed.
ftp>

Please help me out.
0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 34209144
hi Anu,

pls confirm if you have made the changes on your client machine or on the host machine. can you post the ftp access log and also confirm if FTP service is running fine on the cloud machine.

The MS article was for making changes on client machine if that is windows 7 / Vista / 2008 and not for the FTP machine.

regards
bhanu
0
 

Author Comment

by:anuboggaram
ID: 34210984
Bhanu,

Please find below log file details. I did the changes on client PC as said but no luck.


#Version: 1.0
#Date: 2010-11-25 06:12:32
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2010-11-25 06:12:32 10.245.135.32 GET /login.aspx ReturnUrl=%2fDefault.aspx 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 1287
2010-11-25 06:12:32 10.245.135.32 GET /site.css - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 280
2010-11-25 06:12:33 10.245.135.32 GET /Footer.css - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 486
2010-11-25 06:12:35 10.245.135.32 GET /images/afs.jpg - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 1797
2010-11-25 06:12:35 10.245.135.32 GET /favicon.ico - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 404 0 2 278
2010-11-25 06:19:06 10.245.135.32 POST /login.aspx ReturnUrl=%2fDefault.aspx 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 302 0 0 642
2010-11-25 06:19:07 10.245.135.32 GET /Site.css - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 278
2010-11-25 06:19:07 10.245.135.32 GET /Default.aspx - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 1623
2010-11-25 06:19:08 10.245.135.32 GET /WebResource.axd d=jn4M1Rn7cYjo85vjOEJMog2&t=633750451411712030 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 1398
2010-11-25 06:19:08 10.245.135.32 GET /images/searchSymbol.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 343
2010-11-25 06:19:08 10.245.135.32 GET /images/new.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 441
2010-11-25 06:19:08 10.245.135.32 GET /images/home.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 441
2010-11-25 06:19:08 10.245.135.32 GET /images/close.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 465
2010-11-25 06:19:08 10.245.135.32 GET /images/print.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 458
2010-11-25 06:19:08 10.245.135.32 GET /images/reports.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 466
2010-11-25 06:19:08 10.245.135.32 GET /images/topcol.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 458
2010-11-25 06:19:08 10.245.135.32 GET /calendar.gif - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 200 0 0 458
2010-11-25 06:19:08 10.245.135.32 GET /favicon.ico - 80 - 180.151.32.146 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+MDDS;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 404 0 2 296
#Software: Microsoft Internet Information Services 7.0
#Version: 1.0
#Date: 2010-11-25 06:49:36
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2010-11-25 06:49:36 10.245.135.32 GET / - 80 - 180.151.32.146 D:\Tools\url_monitor\responser.pl/0.1+libwww-perl/5.834 302 0 0 720
2010-11-25 06:49:36 10.245.135.32 GET /login.aspx ReturnUrl=%2fdefault.aspx 80 - 180.151.32.146 D:\Tools\url_monitor\responser.pl/0.1+libwww-perl/5.834 200 0 0 616
0
 

Author Comment

by:anuboggaram
ID: 34211726
Bhanu,   i just reinstalled ftp and its working locally from command prompt. when i access it from outside, username\password is taken but the result is "Internet explorer cannot display the webpage".  Below is the logfile content now. thanks in advance.


010-11-25 06:39:39 ::1 - ::1 21 USER ftptest 530 11001 37 7962e128-d9fc-46e6-a3ca-4063157d49b9 -
2010-11-25 06:41:44 ::1 - ::1 21 ControlChannelClosed - - 258 0 7962e128-d9fc-46e6-a3ca-4063157d49b9 -
2010-11-25 06:53:30 180.151.32.146 - 10.245.135.32 21 ControlChannelOpened - - 0 0 e257f0c6-bfba-4eca-95ad-8ef842eb6123 -
2010-11-25 06:53:30 180.151.32.146 - 10.245.135.32 21 USER anonymous 530 11001 37 e257f0c6-bfba-4eca-95ad-8ef842eb6123 -
2010-11-25 06:53:30 180.151.32.146 - 10.245.135.32 21 PASS *** 503 776 0 e257f0c6-bfba-4eca-95ad-8ef842eb6123 -
2010-11-25 06:53:31 180.151.32.146 - 10.245.135.32 21 ControlChannelClosed - - 0 0 e257f0c6-bfba-4eca-95ad-8ef842eb6123 -
2010-11-25 06:53:37 180.151.32.146 - 10.245.135.32 21 ControlChannelOpened - - 0 0 26cb0ad6-7b40-495c-b799-611ebe77c0e5 -
2010-11-25 06:53:37 180.151.32.146 - 10.245.135.32 21 USER ftptest 530 11001 37 26cb0ad6-7b40-495c-b799-611ebe77c0e5 -
2010-11-25 06:53:37 180.151.32.146 - 10.245.135.32 21 PASS *** 503 776 0 26cb0ad6-7b40-495c-b799-611ebe77c0e5 -
2010-11-25 06:53:38 180.151.32.146 - 10.245.135.32 21 ControlChannelClosed - - 0 0 26cb0ad6-7b40-495c-b799-611ebe77c0e5 -
2010-11-25 06:53:51 180.151.32.146 - 10.245.135.32 21 ControlChannelOpened - - 0 0 9c90b092-6586-45c6-b9a0-7ac284b401b9 -
2010-11-25 06:53:51 180.151.32.146 - 10.245.135.32 21 USER administrator 530 11001 37 9c90b092-6586-45c6-b9a0-7ac284b401b9 -
2010-11-25 06:53:51 180.151.32.146 - 10.245.135.32 21 PASS *** 503 776 0 9c90b092-6586-45c6-b9a0-7ac284b401b9 -
2010-11-25 06:53:51 180.151.32.146 - 10.245.135.32 21 ControlChannelClosed - - 0 0 9c90b092-6586-45c6-b9a0-7ac284b401b9 -
2010-11-25 07:00:00 180.151.32.146 - 10.245.135.32 21 ControlChannelOpened - - 0 0 4a2eb1dc-51f6-435a-a5c1-ae8e21d4078b -

0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 34218573
anu,

do you have a default FTP directory, if so verify if the permissions on that are set for this user.....also ensure that your browser is set to FTP folders view in advanced settings.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34220530
Did you try using the format ftp://user:password@ftpservername.domain.tld ?

Or if you'd rather get the prompt, have you told IE to prompt for name/password in the Intranet zone?
e.g. see attached.

InternetOptions-Security-Localin.png
0
 

Author Comment

by:anuboggaram
ID: 34236411
Bhanu,

Root folders have permission to administrator and the users as well. My browser is already setup for FTP folders view.

No idea where is the problem.
0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 34237667
what is the OS running on your desktop/laptop.... and did you try a command line ftp from your laptop/desktop or try using "winscp" and check winscp logs.
0
 

Author Comment

by:anuboggaram
ID: 34237804

I am using Windows 7. From command line it works and shows the list of files as well. Please see below ftp result from my desktop to ftp site.


C:\Users\anuradha>ftp mcubeftp.mcubeit.com
Connected to mcubeftp.mcubeit.com.
220 Microsoft FTP Service
User (mcubeftp.mcubeit.com:(none)): ftptest
331 Password required for ftptest.
Password:
230 User logged in.
ftp>

0
 

Author Comment

by:anuboggaram
ID: 34237924
Tested on windows xp with IE 7 as well. same error.
0
 

Author Comment

by:anuboggaram
ID: 34238173
Hi Bhanu,

Its working now. I just restarted the server.
But now pblm is when i open the ftp site it directly opens without asking username\pwd.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34239075
> But now pblm is when i open the ftp site it directly opens without asking username\pwd.


Did you set IE to prompt for a name/password when in the Intranet zone? (the option circled in red in the attachment I posted.)
0
 

Author Comment

by:anuboggaram
ID: 34245572
Yes. It is set. No idea why this happening.
0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 34247454
disable anonymous logon on the FTP site and verify if that reverts the earlier behaviour or if it prompts for username password and works fine.
0
 
LVL 23

Expert Comment

by:bhanukir7
ID: 34247459
remember to restart the IIS services after the changes and then try connecting from both command line and browser.
0
 

Author Comment

by:anuboggaram
ID: 34257006
Never enabled anonymous logon on this. but still restarted the IIS and checked but no use.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A procedure for exporting installed hotfix details of remote computers using powershell
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question