OCS 2007 R2 - Change Internal URL for Web Component

Hi.

How can I change the Internal URL? I have tried with wbemtest, and the Internal URL in there is allready correct.

 ...
LVL 1
Sum WumAsked:
Who is Participating?
 
BusbarConnect With a Mentor Solutions ArchitectCommented:
     1. Log on to the computer that is running Communications Server 2007 Standard Edition or Communications Server 2007 Enterprise edition by using an account that is a member of the RTCUniversalServerAdmins group or that has equivalent permissions.
      2. Click Start, click Run, type wbemtest, and then click OK.
      3. In the Windows Management Instrumentation Tester dialog box, click Connect.
      4. In the Connect dialog box, type root\cimv2 in the Namespace box, and then click Connect.
      5. In the Windows Management Instrumentation Tester dialog box, click Query.
      6. In the Query dialog box, type the following in the Enter Query box according to the edition of Communications Server 2007 that you are using, and then click Apply:

For Communications Server 2007 Enterprise pool

Select * from MSFT_SIPGroupExpansionSetting where backend="server name\\sql instance"

For Communications Server 2007 Standard Edition

Select * from MSFT_SIPGroupExpansionSetting where backend="(local)\\rtc"
      7. In the Query Result dialog box, double-click the result.
      8. Select internalDLExpansionWebURL, and then click Edit Property.
      9. In the Property Editor dialog box, click to select the Not NULL option.
      10. In the Value box, type the InternalWeb farm URL in the following format, and then click Save Property and Save Object:
https://intenralurl.domain.com/GroupExpansion/Ext/service.asmx
      11. Click Save Object, and then click Close.
      12. In the Windows Management Instrumentation Tester dialog box, click Query.
      13. In the Query dialog box, type the following in the Enter Query box according to the edition of Communications Server 2007 that you are using, and then click Apply:

For Communications Server 2007 Enterprise pool

Select * from MSFT_SIPDataMCUCapabilitySetting where backend="server name\\sql instance"

For Communications Server 2007 Standard Edition

Select * from MSFT_SIPDataMCUCapabilitySetting where backend="(local)\\rtc"
      14. In the Query Result dialog box, double-click the result.
      15. Select internallClientContentDownloadURL, and then click Edit Property.
      16. In the Property Editor dialog box, click to select the Not NULL option.
      17. In the Value box, type the internalWeb farm URL in the following format, and then click Save Property and Save Object:
https://internalurl.domain.com/etc/place/null
      18. Click Save Object, and then click Close.
      19. In the Windows Management Instrumentation Tester dialog box, click Query.
      20. In the Query dialog box, type the following in the Enter Query box according to the edition of Communications Server 2007 that you are using, and then click Apply:

For Communications Server 2007 Enterprise pool
Select * from MSFT_SIPAddressBookSetting where backend="server name\\sql instance"

For Communications Server 2007 Standard Edition
Select * from MSFT_SIPAddressBookSetting where backend="(local)\\rtc"
      21. In the Query Result dialog box, double-click the result.
      22. Select internalURL, and then click Edit Property.
      23. In the Property Editor dialog box, click to select the Not NULL option.
      24. In the Value box, type the internalWeb farm URL in the following format, and then click Save Property and Save Object:
https://internalurl.domain.com/abs/Ext/Handler
      25. Click Save Object, and then click Close.
      26. Click Exit.
0
 
BusbarSolutions ArchitectCommented:
the fqdn should point to the pool or the FE server internally, the pool FQDN will point to the FE IP in single ENT server or the VIP with multiple FE servers.
from what I can see it is correct.
0
 
Sum WumAuthor Commented:
Hi Busbar:

The reason why I want to change is because of our setup and our internal domain name. Back in the days when it was made, my predecessors made a huge mistake in making an internal domain name that already exist as a global domain name, which I suffer under right now.

We have a FE and a Edge server, no reverse proxy. I want people from outside our domain to be able to join meetings in Live Meeting and be able to see whiteboard and shared powerpoint presentations. But right now, they cant because of a certificate issue. We cant get a SAN certificate that contains both the internal URL and the External URL, because our internal domain name is owned by another unknown company.

So right now, my thought was to change the our internal domain to our external domain name on the OCS server and then change my dns records and solve it by doing that. We solved our Exchange 2010 certificate problem by doing something simular to this. Is it possible or is there another way to solve this mess?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
BusbarSolutions ArchitectCommented:
is the internal domain is .com domain, if yes then you are in trouble.
anyhow you can use the external name as the internal one, and create a DNS zone in the internal DNS servers that points to the internal IP.

get rid of the OCS thinking, at the end it is HTTP and DNS :)
0
 
Sum WumAuthor Commented:
No its a .net domain, but its the same :(.

I already have another DNS zone for out external domain name on our internal DNS server. But before I can assign our certificate for our external domain name, I need to change the FQDN in OCS, or am I wrong?
0
 
BusbarSolutions ArchitectCommented:
you are correct make it as the public one comp.domain.com
0
 
Sum WumAuthor Commented:
Do you know how I do that?
0
 
Sum WumAuthor Commented:
Or should I remove my corrent pool and then make it from scratch again?
0
 
BusbarSolutions ArchitectCommented:
don't forget to restart the OCS services
0
 
Sum WumAuthor Commented:
Hi again.

What a great guide you've made there! :). Thanks!!!!

But there is a mismatch between the FE name and out certificate. Out FE name is still ocpool.internaldomainname.net and our certificate is *.externaldomainname.com. Is it possible to change?

0
 
BusbarSolutions ArchitectCommented:
no you cannot use wildcard certificate with OCS.
0
 
Sum WumAuthor Commented:
If I issue a new certificate from our internal CA, will document sharing etc work in Live Meeting?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.