Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Sluggish browsing after IOS upgrade on Cisco 851 router

Avatar of Spanjis
SpanjisFlag for Norway asked on
8 Comments1 Solution799 ViewsLast Modified:
After upgrading to Version 12.4(15)T14, RELEASE SOFTWARE (fc2) the internet browsing is very sluggish. I can usually see the browser status saying something along the lines of "waiting for abcsite.com" then hang, then suddenly the page loads up pretty quickly.

I've done numerous speed tests and they all show pretty good speeds for sustained transfers, also tried different DNS without any luck. Is there anything wrong with the config maybe?

Building configuration...

Current configuration : 7173 bytes
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

hostname sw01
boot system flash
boot system flash c850-advsecurityk9-mz.124-9.T2.bin
boot system flash:c850-advsecurityk9-mz.124-15.T14.bin
logging buffered 51200
logging console informational
aaa new-model
aaa authentication login default local
aaa authentication login userauthen local
aaa authorization console
aaa authorization exec default local
aaa authorization network groupauthor local
aaa session-id common
memory-size iomem 15
clock timezone PCTime 1
crypto pki trustpoint TP-self-signed-3743990007
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3743990007
 revocation-check none
 rsakeypair TP-self-signed-3743990007
crypto pki certificate chain TP-self-signed-3743990007
 certificate self-signed 01
  30820255 308201BE A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  1FA06ABA 89103F2C 3F43560A DDB78D5B 0EB306F8 38C8E37A 66F0E437 6CC71C5E
  E965D121 B37575DC E27A79B7 2EF46B98 0939485A ED762245 B7
dot11 syslog
no ip source-route
ip cef
ip inspect udp idle-time 1800
ip inspect dns-timeout 7
ip inspect tcp idle-time 14400
ip inspect name ADMIN tcp
ip inspect name ADMIN udp
ip inspect name ADMIN ftp
ip inspect name ADMIN smtp
ip inspect name ADMIN icmp
ip inspect name FW tcp
ip inspect name FW udp
ip inspect name FW icmp
ip inspect name FW smtp
no ip bootp server
ip domain name something.local
ip name-server
username ::snip::
crypto isakmp policy 10
 encr 3des
 authentication pre-share
 group 2
crypto isakmp keepalive 30 5
crypto isakmp nat keepalive 20
crypto isakmp client configuration group vpnclient
 pool vpnclientpool
 acl 175
crypto ipsec transform-set strong esp-3des esp-md5-hmac
crypto ipsec transform-set stronger esp-3des esp-sha-hmac
crypto dynamic-map vpnclient 10
 set transform-set stronger
 match address 176
crypto map VPNmap client authentication list userauthen
crypto map VPNmap isakmp authorization list groupauthor
crypto map VPNmap client configuration address respond
crypto map VPNmap 10 ipsec-isakmp dynamic vpnclient
 log config
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
interface FastEthernet0
 no cdp enable
interface FastEthernet1
 no cdp enable
interface FastEthernet2
 no cdp enable
interface FastEthernet3
 no cdp enable
interface FastEthernet4
 no ip address
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1350
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1395
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
interface Vlan1
 description LAN
 ip address
 ip access-group fraAdmin in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1392
 ip inspect ADMIN in
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1352
interface Dialer0
 description TELENOR ADSL
 ip address negotiated
 ip access-group fraInternet in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1392
 ip inspect FW in
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1352
 dialer pool 1
 dialer-group 1
 keepalive 9
 no cdp enable
 ppp authentication pap callin
 crypto map VPNmap
ip local pool vpnclientpool
ip forward-protocol nd
ip route Dialer0
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip nat inside source list NATliste interface Dialer0 overload
ip access-list extended NATliste
 deny   ip
 permit ip any
ip access-list extended alterlov
 permit ip any any
ip access-list extended fraAdmin
 remark DHCP
 permit udp any eq bootpc any eq bootps
 permit udp any eq bootpc any eq bootpc
 remark tillater alt annet
 permit ip any
 deny   ip any any log
ip access-list extended fraInternet
 permit icmp any any
 remark PING
 permit icmp any any echo-reply
 permit icmp any any host-unreachable
 permit icmp any any host-unknown
 remark VPN
 permit esp any any
 permit ahp any any
 permit udp any any eq isakmp
 permit udp any any eq non500-isakmp
 permit ip
 remark Vedlikehold fra Allianse
 remark Mail inn
 permit tcp any host eq smtp
 remark Tillater icmp til offentlig ip
 remark Nekter RFC 1918 adresser
 deny   ip any
 deny   ip any
 deny   ip any
 deny   ip any
 deny   ip host any
 deny   ip any any log
logging trap debugging
access-list 175 permit ip
access-list 176 permit ip any
no cdp run
bridge 1 protocol ieee
banner login ^CCCC
Authorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!
Please leave, restricted area!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 transport input telnet ssh
scheduler max-task-time 5000

Avatar of cstosgale
cstosgaleFlag of United Kingdom of Great Britain and Northern Ireland image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

This problem has been solved!
Unlock 1 Answer and 8 Comments.
See Answers