• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1831
  • Last Modified:

can't start apache in centos 5.x

Hi,

I can't start apache on my centos 5.x Here's the error I receive:
[root@seokingdomheaven vkimura]# /etc/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 187 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_rewrite.so into server: /etc/httpd/modules/mod_rewrite.so: undefined symbol: ap_get_server_banner
                                                       
0
Victor Kimura
Asked:
Victor Kimura
  • 9
  • 5
  • 3
  • +1
3 Solutions
 
darren-w-Commented:
are you sure you have super user access?
0
 
darren-w-Commented:
Looking at your error again, it looks like mod_rewrite.so has an error, has it been modified recently?
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
No, mod_rewrite.so hasn't been modified.

I have su access. It's at root with these commands.

I think the problem lies in that when I compiled apache I didn't use the default centos install paths. It was based on a one of the recommendations of an expert here. I think that's why but how do I figure this out?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
balasundaram_sCommented:
Did you upgrade Apache?  What version of Apache running?  
Is this first time, Apache being compiled and made run on this server?

'ap_get_server_banner" is not available until httpd version 2.2.4.


0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
[root@seokingdomheaven vkimura]# httpd -v
Server version: Apache/2.2.3
Server built:   Nov 12 2009 18:43:41

This is where httpd is located:
[root@seokingdomheaven vkimura]# which httpd
/usr/sbin/httpd
0
 
balasundaram_sCommented:
Is it possible to upgrade to 2.2.4?  
I dont have any other option to resolve this issue, except upgrade.
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
Do you know if /usr/sbin/httpd is the default location?

How do I upgrade to 2.2.4? What are the commands? Sorry, newbie questions but I don't use my centos often. I forget the commands.
0
 
darren-w-Commented:
yum update mysql-server
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
httpd restart is still failing. Any ideas?
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
How can I upgrade from 2.2.3. to 2.2.4? I don't know if that will resolve the problem though.
0
 
balasundaram_sCommented:
Look at the section "Upgrading of Apache 2.2.3 to Apache 2.2.4"  in the below link:

http://www.freelinuxtutorials.com/tutorials/centos-lamp-installation/

or You may download the source and compile it.
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
I can't find:
3.    Download httpd-2.2.4-4.x86_64.rpm from http://rpmfind.net/
4.    Download httpd-devel-2.2.4-4.x86_64.rpm from http://rpmfind.net/
5.    Download lib64db4.5-4.5.20-1mdv2007.1.x86_64.rpm http://rpmfind.net/
6.    Install lib64db4.5-4.5.20-1mdv2007.1.x86_64.rpm

on
http://rpmfind.net/linux/rpm2html/search.php?query=apache&submit=Search+...&system=&arch=

I tried searching by 'apache' and 'httpd' but I can't find them. I tried even searching for them via google but still no luck. I'd like to try and avoid compiling for time's sake. Aren't there dependencies that I may miss if I compile from source?

If you have a direct page that would so helpful to me. =)
0
 
darren-w-Commented:
Hi,

Can I assume that you have tried running "sudo yum update mysql-server" on the command line? In order to get the system to automatically upgrade the apache?

Darren
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
Hi darren-w,

I tried that. I still can't restart httpd.
[root@seokingdomheaven vkimura]# /etc/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 187 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_rewrite.so into server: /etc/httpd/modules/mod_rewrite.so: undefined symbol: ap_get_server_banner
                                                           [FAILED]
[root@seokingdomheaven vkimura]#

That didn't update apache:
[root@seokingdomheaven vkimura]# httpd -v
Server version: Apache/2.2.3
Server built:   Nov 12 2009 18:43:41

Do you know where I can find the latest rpm for httpd?
0
 
SimonDardCommented:
To summarize, you downloaded the source code of Apache, compiled it, installed it and now (re)starting Apache ends prematurely in an error stating there's something wrong with mod_rewrite.so

Apparently, the newer compiled Apache is trying to load a version of mod_rewrite.so which is incompatible with it. I can think of 2 causes:
1. During compiling mod_rewrite was not built and therefore not replaced. Soluation: when configuring Apache before compiling (./configure before make), you need to add the right flag for adding mod_rewrite (and any other mod for that mather).
2. mod_rewrite was built, but got placed in another location. Solution: use (s)locate to scan your drive(s) for mod_rewrite and replace the failing mod_rewrite with the newer one.

0
 
darren-w-Commented:
0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
I have this:
[vkimura@seokingdomheaven ~]$ locate httpd.conf
/etc/httpd/conf/httpd.conf
/etc/httpd/conf/httpd.conf.save
/etc/httpd/conf/original/httpd.conf
/etc/sysconfig/ha/conf/httpd.conf
/home/vkimura/.kde/share/apps/RecentDocuments/httpd.conf.desktop
/home/vkimura/httpd-2.2.14/docs/conf/httpd.conf
/home/vkimura/httpd-2.2.14/docs/conf/httpd.conf.in
/usr/local/apache/conf/.httpd.conf.swp
/usr/local/apache/conf/httpd.conf
/usr/local/apache/conf/httpd.conf.bak
/usr/local/apache/conf/httpd.conf.txt
/usr/local/apache/conf/original/httpd.conf
/usr/share/system-config-httpd/httpd.conf.xsl

The one I compiled is located here:
/usr/local/apache/conf/httpd.conf

so I found out that for me to start it I had to run this:
/usr/local/apache/bin/httpd -k start



0
 
Victor KimuraSEO, Web DeveloperAuthor Commented:
Thank you all for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 5
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now