Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Shortcut to Remote Desktops

Posted on 2010-11-10
13
876 Views
Last Modified: 2012-05-10
I have multiple users connecting to the same server via Remote Desktop.  I want to setup shortcuts or RDP files so I can allow each user to simply click on the shortcut or open the RDP file and logon without having to reenter UN and PW each time.  

Each time I save the RDP file it works. After repeating this for each user I have 5 RDP files each named User1.rdp, user2.rdp, etc.

However, now when I open user1.rdp it has the details from user5.rdp which is the last one I setup.  Every time, it changes all the rdp file to the last one I saved.

Please help.
0
Comment
Question by:deming
  • 5
  • 5
  • 2
  • +1
13 Comments
 
LVL 7

Expert Comment

by:compaqus
ID: 34103926
Just do a shortcut to mstsc.exe with the following:
%windir%\system32\MSTSC.exe -v server_name_or_IP
0
 
LVL 2

Expert Comment

by:SeanMN
ID: 34103943
http://www.mremoteng.org/

Wins the award for remote connection management. I can't reproduce your issue at all with .rdp files. Got 5 to work fine. I doubt your hitting save instead of save as or something easy?
0
 
LVL 7

Expert Comment

by:compaqus
ID: 34103953
Oh, you said no username and pass... :)
my mistake
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 8

Expert Comment

by:ShareefHuddle
ID: 34104071
Save as :)
0
 

Author Comment

by:deming
ID: 34104595
These are the steps that I am doing which do not work:
1. Close all RDP sessions.
2. Run Remote Desktop
3. Enter the IP address in Computer field
4. Click Edit, and "Use another account"
5. Uncheck "Always ask for credentials"
5. Enter the UN and Password, click OK
6. Click "Save As"  filename "Admin1.rdp"
7. Click "connect" and it works.
8. Close RDP session.
9. Double click on the Admin1.rdp file  to open and it connects correctly.
10. Repeat steps 1 thru 8 for "user2.rdp"
11. Now double click on the "user2.rdp" file to open and it connects correctly.
* * * PROBLEM HERE
12. Now close all sessions and double click on "Admin1.rdp" and it opens the "user2" session.
0
 
LVL 2

Expert Comment

by:SeanMN
ID: 34105073
But your connected to the same host right? Are the file details actually changed or is it just using incorrect credentials?
0
 

Author Comment

by:deming
ID: 34105557
I am doing this all from a single computer and all users are same IP to the server.  Here is a rdp file that works but I don't see any UN or PW

screen mode id:i:1
desktopwidth:i:1024
desktopheight:i:768
session bpp:i:32
winposstr:s:0,1,683,216,1723,1022
compression:i:1
keyboardhook:i:2
displayconnectionbar:i:1
disable wallpaper:i:1
disable full window drag:i:1
allow desktop composition:i:0
allow font smoothing:i:0
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:removed by me
audiomode:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:1
drivestoredirect:s:*
use multimon:i:0
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:2
redirectdirectx:i:1
use redirection server name:i:0

Open in new window

0
 
LVL 2

Expert Comment

by:SeanMN
ID: 34105704
You do have prompt credentials once and save enabled. This mean it is more than likley saving your last known credentials to default.rdp and then using those automatically.

Do you have RDP 6 installed?

If so, I'm betting you need to check allow me to save credentials.
0
 

Author Comment

by:deming
ID: 34106033
I just tried what you suggested and no luck. It is doing the same problem of overwriting the previous profile. I can only get one to work and not two or more.
0
 

Author Comment

by:deming
ID: 34106065
I'm thinking you can only save a single set of credentials per Computer (IP address). I need five different logon credentials for the same IP address from the same local computer.
0
 
LVL 2

Expert Comment

by:SeanMN
ID: 34106177
Well there isn't any user data in there, so it isn't getting saved, for example my working ones look like attached.

Honestly If you can install software for these people i would just use my originally linked http://www.mremoteng.org/

You can use pre-configured conf files then. I use it for the 50+ boxes i connect to with multiple accounts and settings, its far easier and more reliable then creating custom files.

I've never got rdp save credentials to work 100% of the time. Still randomly prompts password or doesn't fill right, mremote hasn't failed me yet.

Your steps you took to configure settings makes me think you are using an older rdp client. Does it look like this?


screen mode id:i:2
desktopwidth:i:1920
desktopheight:i:1200
session bpp:i:16
winposstr:s:0,1,219,0,1345,1016
compression:i:1
keyboardhook:i:2
displayconnectionbar:i:1
disable wallpaper:i:1
disable full window drag:i:0
allow desktop composition:i:1
allow font smoothing:i:0
disable menu anims:i:0
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:hqfakeserver03
audiomode:i:1
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
drivestoredirect:s:F:;
autoreconnection enabled:i:1
authentication level:i:0
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:0
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:1
username:s:notmyrealdomain\fakeusername

Open in new window

rdp.bmp
0
 
LVL 2

Accepted Solution

by:
SeanMN earned 500 total points
ID: 34106194
Given what you need to do, mremote meets your needs far better then shortcuts.... and free is nice.
0
 

Author Closing Comment

by:deming
ID: 34107312
The mRemoteNG program works great!
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…

861 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question