• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1472
  • Last Modified:

Troubleshooting .NET Framework Targeting Errors

Hi My site was working http://www.unesco.ca and now is not working after I did the following in my Visual Studio 2010

The Web project ‘ftp://ftp.unesco.ca ’ is targeting “.netframework, version =v2.0’, which is not installed on this machince. You must download this framework, as well as .net framework 3.5, in order to open and build this project. In order to proceed, you must select an option below

( x) retarget the project to .net framework 4. After the project opens, you can retarget it to another framework or profile.
(  ) take me to the framework download web site
( ) leave the project as unloaded.

[ ] Do not ask me again during this operation.

I've chooose X Retarget... So now it's now working and it giving me the following errors How I can fixed back to 2.0

 Please advice...

http://www.unesco.ca


=================================

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'targetFramework'.

Source Error:


Line 12:           debugging ASP.NET files.
Line 13:     -->
Line 14:             <compilation defaultLanguage="vb" debug="true" targetFramework="4.0"/>
Line 15:             <!--  CUSTOM ERROR MESSAGES
Line 16:           Set customErrors mode="On" or "RemoteOnly" to enable custom error messages, "Off" to disable.
 

Source File: E:\inetpub\wwwroot\UNESCO\web.config    Line: 14
0
elieazzi
Asked:
elieazzi
  • 7
  • 2
1 Solution
 
elieazziAuthor Commented:
This my web.config file.



<?xml version="1.0"?>
<configuration>
	<appSettings>
		<add key="XmlFilePath" value="./menu.xml"/>
	</appSettings>
	<system.web>
		<!--  DYNAMIC DEBUG COMPILATION
          Set compilation debug="true" to insert debugging symbols (.pdb information)
          into the compiled page. Because this creates a larger file that executes
          more slowly, you should set this value to true only when debugging and to
          false at all other times. For more information, refer to the documentation about
          debugging ASP.NET files.
    -->
		<compilation defaultLanguage="vb" debug="true" targetFramework="4.0"/>
		<!--  CUSTOM ERROR MESSAGES
          Set customErrors mode="On" or "RemoteOnly" to enable custom error messages, "Off" to disable. 
          Add <error> tags for each of the errors you want to handle.
    -->
		<customErrors mode="Off"/>
		<!--  AUTHENTICATION 
          This section sets the authentication policies of the application. Possible modes are "Windows", 
          "Forms", "Passport" and "None"
    -->
		<authentication mode="None"/>
		<!--  AUTHORIZATION 
          This section sets the authorization policies of the application. You can allow or deny access
          to application resources by user or role. Wildcards: "*" mean everyone, "?" means anonymous 
          (unauthenticated) users.
    -->
		<authorization>
			<allow users="*"/>
			<!-- Allow all users -->
			<!--  <allow     users="[comma separated list of users]"
                             roles="[comma separated list of roles]"/>
                  <deny      users="[comma separated list of users]"
                             roles="[comma separated list of roles]"/>
            -->
		</authorization>
		<!--  APPLICATION-LEVEL TRACE LOGGING
          Application-level tracing enables trace log output for every page within an application. 
          Set trace enabled="true" to enable application trace logging.  If pageOutput="true", the
          trace information will be displayed at the bottom of each page.  Otherwise, you can view the 
          application trace log by browsing the "trace.axd" page from your web application
          root. 
    -->
		<trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true"/>
		<!--  SESSION STATE SETTINGS
          By default ASP.NET uses cookies to identify which requests belong to a particular session. 
          If cookies are not available, a session can be tracked by adding a session identifier to the URL. 
          To disable cookies, set sessionState cookieless="true".
    -->
		<sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="data source=127.0.0.1;user id=sa;password=" cookieless="false" timeout="20"/>
		<!--  GLOBALIZATION
          This section sets the globalization settings of the application. 
    -->
		<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
		<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/></system.web>
</configuration>

Open in new window

0
 
Daniel Van Der WerkenIndependent ConsultantCommented:
Change this line:
<compilation defaultLanguage="vb" debug="true" targetFramework="4.0"/>

to this:

<compilation defaultLanguage="vb" debug="true" />
0
 
elieazziAuthor Commented:
I've chagned now i'm having this error

Line 56:     -->
Line 57:             <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
Line 58:             <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/></system.web>
Line 59: </configuration>
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
elieazziAuthor Commented:
i did it but i'm having the following errors
Line 56:     -->
Line 57: 		<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
Line 58: 		<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/></system.web>
Line 59: </configuration>

Open in new window

0
 
elieazziAuthor Commented:
are u there ?
0
 
elieazziAuthor Commented:
As a I  try, right click your website >> Property Pages >> Build >> change "Target Framework" to .NET Framework 4.0

I only see 4.0 I'm not able to see 2.0 or 3.5 Any solutions?
0
 
elieazziAuthor Commented:
Hi Dan,

I've removed the following code.


Line 58:             <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>

What this mean ? Now it's working please advice....
<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
		</system.web>

Open in new window

0
 
elieazziAuthor Commented:
Please answer my comments. thank you for your time.
0
 
Daniel Van Der WerkenIndependent ConsultantCommented:
Sorry.  Took Veteran's Day off.
When you target 3.5 or above, it puts a bunch of stuff in the Web.config.  As a result, you will not be able to use that very web.config for 2.0 builds.  

One thing you might want to do is clear out the web.config of anything that refers to 3.5 or as another possibility, create a blank project with 2.0 as the target and use that web.config as a model for the web.config you need.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now