PRIMARY filegroup is full SQL Server 2005

Hi

This is an error message in my prod environment.  
Can somebody give me the steps to resolving the following problem?


Executed as user: NT AUTHORITY\SYSTEM.
Could not allocate space for object 'dbo.ePetlm_Index' in database 'MCS'
because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup. [SQLSTATE 42000] (Error 1105).  The step failed


thanks
FavorableAsked:
Who is Participating?
 
DFW_EdConnect With a Mentor Commented:
What disk space is left or available where it resides?
If none, is it virtual so you can easily add more or is it a physical drive?  
How big is the filegroup?  (to determine length and difficulty of potentially moving)
Are there log files shared on that drive that can be easily backed up, truncated and even better moved?
0
 
Philippe DamervalConnect With a Mentor Senior Analyst ProgrammerCommented:
Hi,
I'm assuming you checked the obvious, such as whether your server is out of disk space?
Please review the following link for information on file groups:
http://msdn.microsoft.com/en-us/library/ms179316.aspx

Meanwhile, if the error is not a result of lack of physical disk space, then it would seem you need to create a new filegroup or allow your file group to grow automatically. This is described on the following section:
http://technet.microsoft.com/en-us/library/bb522469.aspx

Generally, run an ALTER DATABASE statement either specifying a new file that auto-grows or adding a new filegorup containing a file that auto-grows. Remember, a filegroup does not really exist - it is a logical object created purely to help compartmentalize the way your database is stored physically. In the end your database is stored on individual files, primary and secondary data files as well as log files. You choose where you want to store your tables physically when you define your tables (and other objects). It is very useful to plan for this when you need to grow your database, for instance, you want want to put large tables in one place and tables that are accessed very often for micro-results in another, thus achieving better management of your I/O, which typically is the bottleneck on a database server.

Thx,

Philippe
0
 
FavorableAuthor Commented:
Was resolved by disabled the auto growth for few seconds and enabled after few seconds.
0
 
FavorableAuthor Commented:
Nice comments
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.