Solved

Connecting Two Wireless Routers

Posted on 2010-11-10
43
1,657 Views
Last Modified: 2012-08-13
The scenario is really simple. I am currently having one adsl router which is Aztech ADSL2+ Wireless 4-Port Router by my ISP (Etisalat) which is having AR7WRD Firmware and another one is a wireless Bubble Gini Router which is having firmware similar to DDR-WRT. Now i tried to make my Gini as CLIENT BRIDGE and configured with the same wireless encryption as my main Aztec router disabling dhcp server on Gini. But i don't know where am i going wrong and i am still not able to make a connection between two wireless routers. Do i have to make any settings in my main wireless router as well ?

The purpose of connecting two wireless router is because i am having my main router outside my room and i have got a voip device where i need to connect it through the internet and i cannot pull the cable till my room from the main router. So i was wondering if i can get the dhcp by another wireless router and connect my voip device and other devices on cable
0
Comment
Question by:ibrahim52
  • 30
  • 10
  • +2
43 Comments
 
LVL 2

Expert Comment

by:dannyyo
ID: 34105095
You shouldn't have to make changes on the main router.  Your Client Bridge setting is right.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34105163
Exactly but thats what, why it is not responding ?
0
 
LVL 10

Expert Comment

by:Wolfhere
ID: 34105885
Is there a setting on the Aztec to accept bridge connections? Page 44 (4.5.22) for this manual - ftp://ftp.aztech.com/support/singapore/ADSL/DSL600EW%20User%20Manual%20v1.0.pdf . You have to enable bridge filters under Advanced > Mac Filtering
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34109564
Besides enabling it ,do i have to insert any MAC for source and destination ?
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34109840
Now however according to the WIRELESS STATUS page my client wireless router is able to communicate with the aztech gateway router. But unfortunately i am still not able to have DHCP when i plugging in cable to my laptop from gini LAN port.So for that purpose i have posted some screenshots of the configurations i did. One doubt what i am having is on Advanced Routing, earlier it was on RIP2 router but i switched it to GATEWAY and in DHCP options i am having one more option as DHCP forwarder , i tried that as well but did not worked.
Advanced-Routing.png
Network-setup.png
Wireless-security.png
Wireless-Setup.png
Wireless-Status.png
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34109901
I would like to add one more thing that my main gateway router IP is 192.168.1.1 and i have changed my client wireless router as 192.168.1.100 (please check screenshot)
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34122120
Alright i tried to change the Advanced Routing interface to ROUTER but now the only issue is that i am not able to have DHCP from the main gateway router.
0
 
LVL 22

Expert Comment

by:rickhobbs
ID: 34126072
So define a different DHCP on the second router.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34126885
But the DHCP has to be disabled if i am using the Standard bridging system and yeah i have tried keeping a manual IP in my laptop but it is not able to ping the main gateway router also.It is just showing till the WIRELESS status page of my second router as shown in the screen shot.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34127532
In the gini, on the Network Setup page (http://filedb.experts-exchange.com/incoming/2010/11_w46/368404/Network-setup.png ), what other choices for DHCP Type do you have?

That appears to be a picklist arrow next to "DHCP Server" - in DD-WRT's firmware, what you would choose in this situation is "DHCP Forwarder" instead of DHCP Server.  So look for something similar in that picklist (then change its radio button back to Enable after making the change to the picklist).
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34127788
Yeah it is DHCP forwarder and i even had tried it , i dont remember but i will try it one more time.I didn't get your line (then change...)
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34127936
I am seriously not getting,where am i going wrong. I have even start a discussion in DDWRT forums and they suggested me to change the routing to ROUTER, i even did that but just not getting why it is happening. I tried setting up manual ip address but i am not able to ping the main router. So something is there i need to rectify.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34127975
Seriously i am pulling my hairs now, i tried every possibilities i could. I am not able to ping down the main router even if i set my laptop ip address to static, something is wrong and i am really not getting what, as the LED of WLAN on my router blinks really fast and even in WIRELESS status page it shows that it is connected but why it is not able to recieve the DHCP from main gateway router. I am posting one more screenshot of the options available below the ROUTER option in ADVANCED ROUTING page. Thank you

Note:
Under Dynamic Routing ---> Interface options are
1.Wan
2. LAN & WAN
3. Both






fedup.png
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34127978
@rickhobbs, Enabling DHCP on standard bridging will not work.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34128218
> I didn't get your line (then change...)



My bad... switch the radio button it to Enable, then choose DHCP Forwader from the picklist and Save Settings.

Even though the enable/disable disappears when DHCP Forwarder is chosen, I don't know for sure that enabling the DHCP Server section first doesn't make a difference.

Anyway, having DHCP Forwarder enabled should allow BOOTP messages to pass in both directions, which normally a router will block.


What firmware are you using in the gini, by the way?
In DD-WRT, there is a setting in Wireless->Basic Settings to break the link between its wired and wireless sections... (see attached) - is there a setting like that in the firmware you're using?
Wireless-Wired-Bridged.png
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34128307
Yes it is exactly the same and it is on BRIDGED only.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34128327
Alright so according to the DD WRT forums they have asked me to follow the guide posted in the link below.I am going to reset my secondary router and try it one more time following the exact step posted.Wish me luck. Thank you.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34128454
Since the WAN port is assigned to the switch, apparently the Connection Type in WAN Setup is 'Disabled' - right?


You should install Wireshark, set its Display filter (on the Analyze menu) to BOOTP (at the bottom of the default filters), and start it watching on whatever network interface you're using. If which one to use isn't clear, open Capture->Interfaces dialog and watch which interface is rolling up numbers under Packets and Packets per sec.

Anyway... with the BOOTP filter set, you should see 5 steps in the DHCP process...
1) the request from 0.0.0.0 for active DHCP servers
2) the reply from the DHCP server's IP with an offer of an address
3) The acceptance of the addresses offered, from 0.0.0.0
4) an Ack from the DHCP server
5) an Ack from the requester with its new IP address as the Source and the IP of the DHCP server as destination.

There are other steps in there, like the DHCP Server checking that the address it wants to assign is not already in use, and the client checking the same thing before it starts using its new IP, but those can't be seen with the BOOTP filter on.

Still, watch it from the Bubble Gini and while connected to the Aztech. Note which of those 5 steps are missing, and from where it looks like they're missing.

I don't find Coral Maksat on the supported list at DD-WRT, but I have to think the Bubble Gini could run DD-WRT, given the similarities between the screen grabs you've posted and DD-WRT's interface.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34128581
I am sorry but i dont see BOOTP in Analyze--->Display Filters
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34128664
Oh sorry for that i should have read your reply properly, i tried again and i got this results. Please check the attachment.
results.png
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34128684
It should be all the way at the bottom.
See attached.
I don't remember making it custom, but if I did the expression to duplicate it is shown in the grab, too.
Wireshark-DisplayFilter-BOOTP.png
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 44

Expert Comment

by:Darr247
ID: 34128698
If your 'results' cap is taken while connected to the Bubble Gini, then no reply from a DHCP server is ever showing up.

Now watch from the Aztech side while a request is being made through the Gini and see if that discovery packet is making it through the bridge.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34128717
Alright what i noticed in the STATUS page of my gini under the results of ROUTER page was the ACTIVE CONNECTION link which showed me quite this kind of results where 192.168.1.1(primary router) showing timed out.
resul2.png
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34146272
Apart from client bridge is there any other way i can connect this router, as a repeater or something ?
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34146282
Because if i check the connected clients status page of aztech,it shows that my secondary (client bridge) router is connected.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34146599
I have even tried disabling the firewall in Aztech which was quite unnecessary but still it is the same.Everything is perfect according to the status results on both sides, the only thing is i am not able to recieve the DHCP. Which makes me to doubt on only one thing which is the ADVANCED ROUTING page of bubble gini.any ideas ?
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34148429
What does the DHCP request look like in Wireshark when you watch it from a computer connected to the Aztech?

If it's not appearing from there, then it sounds like the Aztech is blocking BOOTP broadcasts through the wireless bridge.

Can you manually assign an IP address (say, 192.168.1.251 / 255.255.255.0) to a computer connected to the Bubble Gini, then ping another computer (turn off both computers' firewalls temporarily) that's connected to the Aztech?
That would confirm if regular IP traffic is getting through and there is just something blocking the BOOTP broadcasts.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34152964
Alright guess, i think GINI is making a request but AZTECH is ignoring it or i dont know what. I am posting the screenshot here.Kindly see it once,thanks.
sc2.png
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34152968
192.168.1.2 is my GINI ip address
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34154762
None of those are BOOTP messages.  Did you try the BOOTP display filter?
After selecting it you must click Apply, also.

Did you try this part:
Can you manually assign an IP address (say, 192.168.1.251 / 255.255.255.0) to a computer connected to the Bubble Gini, then ping another computer (turn off both computers' firewalls temporarily) that's connected to the Aztech?
That would confirm if regular IP traffic is getting through and there is just something blocking the BOOTP broadcasts.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34155053
sure ill try it right now and will get back to you. Thanks
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34155160
Alright i am not getting one thing here whenever i choose the filter and start the CAPTURE button the screen is blank and when i press clear i am having the same results what i posted on my earlier screenshot.

Yeah, i tried your suggestion of disabling the firewall connected to both of my routers and unfortunately it does not ping each other.
bootp.png
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34155178
This is what i am getting when i press CLEAR
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34155186
I am sorry there was some error attaching the image so i am attaching here now
results-2.png
0
 
LVL 44

Accepted Solution

by:
Darr247 earned 500 total points
ID: 34155981
Try it with Encryption disabled on both the Bubble Gini and on the Aztech.

If it works with Encryption disabled,  they are "connecting" (because Authentication is 'Open'), but for some reason the WEP keys the Bubble Gini and the Aztech are each putting in their packets do not not match, so when received the packets are just discarded.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34156407
Experts will be EXPERTS , i should have thought before prolonging the subject. I will try and get back to this topic soonest. thanks
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34159360
As i told you i am currently PLUGGED in through my bubble GINI and i am actually using it through cable but only thing i am upset of is that i cant use it on encryption. But i give one more chance,any idea why it is not ?
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34161597
Did you try entering the key manually on both ends?

By the looks of the screen grab from the bubble gini, it was generated using a passphrase instead of being entered manually.
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34162849
Exactly, THANK YOU very much Darr247, you made my MIND working by your suggestions and points.Now what i really did is that i made a little change in the encryption of my primary router and in the secondary for all the four blanks under the passphrase i used the same password what i have in my primary router.Check the screenshot.

In the end, i am sorry that i took so much of your time and THANKS once again for all your support.
primary-router.png
secondary.png
0
 
LVL 12

Author Closing Comment

by:ibrahim52
ID: 34162853
Thanks for the GENIUS support Dar
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34163171
But still if you can explain why it worked after i used the same password for all the four blanks, please.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 34163348
You should only need a password in the key you're using... it uses only one of the four.
If it doesn't work with the password only in key number 1, try it in key number 4 instead.
I notice the Aztech doesn't have them numbered... so I wonder if it actually has them arranged backwards (with number 4 at the top).
0
 
LVL 12

Author Comment

by:ibrahim52
ID: 34166549
Thanks for the explaination.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now