Solved

Can't run .exe executables

Posted on 2010-11-10
25
680 Views
Last Modified: 2012-05-10
We have an XP Pro laptop that's lost the ability to run .exe's.  It won't run anything in the Run sections of the registry.  It will run Malwarebytes, but nothing is found.  I can access the registry by running Start regedit.com at a command prompt.  I've compared HKCR\exefile, .exe, etc to a working machine and found no differences.  I think I've tried everything at EE under the title of this question and related variations, and I'm stumped.
0
Comment
Question by:lgottlieb45
  • 12
  • 8
  • 2
  • +2
25 Comments
 
LVL 11

Expert Comment

by:David Kroll
ID: 34105908
I assume you've done this:

http://www.dougknox.com/xp/file_assoc.htm

How did you run Malwarebytes if you can't run exe's?
0
 
LVL 10

Expert Comment

by:moon_blue69
ID: 34105972
try restoring to a date when it worked for you before
0
 

Author Comment

by:lgottlieb45
ID: 34106049
dkrollCTN: yes, I was able to successfully import the .exe fix from Doug Knox, but upon reboot the problem persists.  Regarding Malwarebytes, I was able to install it and it ran once as part of the install.  It won't run now either.

moon_blue69: I can't run system restore in normal mode (I get the same error message ("The application failed to initialize properly (0xc0000005)").  I can't log in in safe mode, as none of the passwords that have ever been used on this machine work in safe mode, though they work in normal mode(!)
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34106074
Do the exe fix again, then run ComboFix (http://www.combofix.org/).  ComboFix can be very dangerous if used improperly, so be careful.
0
 

Author Comment

by:lgottlieb45
ID: 34106156
OK, maybe you can clue me into (what is otherwise the mystery to me) of renaming Combofix, which won't run either.  I don't think I understand prevous posts about how to do that.  I tried running Combofix without renaming and get the same error (oxc000007b), whatever that means.
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34106221
some malware can specifically target filenames, such as combofix.exe.  Renaming it to something else, like test.exe, might let it run.
0
 

Author Comment

by:lgottlieb45
ID: 34106264
Nope.
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34106277
If viable, it might be best to wipe and reload the machine.
0
 

Author Comment

by:lgottlieb45
ID: 34106379
Yeah, I figured.  It's just the 4 versions of QuickBooks and 3 of ProSeries that are on the machine (the guy's a CPA... but you probably guessed that).
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34106405
Yeah, that's the last thing I ever want to do, but sometimes it's the only way.  Maybe he'll be a little more careful next time.
0
 

Author Comment

by:lgottlieb45
ID: 34106457
Careful of what?  He's a pretty careful guy...
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34106480
I've seen people I thought were smart do stupid things.  Like one guy who opened the .zip attachment in the email from the USPS because he was expecting a package.  You just never know with some people.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 22

Expert Comment

by:optoma
ID: 34107354
Run exehelper first. Dont reboot if prompted..
http://raktor.net/exeHelper/exeHelper.com

Then run Hitmanpro.exe but rename it to Hitmanpro.com first before launching.
MAy work :)

http://www.surfright.nl/en/hitmanpro
0
 
LVL 47

Expert Comment

by:rpggamergirl
ID: 34107616
Also check this article, If you can't run .exes in an infected system:
http://www.experts-exchange.com/Software/Internet_Email/Anti-Virus/A_1995-CAN'T-RUN-EXES-IN-AN-INFECTED-SYSTEM.html 

If you scroll down EXEHelper is also mentioned in post 17 in ID: 10177
0
 

Author Comment

by:lgottlieb45
ID: 34107686
No luck.  I did as you said, but I still can't run any .exe files, and I have to step through every item in the startup section of msconfig to clear the failed to initialize errors.

I'll wait another day or so to see if any more ideas are forthcoming, and I greatly appreciate all your efforts...
0
 
LVL 47

Expert Comment

by:rpggamergirl
ID: 34107755
Can you run these tools by doubleclicking on their .executables?

TDSSKiller:
http://support.kaspersky.com/downloads/utils/tdsskiller.zip 

ComboFix:
http://www.bleepingcomputer.com/combofix/how-to-use-combofix 
 
HitmanPro:
http://www.surfright.nl/en/hitmanpro 
0
 

Author Comment

by:lgottlieb45
ID: 34107810
Tomorrow...
0
 

Author Comment

by:lgottlieb45
ID: 34113696
rpggamegirl: I successfully ran tdsskiller.  It found nothing.  ComboFix won't run as combofix.exe or .com.  I was also able to run hitmanpro, and it didn't find anything either.

I don't think there's anything running around in this system, or one of these tools would likely have found it.  I think Windows is just broken, though I don't know where, since I've also successfully run the exe-fixers suggested above.
0
 
LVL 22

Expert Comment

by:optoma
ID: 34114223
Longshot but try resetting internet explorer . Use Microsoft fixit .  support.microsoft.com/kb/923737      
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34114242
Have you tried to do a repair install of Windows?  Will the current situation allow that?
0
 

Author Comment

by:lgottlieb45
ID: 34114370
Regarding Microsoft Fix-It, a "cscript.exe failed to initialize" error stopped it cold.

dkrollCTN, please be more specific.  I could start off the Windows CD and reinstall over the current install.  I could do what's described in http://support.microsoft.com/default.aspx?scid=kb;en-us;q307545.
0
 
LVL 11

Expert Comment

by:David Kroll
ID: 34114411
You could try that link, but I was referring to booting from the Windows CD, when the menu comes up, DON'T press R to go to the recovery console.  Choose Install, it should locate your previous version of Windows and give you the option to repair it.  If the previous version doesn't show up, a full install will be the next course of action.
0
 

Author Comment

by:lgottlieb45
ID: 34114434
OK, will do.
0
 

Accepted Solution

by:
lgottlieb45 earned 0 total points
ID: 34116278
I tried the repair as you proposed, and about half way through it collapsed in a seemingly endless cascade of rundll32.exe and regsvr32.exe errors.  Same thing now when it tries to boot.  I think we've reached the end of the line, folks.  Thanks to all!!
0
 

Author Closing Comment

by:lgottlieb45
ID: 34182478
I appreciate all the efforts.  I just erased and started over and all is well.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Disclosure: Use this tutorial only when no other options helps to get Windows XP running without any problems and you don't want to format the drive. The back up of the data is the responsible of the user, however there is a description of how t…
Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Delivering innovative fully-managed cloud services for mission-critical applications requires expertise in multiple areas plus vision and commitment. Meet a few of the people behind the quality services of Concerto.

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now