Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Warnings in Remoteapp for Windows Server 2008  R2

Posted on 2010-11-10
4
Medium Priority
?
620 Views
Last Modified: 2012-06-27
I have configured Remoteapp in windows server 2008 and have it working. I chose the option to deploy the link via an MSI and then ran that MSI on a domain-joined machine.  I get several warnings before opening up the application as shown in the screen shot below:
1. When I first click on the icon, I get the warning stating that the publisher cannot be identified.
2. When I click past #1, I get the prompt for credentials.
3. When I click pass that, I get another warning about verifying the identity of the remote computer.

I want to make sure that none of these ever show up for my organization. The goal is that they click the icon on the desktop and the remote application just opens as would an application installed on the local machine. Having them click past these once or enter credentials once and then using the "never show this again" check box is not an option due to the number of help desk calls it will generate. Also, I can't purchase an additional certificates though I could use one created by my own internal certification authority if that is required.

Can someone please tell me with some step by step instructions to get around this?

Thanks!
 Warning 1 Warning 2 Warning 3
0
Comment
Question by:Julian123
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 29

Expert Comment

by:sammySeltzer
ID: 34106880
I don't know about the credentials but the remote desktop warning seems to be as a result of (this is me thinking) ie8.

All you do is check the box to NOT show the warnings again.

As for the login prompt, how did you set up iis, it seems that you set it with integrated windows authentication.

You may change it to annoymous.

You may also go to internet options, security tab and intranet under Use Credentials and choose the auto logon option.
0
 
LVL 29

Expert Comment

by:sammySeltzer
ID: 34107685
Here is something else you can try.

Assuming that you are on a domain you can install certificates on the terminal servers using self-signed certificates

This link should help.

http://technet.microsoft.com/en-us/library/cc782610(WS.10).aspx
0
 
LVL 12

Accepted Solution

by:
Julian123 earned 0 total points
ID: 34131914
I also needed to configure single sign on and a certificate CA, self signed didn't work.
0
 
LVL 12

Author Closing Comment

by:Julian123
ID: 34171257
This was what worked.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had a question today where the user wanted to know how to delete an SSL Certificate, so I thought that I would quickly add this How to! Article for your reference. WHY WOULD YOU WANT TO DELETE A CERTIFICATE? 1. If an incorrect certificate was …
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question