Solved

Outlook 2010 changing Outlook Anywhere URL

Posted on 2010-11-10
13
3,841 Views
Last Modified: 2012-08-14
I have an issue with all Outlook 2010 clients not able to connect via Outlook Anywhere.  When I check the exchange proxy settings I notice that it keeps changing to the local "internal" hostname.  I'm sure it has something to do with the autodiscovery but I have yet to find the issue.  I'm pretty much chasing my tail at this point.

They are running Exchange 2007 SP3 on Server 2003 R2 SP2.  I have confirmed that:
- outlookanywhere has been enabled
- recreated the virtual directories
- reinstalled UCC certificate
- get-clientaccessserver shows the autodiscoverserviceinteraluri = https://mail.domain.com/autodiscover/autodiscover.xml

But when I run test-outlookwebservices | fl I get the attached errors:

 test-outlookwebservices error
Can someone please help point out what I'm missing?  Thanks.
0
Comment
Question by:french44
13 Comments
 
LVL 6

Expert Comment

by:expone
ID: 34108589
Have you opened port 443 on the firewall and redirected to the Exchange server IP address?
0
 
LVL 49

Accepted Solution

by:
Akhater earned 500 total points
ID: 34109024
1. Go to testexchangeconnectivity.com and run an outlook anywhere test and share the results
2. autodiscovery url is well https://mail.domain.com/autodiscover/autodiscover.xml if i refer to your screenshot is this URL reachable from outside?
3. issue a get-outlookprovider do you see the internal hostname anywhere ? if yes remove it by running

set-outlookprovider expr -server $null
or
set-outlookprovider exch -server $null

depending on the internal name if it was in the expr or exch field

0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34109511
Where are these clients? Are they on the LAN? Or are you testing from the Internet?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:french44
ID: 34111877
Thanks for the help.

- Port 443 is open and directed to the exchange server.

- The clients work fine when on the LAN but the clients outside of the LAN is the ones I'm having issues with.  I am testing from the internet.

- Here are the results from testexchangeconnectivity.com:

Testing RPC/HTTP connectivity.
       The RPC/HTTP test failed.
       
      Test Steps
       
      ExRCA is attempting to test Autodiscover for pgrunloh@akrabuilders.com.
       Autodiscover was tested successfully.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service was tested successfully.
       
      Test Steps
       
      Attempting to test potential Autodiscover URL https://akrabuilders.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
       
      Attempting to resolve the host name akrabuilders.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 208.109.14.128
      Testing TCP port 443 on host akrabuilders.com to ensure it's listening and open.
       The specified port is either blocked, not listening, or not producing the expected response.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       A network error occurred while communicating with the remote host.
Exception details:
Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 208.109.14.128:443
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()
      Attempting to test potential Autodiscover URL https://autodiscover.akrabuilders.com/AutoDiscover/AutoDiscover.xml
       Testing of the Autodiscover URL was successful.
       
      Test Steps
       
      Attempting to resolve the host name autodiscover.akrabuilders.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 74.40.169.185
      Testing TCP port 443 on host autodiscover.akrabuilders.com to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Test Steps
       
      Validating the certificate name.
       The certificate name was validated successfully.
       
      Additional Details
       Host name autodiscover.akrabuilders.com was found in the Certificate Subject Alternative Name entry.
      Certificate trust is being validated.
       The test passed with some warnings encountered. Please expand the additional details.
       
      Additional Details
       ExRCA can only validate the certificate chain using the Root Certificate Update functionality from Windows Update. Your certificate may not be trusted on Windows if the "Update Root Certificates" feature isn't enabled.
      Testing the certificate date to confirm the certificate is valid.
       Date validation passed. The certificate hasn't expired.
       
      Additional Details
       The certificate is valid. NotBefore = 11/8/2010 6:38:04 PM, NotAfter = 6/18/2011 1:22:03 PM
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
       Accept/Require Client Certificates isn't configured.
      Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
       ExRCA successfully retrieved Autodiscover settings by sending an Autodiscover POST.
       
      Test Steps
       
      ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.akrabuilders.com/AutoDiscover/AutoDiscover.xml for user pgrunloh@akrabuilders.com.
       The Autodiscover XML response was successfully retrieved.
       
      Additional Details
       Autodiscover Account Settings
XML response:
<?xml version="1.0"?>
<Autodiscover xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
<User>
<DisplayName>Paul Grunloh</DisplayName>
<LegacyDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=pgrunloh1</LegacyDN>
<DeploymentId>df6e14f7-3361-4faf-a88c-1d605805a199</DeploymentId>
</User>
<Account>
<AccountType>email</AccountType>
<Action>settings</Action>
<Protocol>
<Type>EXCH</Type>
<Server>mailserver.akrabuilders.com</Server>
<ServerDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=MAILSERVER</ServerDN>
<ServerVersion>72038053</ServerVersion>
<MdbDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=MAILSERVER/cn=Microsoft Private MDB</MdbDN>
<ASUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</ASUrl>
<OOFUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</OOFUrl>
<OABUrl>https://mail.akrabuilders.com/OAB/c43ba2ab-6a46-43d8-a542-290792cad341/</OABUrl>
<UMUrl>https://mailserver.akrabuilders.com/UnifiedMessaging/Service.asmx</UMUrl>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<PublicFolderServer>mailserver.akrabuilders.com</PublicFolderServer>
<AD>mailserver.akrabuilders.com</AD>
<EwsUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</EwsUrl>
</Protocol>
<Protocol>
<Type>EXPR</Type>
<Server>mailserver</Server>
<ASUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</ASUrl>
<OOFUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</OOFUrl>
<OABUrl>https://mail.akrabuilders.com/OAB/c43ba2ab-6a46-43d8-a542-290792cad341/</OABUrl>
<UMUrl>https://mail.akrabuilders.com/UnifiedMessaging/Services.asmx</UMUrl>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<EwsUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</EwsUrl>
</Protocol>
<Protocol>
<Type>WEB</Type>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<External>
<OWAUrl AuthenticationMethod="Fba">http://mail.akrabuilders.com/owa</OWAUrl>
<OWAUrl AuthenticationMethod="Fba">https://externalurl/owa</OWAUrl>
<Protocol>
<Type>EXPR</Type>
<ASUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</ASUrl>
</Protocol>
</External>
<Internal>
<OWAUrl AuthenticationMethod="Basic, Fba">https://internalurl/owa</OWAUrl>
<Protocol>
<Type>EXCH</Type>
<ASUrl>https://mail.akrabuilders.com/EWS/Exchange.asmx</ASUrl>
</Protocol>
</Internal>
</Protocol>
</Account>
</Response>
</Autodiscover>
      Autodiscover settings for Outlook Anywhere are being validated.
       ExRCA wasn't able to validate Outlook Anywhere Autodiscover settings.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       The AuthPackage wasn't specified in the EXPR section of the Autodiscover response.



When I check the https://autodiscover.akrabuilders.com/autodiscover/autodiscover.xml and login I get:

  <?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="08:34:06.0300874" Id="2608404402">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>


When running get-outlookprovider I do see my internal hostname on both EXCH, EXPR and WEB.

Should I make that null?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34111971
yes set them to null all 3 wait and then test again and see if it will change it once more
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34111990
following your testexchangeconnectivity results all is working fine. do set outlookprovider to null in all 3

0
 

Author Comment

by:french44
ID: 34112057
How long does it generally take for the changes to occur?  Do I need to run an iisreset or anything?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34112070
it really depends on how big your environment is how many domain controllers do you have

15 min or so...

test the test-outlookwebservices | fl  again is it still giving the interal url?
0
 

Author Comment

by:french44
ID: 34112162
After running test-outlookwebservices | fl I get the same results as the first post's screen shot that was attached.

When the internal hostname has been entered into the proxy settings do I have to manually change it to the external for the client's outlook to connect for the new settings, or will it change automatically?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34112182
if you still see the internal url then you should wait a bit more

0
 

Author Comment

by:french44
ID: 34112187
After changing the proxy settings manually so far it hasn't changed it back to the local hostname.  I'll continue to monitor.

With the outlook provider being set to null, where is it actually pulling the external url from?

Thanks for the help.  Feels like we're getting somewhere.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 34112233
yes now the proxy settings will not change again and new clients should take the new one

it is still pulling it from AD but it is pulling the correct one now

if you want to force it you can set it again to mail.mydomain.com (or whatever external url you have)

set-outlookprovider EXCH -server mail.mydomain.com

this should force the switch
0
 

Author Comment

by:french44
ID: 34112260
I think that has fixed the issue.  No changes thus far.  Thanks a lot!!
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
In-place Upgrading Dirsync to Azure AD Connect
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question